probleme exportation STL 3D

Voir le sujet précédent Voir le sujet suivant Aller en bas

probleme exportation STL 3D

Message  seb18 le Mer 14 Oct 2015 - 17:37


Bonjour,

J ai realise une piece simple sur freecad, un cylindre avec une depouille et une poche, je l ai enregistré en format stl, et ouvert sur cambam. Mais je rencontre des problèmes, pour etre claire j 'ai pris des photos

si quelqu un connaît ce probleme merci

seb 18

seb18
petit nouveau
petit nouveau

Messages : 24
Points : 34
Date d'inscription : 04/10/2015
Age : 34
Localisation : saint etienne

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  dh42 le Mer 14 Oct 2015 - 20:24

Salut,

tien, un voisin Wink

bienvenu03

Oui, photo et fichier CamBam (le .cb, pas le gcode) sont nécessaire pour comprendre ce qui ne vas pas. (et une explication des problèmes en question)

pour poster de photo sur MB, il y a un tuto ici

http://www.metabricoleur.com/t570-poster-une-image

Tu débute avec CB, ou tu débute seulement avec l'utilisation spécifique des objets 3D et les opérations d'usinage 3D ?

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

photos

Message  seb18 le Jeu 15 Oct 2015 - 8:56





seb18
petit nouveau
petit nouveau

Messages : 24
Points : 34
Date d'inscription : 04/10/2015
Age : 34
Localisation : saint etienne

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  dh42 le Jeu 15 Oct 2015 - 14:48

Salut,

Ah, mais tu est sur Linux !

Bon, c'est bien les photos, mais une petite explication ce serait bien aussi Wink ...

Je viens d'ouvrir un STL sur la version linux, et il s'ouvre.

Que fais tu exactement pour arriver à ce message d'erreur ? merci de donner des détails, sinon je ne peux pas t'aider.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

exportation stl

Message  seb18 le Jeu 15 Oct 2015 - 22:23

Merci David, pour ta réponse,

Non je ne suis pas sur linux, je suis sous window 7, j ai dessine la pièce sur freecad comme tu peux la voir, après je l enregistre au format stl dans mes documents puis je l ouvre dans cambam, pour expliciter photo 1, et des que je l ouvre j ai le message d erreur que tu peux voir :photo 2 mais je peux continuer mais si je sélectionne la pièce cambam affiche le deuxième message ,voir photo. Voilà j espère être claire.

seb18
petit nouveau
petit nouveau

Messages : 24
Points : 34
Date d'inscription : 04/10/2015
Age : 34
Localisation : saint etienne

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  dh42 le Ven 16 Oct 2015 - 0:13

Ok, vu la couleur marron des fenêtres j'ai cru que c'était une version linux de Cambam pancoops

La seule chose qui me vient à l'esprit c'est que ton .net frameworks 3.5 n'est pas activé/installé sur Win7 ... (ça pose problème avec les DXF si il n'est pas installé, c'est peut être le cas aussi avec les STL)

voir la procédure ici
http://www.techhit.com/how-to/install-.net-3.5.1/windows7/

Si ça ne change rien, il faudrait que tu compresse ton STL en .zip et que tu le mette en pièce jointe, que je vois si ce n'est pas le fichier en lui même qui à un soucis. c'est une erreur que je n'ai jamais vu jusqu'à présent (tu a quelle version de CB ? -> menu aide/à propo de CB - la première ligne de la fenêtre)

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

suite

Message  seb18 le Mar 20 Oct 2015 - 13:53


bonjour,

david, j ai verifier frameworks 3.5 est bien installé, mon stl doit etre bon car je realisé une forme simple ne demandant pas d' esquisse particuliere ou de raccords et j 'arrive a l ouvrir sans probleme sur d autres logiciels. J aurai une question sur l utilisation que j aurai souhaité faire de cambam, lorsque je regarde les différents tutos, et les différents parcours d'outils, cambam peut il realiser un parcour d'outil pour realiser un modele qui doit avoir de la depouille car je voudrais realiser des moules pour couler de la resine dedans.

encore merci, il ne manquerait un plug in pour avoir une importation correct de la 3D?

merci A+
seb 18

seb18
petit nouveau
petit nouveau

Messages : 24
Points : 34
Date d'inscription : 04/10/2015
Age : 34
Localisation : saint etienne

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  dh42 le Mar 20 Oct 2015 - 15:03

Salut,

cambam peut il realiser un parcour d'outil pour realiser un modele qui doit avoir de la depouille car je voudrais realiser des moules pour couler de la resine dedans.

Oui, soit avec les opérations d'usinage 3D (et donc un modèle 3D), soit si tu veux une simple pente sur un contour, tu peux utiliser le profilage des bords avec l'option 'chanfrein' ; pas très intuitif à paramétrer mais bien utile.

http://www.atelier-des-fougeres.fr/Cambam/Aide/cam/SideProfiles.htm

il ne manquerait un plug in pour avoir une importation correct de la 3D?

Non, aucun plugin n'est nécessaire pour ça ; le problème doit être ailleurs.

Sans certitude, mais il est aussi possible que ça vienne de la carte VGA si elle ne sait pas gérer le mode vidéo réglé dans cambam.

- menu outils/options -> mode d'affichage et version du shader GLSL, dis moi ce que tu a comme réglages

- pour tester, change mode d'affichage sur GDI puis ferme et ré ouvre CB et essais ton objet 3D. Il sera moche (pas d'ombrage), mais si ça ne plante plus on saura si ça viens du driver VGA car en mode GDI l'openGL et les fonctions 3D internes de la carte VGA ne sont pas utilisées, c'est le CPU qui fait tout le job.

tu a la dernière version 0.9.8P de cambam ?

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

option gdi

Message  seb18 le Mar 20 Oct 2015 - 16:17

dh42 a écrit:Salut,

cambam peut il realiser un parcour d'outil pour realiser un modele qui doit avoir de la depouille car je voudrais realiser des moules pour couler de la resine dedans.

Oui, soit avec les opérations d'usinage 3D (et donc un modèle 3D), soit si tu veux une simple pente sur un contour, tu peux utiliser le profilage des bords avec l'option 'chanfrein' ; pas très intuitif à paramétrer mais bien utile.

http://www.atelier-des-fougeres.fr/Cambam/Aide/cam/SideProfiles.htm

il ne manquerait un plug in pour avoir une importation correct de la 3D?

Non, aucun plugin n'est nécessaire pour ça ; le problème doit être ailleurs.

Sans certitude, mais il est aussi possible que ça vienne de la carte VGA si elle ne sait pas gérer le mode vidéo réglé dans cambam.

- menu outils/options -> mode d'affichage et version du shader GLSL, dis moi ce que tu a comme réglages

- pour tester, change mode d'affichage sur GDI puis ferme et ré ouvre CB et essais ton objet 3D. Il sera moche (pas d'ombrage), mais si ça ne plante plus on saura si ça viens du driver VGA car en mode GDI l'openGL et les fonctions 3D internes de la carte VGA ne sont pas utilisées, c'est le CPU qui fait tout le job.

tu a la dernière version 0.9.8P de cambam ?

++
David
 rebonjour david,


 Ok, encore merci pour ta reponse, la version est cambam plus 0.9.8
je viens d 'essayer le changement en gdi, quand j ouvre cambam et importe mon stl j ai la piece mais qui a change de couleur (jaune) mais j ai toujours les mêmes messages d 'erreur et je ne peux effectuer des operations

A+

seb18
petit nouveau
petit nouveau

Messages : 24
Points : 34
Date d'inscription : 04/10/2015
Age : 34
Localisation : saint etienne

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  dh42 le Mar 20 Oct 2015 - 16:57

Re

C'est vraiment bizarre, je n'ai jamais entendu parler de ce problème avec les STL. De plus d'après le message d'erreur c'est une fonction d'une DLL de Windows qu'il ne trouve pas (System.Drawing.pointF[]) d’où ma suspicion d'une absence du .net framework 3.5, car c'est dans ce framework que se trouvent ces fonctions.

david, j ai verifier frameworks 3.5 est bien installé

Installé oui, je crois qu'il l'est sur tous les win7, mais est il actif ?  tout doit être coché



Tente une réinstallation de Cambam:

- sauve ton fichier de licence (cambamPro.lic)qui est dans le dossier C:\Program Files (x86)\CamBam plus 0.9.8

- supprime complètement le dossier  C:\Program Files (x86)\CamBam plus 0.9.8 (version Win 64bits, si 32 bit c'est dans C:\Program Files\CamBam plus 0.9.8)

- relance l'insta de Cambam en mode administrateur ; assure toi de bien avoir la dernière version (0.9.8 P)
http://www.cambam.co.uk/downloads/CamBamPlus-0.9.8P.msi

- lors de l'insta, n'oublie pas d'accepter quand il te demande de mettre des permissions au dossier.

- remet ton fichier de licence à sa place.

- lance cambam en mode administrateur, règle le mode d'affichage sur OpenGL_legacy (nécessite un redémarrage)

Si rien de tout cela n'y fait, je n'ai plus d'idées, à part un pb avec Windows lui-même (ton insta), car à ma connaissance CB fonctionne bien avec W7 32 et 64 bits scratch

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

framework

Message  seb18 le Mar 20 Oct 2015 - 17:37



rebojour david,

C est vrai que ce serait bien cela, en fait j ai pas window 7 mais window 8, j ai cherché sur le net, le deuxieme message " erreur bibliotheque" serait typique de ce que tu dis, pourtant
j ai coché les sous indices et Framework 3.5 comporte un "v" mais je vois en bas un Framework 4.5 avancé?
desolé de ces approximations

A+

seb18
petit nouveau
petit nouveau

Messages : 24
Points : 34
Date d'inscription : 04/10/2015
Age : 34
Localisation : saint etienne

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  dh42 le Mar 20 Oct 2015 - 20:21

Ah !! win 8 ... il semble qu'il y ai des tas de bizarrerie avec cette version (la 8.1 pour être exact) ; des images qui disparaissent dans des plugins, des soucis d'insta, script python qui ne marchent pas .. etc .. problèmes qui ne se posent pas sur XP, W7 et W10.  scratch ... W8 serait il un ersatz de Windows Millenium ?  What a Face

j'ai entendu dire que les possesseurs de win 7, 8 et 8.1 pouvaient passer à win 10 gratuitement.

j ai coché les sous indices et Framework 3.5 comporte un "v" mais je vois en bas un Framework 4.5 avancé?

Je ne sais pas pour le 4.5, mais pour le 4.0 c'est sur, il ne remplace pas le 3.5.

Un test à effectuer, installe le plugin V-Grave et regarde si il marche, si le .net framework 3.5 n'est pas installé/reconnu le plugin ne se charge pas et tu a une erreur dans la fenêtre du bas de CB comme sur cette image.



le plugin V-engrave
http://www.atelier-des-fougeres.fr/Cambam/Aide/Plugins/VengraveFR.html

insta d'un plugin
http://www.atelier-des-fougeres.fr/Cambam/Aide/Plugins/plugin_menu_FR.html


Une dernière idée qui me viens subitement ; regarde si tu peux lancer Cambam en mode de compatibilité win7 ou win XP (et coche aussi le mode lancer en administrateur par la même occasion si ce n'est déjà fait)




++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

ça marche

Message  seb18 le Mer 21 Oct 2015 - 10:44



bonjour,

un grand merci a david, j ai un peu bidouillé et ça y est, je peux importer stl sans messages d'erreurs, je peux selectionner la pièces decomposer en polyligne. En fait j ai reinstallé cambam sur un pc avec XP, mais j ai aussi telecharger Framework 2.0 x86 car mon xp ne reconnaissait pas les autres. Ok il ne reste plus qu' a travailler et toute ma reconnaissance a david

A+

seb18
petit nouveau
petit nouveau

Messages : 24
Points : 34
Date d'inscription : 04/10/2015
Age : 34
Localisation : saint etienne

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  seb18 le Mer 4 Nov 2015 - 21:44

seb18 a écrit:

 bonjour,

 un grand merci a david, j ai un peu bidouillé et ça y est, je peux importer stl sans messages d'erreurs, je peux selectionner la pièces decomposer en polyligne. En fait j ai reinstallé cambam sur un pc avec XP, mais j ai aussi telecharger Framework 2.0 x86 car mon xp ne reconnaissait pas les autres. Ok il ne reste plus qu' a travailler et toute ma reconnaissance a david

 A+


Bonsoir,

Maintenant j ai un petit probleme sur mes parcours d'outil je pense dut au stl, pour des formes cylindriques je n' ai pas de probleme par contre pour un rectangle de hauteur 30 mm et de la depouille sur toutes ces faces le parcours d 'outil est totalement incoherent, ce que je remarque c est que lorsque je decompose le stl je me retrouve avec une cinquantaine de polylignes (triangles) et j 'ai l 'impression que le parcours d outil est conditionné par cela, que dois je faire?

seb18
petit nouveau
petit nouveau

Messages : 24
Points : 34
Date d'inscription : 04/10/2015
Age : 34
Localisation : saint etienne

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  dh42 le Mer 4 Nov 2015 - 22:16

Salut,

compresse ton fichier .cb en zip et met le en pièce jointe ; je regarderais d’où peut venir le problème ; ça peut venir du STL, mais pas forcément ...

Le mode d'usinage 3D par balayage (horiz/vertic) est plutôt conciliant avec les STL même de mauvaise qualité, par contre si tu utilise le mode "lignes de niveau" alors il faut un STL bien propre.

Le stl doit être une pièce faite d'un bloc, sans trous et il ne doit pas contenir de maillages imbriqués.

++
David


_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  seb18 le Ven 6 Nov 2015 - 10:09

dh42 a écrit:Salut,

compresse ton fichier .cb en zip et met le en pièce jointe ; je regarderais d’où peut venir le problème ; ça peut venir du STL, mais pas forcément ...

Le mode d'usinage 3D par balayage (horiz/vertic) est plutôt conciliant avec les STL même de mauvaise qualité, par contre si tu utilise le mode "lignes de niveau" alors il faut un STL bien propre.

Le stl doit être une pièce faite d'un bloc, sans trous et il ne doit pas contenir de maillages imbriqués.

++
David


bonjour,

 Je t envoie le stl c'est une forme simple, lorsque je génère un parcour d 'outils mold en mode balayage horizontale sur une longeur en x le z passe du haut de la piece au bas de la piece!
Fichiers joints
simple rectangle.zip Vous n'avez pas la permission de télécharger les fichiers joints.(1 Ko) Téléchargé 1 fois

seb18
petit nouveau
petit nouveau

Messages : 24
Points : 34
Date d'inscription : 04/10/2015
Age : 34
Localisation : saint etienne

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  dh42 le Ven 6 Nov 2015 - 15:42

Salut,

Ce serait mieux que tu mette ton fichier Cambam (.cb) que je vois aussi comment sont paramétrées tes op d'usinage. Le STL en lui même n'a pas de défaut ; je l'ai ouvert sous 3DSmax et passé au "test STL" et il trouve 0 erreur ... visuellement il est ok aussi.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

parcours d' outil en aller retour

Message  seb18 le Dim 20 Déc 2015 - 7:16

dh42 a écrit:Salut,

Ce serait mieux que tu mette ton fichier Cambam (.cb) que je vois aussi comment sont paramétrées tes op d'usinage. Le STL en lui même n'a pas de défaut ; je l'ai ouvert sous 3DSmax et passé au "test STL" et il trouve 0 erreur ... visuellement il est ok aussi.

++
David

Bonjour,


en mode 3 D, mon parcours d'outil est le suivant: descente dans la matiere, passe de la profondeur indiquée puis remontée de l 'outil qui repart sans usiné au point de depart. Comment je peux usiner avec une passe en aller et une passe en retour.

salutations

seb18
petit nouveau
petit nouveau

Messages : 24
Points : 34
Date d'inscription : 04/10/2015
Age : 34
Localisation : saint etienne

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  dh42 le Dim 20 Déc 2015 - 17:19

Salut,

Comment je peux usiner avec une passe en aller et une passe en retour.

Met "sens d'usinage" sur Mixte.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: probleme exportation STL 3D

Message  Contenu sponsorisé Aujourd'hui à 7:52


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum