Message d'erreur "rebelle" dans Mach3

Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Message d'erreur "rebelle" dans Mach3

Message  Papyblues le Mar 24 Nov 2015 - 18:41

Bonsoir à tous,

Je travaille avec le couple CAMBAM/MACH3,

Un truc bizarre.... j'ai lancé un usinage et peut être était il mal préparé car il s'est interrompu  avant la dernière opération (Contour final) . Un message d'erreur a été affiché ....J'ai donc refait et re-vérifié mes opérations d'usinage et au moment de re-lancer je n'ai pas pu effacer le message d'erreur (commande du menu automatique). c'est bien la première fois!.. j'ai tout arrêté et rallumé plusieurs fois , rien à faire il s'incruste !....

Quelqu'un a t il la solution pour "nettoyer" les erreurs après un plantage?

Merci par avance...
`
Papyblues
Papyblues
Papyblues
petit nouveau
petit nouveau

Messages : 44
Points : 66
Date d'inscription : 15/09/2015
Age : 71
Localisation : Bouches du Rhône

http://okf1040@gmail.com

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  eric44 le Mar 24 Nov 2015 - 18:44

Bonjour,

Tu as fait un dessin sous cambam puis tu as généré le gcode.
Tu as ouvert le .nc sous mach3 puis lancé l'usinage.
Cela plante durant l'usinage : quel est le message ?

@+
Eric
eric44
eric44
complétement accro
complétement accro

Messages : 1446
Points : 1918
Date d'inscription : 04/08/2014
Age : 58
Localisation : Près de Nantes (44)

http://www.lamoricais.fr

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  chris74 le Mar 24 Nov 2015 - 19:21

Savez vous que l'on peu faire un test du programme dans "simulation d'usinage" sous mach3, on vérifie ainsi, avant usinage, que le programme ne comporte pas de lignes générant des erreurs.
chris74
chris74
acharné du forum
acharné du forum

Messages : 478
Points : 860
Date d'inscription : 15/07/2012
Age : 50
Localisation : Haute savoie

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Le message rebelle

Message  Papyblues le Mar 24 Nov 2015 - 21:59

Merci pour ces réponses, voici le message (j'aurais pu commencer par cela...)

"Mill->G15 G80 G17 G40 G21 G90 G94 G54 G49 G99 G64 G97"

L'empilage de ces codes n'a pas de sens pour moi....

Par ailleurs, je connais  la commande d'exécution "à blanc", comme c'était une petite chose j'ai pas jugé utile de perdre ce temps là,  j'ai été trop sur de moi....

Merci par avance,
A+
Papyblues
Papyblues
Papyblues
petit nouveau
petit nouveau

Messages : 44
Points : 66
Date d'inscription : 15/09/2015
Age : 71
Localisation : Bouches du Rhône

http://okf1040@gmail.com

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  dh42 le Mar 24 Nov 2015 - 22:30

Salut,

C'est pas ça le message d'erreur Wink

Si tu est sous Mach3FR, le message d'erreur est juste dessous la séquence de codes d'initialisation Wink

Message d'erreur "rebelle" dans Mach3 Mach3f10

ici par exemple, "soft warning on Y min" (dépassement des limites d'usinage en Y-)

++
David


Dernière édition par dh42 le Mar 24 Nov 2015 - 22:46, édité 1 fois

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  dh42 le Mar 24 Nov 2015 - 22:33

chris74 a écrit:Savez vous que l'on peu faire un test du programme dans "simulation d'usinage" sous mach3, on vérifie ainsi, avant usinage, que le programme ne comporte pas de lignes générant des erreurs.

Ce n'est pas vraiment utile ; si il y a une erreur dans le Gcode (ou des codes inconnus), Mach3 le dira immédiatement au chargement du fichier Gcode (dans la zone de messages d'erreur) et montrera la 1ière ligne en défaut au lieu de se mettre sur la première ligne du fichier, prêt à partir.

C'est pour ça que l'ouverture de gros Gcode est parfois un peu longue ; Mach vérifie systématiquement tout Gcode que l'on charge.

Il vérifie également si l'usinage tient dans les limites de la machine compte tenu du pt 0,0,0 en XYZ courant et des tailles fournies dans les "limites machines".

L'intéret de la simu d'usinage par contre, c'est que l'on peut connaitre le temps d'usinage avec précision et non pas de manière très approximative comme avec CutViewer ou CamBam.

après avoir fait les 0 pièces sur les 3 axes, il est bon de cliquer sur 'rafraichir' (regen toolpath) vers la fenêtre d'affichage des parcours de façon à bien resynchroniser les 0 avec les limites machines avant de lancer l'usinage. Si on a une alerte "soflimits Warning . continue" après ça, c'est que l'usinage ne rentre pas dans les limites machine.

Cette alerte peut se produire si vous n'avez par rafraichi les parcours d'outil ; dans ce cas, répondre Non, rafraichir, puis relancer l'usinage.
Si il y a tj l'alerte même après avoir rafraichi les parcours alors c'est qu'il y a vraiment un dépassement des limites d'usinage.

Tout ceci suppose bien sur que la machine ai des contacts de référencement, qu'elle ai été référencé .. et bien sur que les bonne valeurs pour les courses des axes aient été entrées dans les limites

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  Papyblues le Mar 24 Nov 2015 - 23:07

Merci dh42,

Le message que j'ai est bien celui là ,mais sans la seconde ligne. Au lancement de Mach3 , il apparait avec " macro initialisation appelée par RaZ ", quand tout est Ok (Au acquitté etc..) je clique " effacer l'erreur" ...seule cette deuxième ligne s'efface et pas la ligne "Mill-> G.........,

Je doute que ce soit uniquement esthétique sinon ça ne me gène pas , mais j'aimerais retrouver mon écran "clean"...

A+
Papyblues
Papyblues
petit nouveau
petit nouveau

Messages : 44
Points : 66
Date d'inscription : 15/09/2015
Age : 71
Localisation : Bouches du Rhône

http://okf1040@gmail.com

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  Papyblues le Mar 24 Nov 2015 - 23:10

PS; j'ai oublié de préciser en lisant un peu vite que je n'ai pas eu de "Warning" précédemment et que je rafraîchis systématiquement avant tout lancement d'usinage..
Papyblues
Papyblues
petit nouveau
petit nouveau

Messages : 44
Points : 66
Date d'inscription : 15/09/2015
Age : 71
Localisation : Bouches du Rhône

http://okf1040@gmail.com

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  dh42 le Mar 24 Nov 2015 - 23:53

je clique " effacer l'erreur" ...seule cette deuxième ligne s'efface et pas la ligne "Mill-> G.........,

Oui, c'est normal, cette ligne n'affiche pas des erreurs, et elle est toujours la, tu n'a pas dut y faire attention avant Wink

C'est l'initialisation de Mach3:

G17: usinage sur le plan XY
G21: unité = mm
G90: mode de déplacement = absolu
G54: utilisation les coordonnées G54 (set de coordonnées par défaut)
G40: RàZ des décalages outil
etc ...

Cette séquence de codes est envoyée chaque fois que tu clique sur le bouton Reset de Mach3 (arrêt d'urgence sur la VF)

Si ton usinage s'est arrêté en cours de route sans raisons apparente (et sans que tu ai vu le message d'erreur, le vrai) il se peut que ce soit le Watchdog qui fasse des sienne. Menu config/general config, colonne de droite de la fenêtre, décoche "use wachdog" (utiliser chien de garde)

Si ça se reproduit, note bien le message d'erreur qui apparait SOUS la ligne de code d’initialisation avant de toucher quoi que ce soit.

Si tu a une erreur du type "external E-Stop requested" (bouton AU externe utilisé) lorsque la machine s'arrête toute seule, ça peut être un bouton d'AU trop sensible qui déclenche avec les vibrations de l'usinage.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  Papyblues le Dim 29 Nov 2015 - 16:08

Bonsoir, désolé pour le délai mais j'ai été retenu loin de ma machine..

Voilà j'ai bien noté la séquence...

1) j'ai décoché le Watchdog, arrêté la session et relancé M3,

2) à l'ouverture j'ai toujours le message Mill-> etc.. avec une deuxième ligne "RàZ de configuration" (le bouton AU clignote)

3) je décoche l'AU et j'obtiens ur la deuxième ligne " Macro intialisation rappelée par RaZ"

4) je clique "effacer erreur" et seule la seconde ligne s'efface...

J'ai toujours eu ces messages depuis le début et je n'ai jamais eu de pb... effectivement ce défaut est apparu lors d'un usinage (pourtant simple) quand la dernière opération (contour final) n'a pas été exécutée et que l'usinage s'est interrompu de lui même avant...

Je suis certainement à l'origine du pb j'ai du aller un peu vite comme d'hab., ça me servira de leçon...

Merci pour ton aide ...
Papyblues

Papyblues
Papyblues
petit nouveau
petit nouveau

Messages : 44
Points : 66
Date d'inscription : 15/09/2015
Age : 71
Localisation : Bouches du Rhône

http://okf1040@gmail.com

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  Papyblues le Dim 29 Nov 2015 - 18:22

Dernière heure,

pour en avoir le coeur net j'ai lancé un petit usinage... No problème! tout s'est correctement déroulé, jusqu'au bout!....reste le message rebelle qui, apparemment ne nuit pas au fonctionnement général...

A suivre... Papyblues
Papyblues
Papyblues
petit nouveau
petit nouveau

Messages : 44
Points : 66
Date d'inscription : 15/09/2015
Age : 71
Localisation : Bouches du Rhône

http://okf1040@gmail.com

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  dh42 le Dim 29 Nov 2015 - 18:49

Salut,

Ok, les messages que tu obtiens son tout à fait normaux ; pas d'inquiétude à avoir Wink

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  Papyblues le Lun 30 Nov 2015 - 16:29

Un grand merci, ça rassure!
Papyblues
Papyblues
Papyblues
petit nouveau
petit nouveau

Messages : 44
Points : 66
Date d'inscription : 15/09/2015
Age : 71
Localisation : Bouches du Rhône

http://okf1040@gmail.com

Revenir en haut Aller en bas

Message d'erreur "rebelle" dans Mach3 Empty Re: Message d'erreur "rebelle" dans Mach3

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum