Question parcours d'outil

Page 1 sur 4 1, 2, 3, 4  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Question parcours d'outil

Message  Cyrille6901 le Sam 28 Nov 2015 - 14:18

Bonjour à tous,

Jusqu'à présent j'ai toujours utilisé la fonction poche pour graver un texte avec la police de mon choix (préalablement vectorisé avec AutoCad); mais, je trouve que le parcours d'outil est très mal optimisé... sur une même lettre, par exemple Q ou R sur la photo; on voit que la fraise remonte puis redescend à plusieurs reprises. En principe, elle ne devrait descendre qu'une fois, et remonter une fois la lettre entièrement gravée, non?

Changer le sens d'usinage en "mixte" n'y fait rien du tout...



Si quelqu'un à une idée...

Merci d'avance.

Cordialement. Cyrille

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Sam 28 Nov 2015 - 22:34

Salut,

sur la photo; on voit que la fraise remonte puis redescend à plusieurs reprises.

Tu est sur qu'elle remonte ? sur l'image on a plutôt l'impression qu'elle descend dans la matière ; vérifie la valeur de "plan de dégagement" ; elle doit tj être supérieur au point le plus haut de la pièce ou du brut. (+ l'éventuelle épaisseur des brides)

En principe, elle ne devrait descendre qu'une fois, et remonter une fois la lettre entièrement gravée, non?

Peut être pas une seule fois, mais moins souvent.

Ce qui détermine si la fraise remonte ou non pour passer d'une trajectoire à l'autre, c'est le paramètre "Déplacement latéral maxi"

ex: si déplacement latéral maxi = 0.7 et que tu a une fraise de 3, alors si la distance entre le point ou finis un parcours et le point ou démarre le suivant est supérieure à 0.7*3 = 2.1mm la fraise remontera en rapide, se déplacera jusqu'au prochain parcours puis redescendra**. si cette distance est plus courte, elle ne remontera pas mais se déplacera latéralement en vitesse d'usinage (V d'usinage ou de plongée, suivant réglage de "vitesse d'avance latérale")

** si dans le dossier Usinage "Hauteur de plongée en rapide" > 0, alors la descente se fera en rapide jusqu'à cette hauteur au dessus du niveau d'usinage en cours, puis continuera en V de plongée. Si = 0, la descente en rapide est désactivée et toute la descente se fera en V de plongée. Si = -1, la descente se fera en rapide jusqu'à une hauteur = 1x le pas mineur de la grille (en général 1mm sur un dessin en métrique)

http://www.atelier-des-fougeres.fr/Cambam/Aide/cam/Pocket.htm

PS quand tu a un pb avec un fichier Cambam, zippe le fichier .cb et met le en pièce jointe, car juste une image c'est un peu limite pour être sur de ce qui se passe. Wink

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Cyrille6901 le Dim 29 Nov 2015 - 7:49

Bonjour David,

Merci pour ta réponse.

Je mets le fichier en pièce jointe pour y voir plus clair.

Je ne suis pas sûr d'avoir bien compris la fonction du déplacement latéral maxi; visiblement il est de 0.7 par défaut quelque soit le diamètre de la fraise. L'épaisseur moyenne des lettres à graver est d'environ 0.5mm et j'utilise une fraise javelot avec une pointe de 0.1mm (ou peut-être 0.2... je ne me rapelle plus, ce n'est pas marqué dessus et pas évident à mesurer).

Donc, effectivement lorsque j'augmente le déplacement latéral maxi; à partir d'une certaine valeur la fraise remonte beaucoup moins. Mais comment déterminer cette valeur de façon optimale ? Doit-on procéder par tâtonnements ?

Si j'ai bien compris la fonction "hauteur de plongée en rapide", je peux optimiser la durée de l'usinage en faisant descendre la fraise plus rapidement entre chaque parcours. La valeur de -1 serait donc mieux adaptée aux opérations de gravure, c'est bien ça ?

Merci d'avance et bon dimanche à tous.

Cordialement. Cyrille
Fichiers joints
ILS_Grav.zip Vous n'avez pas la permission de télécharger les fichiers joints.(12 Ko) Téléchargé 1 fois

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Dim 29 Nov 2015 - 18:03

Salut,

Donc, effectivement lorsque j'augmente le déplacement latéral maxi; à partir d'une certaine valeur la fraise remonte beaucoup moins. Mais comment déterminer cette valeur de façon optimale ? Doit-on procéder par tâtonnements ?

Oui, le recouvrement choisi aura aussi un effet sur le résultat, ainsi que le point de départ de l'usinage dans certains cas. En augmentant le déplacement latéral maxi il faut veiller à ne pas non plus aller trop loin sinon la fraise risque de ne pas remonter la ou elle le devrait et, par exemple, de couper de la matière entre 2 caractères.

En regardant ton dessin de près, je vois aussi qu'il n'est pas du tout optimisé pour l'application des parcours d'outils pour toutes les lettre qui ont des arrondis (Q R S ..) les arrondis des polylignes ne sont pas des arcs mais une succession de petits traits, ce qui générer aussi des parcours assez moches.

Exemple avec le Q ; à gauche tu peux voir que les polylignes sont constituées d'une multitude de petits segments droits et que les parcours d'outils ont des usinages additionnels sous forme de 7 "traits".  Après un "insérer des arcs" avec une tolérance de 0.05, les polylignes sont arrondies et les parcours s'en portent mieux (cela fait aussi fortement maigrir le Gcode et évite aussi les saccades sur la machine, qui meuvent se produire lorsqu'il y a une succession de traits très courts)



jette un œil ici pour ce qui concerne la préparation des dessins (en particulier lorsqu'ils sont importés)
http://www.atelier-des-fougeres.fr/Cambam/Aide/tutorials/Prepare_dessins.html

Si j'ai bien compris la fonction "hauteur de plongée en rapide", je peux optimiser la durée de l'usinage en faisant descendre la fraise plus rapidement entre chaque parcours. La valeur de -1 serait donc mieux adaptée aux opérations de gravure, c'est bien ça ?

Oui, ça permet de gagner du temps ; pour ma part, je règle cette valeur à 1 en général, sauf si CutViewer me met une alerte collision en rapide lors de la simu (ça peut arriver dans certains cas spécifiques), dans ce cas, je règle cette valeur = a l'incréments de passe utilisé dans l'usinage ou je reçois cette alerte.

Je préfère la régler à une valeur connue plutôt que la laisser à -1 (auto), car dans ce cas c'est dépendant du pas de la grille ... et le pas de la grille tu peux le changer, sans forcément penser à re régler la plongée

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Cyrille6901 le Dim 29 Nov 2015 - 20:07

Bonsoir,

Merci beaucoup, ces méthodes fonctionnent à merveille; j'ai hâte d'essayer ça sur la CN. C'est tout à fait ce qui me manquait Very Happy

Une question concernant la fonction "trajectoire exacte": à chaque usinage (gravure ou autre), je met systématiquement le mode trajectoire exacte dans chaque opération. C'est certainement une mauvaise habitude... cela ralentit probablement les usinages qui n'ont pas besoin d'une extreme précision...

Comment déterminer si pour tel ou tel usinage, le mode doit être en VC ou TE ? Peut-on si besoin, le verrouiller sur tel ou tel mode, dans TOUTES les opérations ?

Merci d'avance et bonne soirée.

Cordialement. Cyrille

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Dim 29 Nov 2015 - 21:27

Re

Une question concernant la fonction "trajectoire exacte": à chaque usinage (gravure ou autre), je met systématiquement le mode trajectoire exacte dans chaque opération. C'est certainement une mauvaise habitude... cela ralentit probablement les usinages qui n'ont pas besoin d'une extreme précision...

Le mode à utiliser par défaut est "vitesse constante", car en mode trajectoire exacte, les axes s'arrête à la fin de chaque segment/arc ; par exemple dans le cas du "Q" de gauche, la machine se mettrais à danser le jerk avec tout ces petits segments car le mouvement s’arrêterais à la fin de chaque segment. Outre le fait que ça fait vibrer la machine, un mouvement qui s'arrête en cours d'usinage, ça laisse une marque sur le flanc de la pièce .. et en plus, l'outil ne travaille pas dans de bonnes conditions

Comment déterminer si pour tel ou tel usinage, le mode doit être en VC ou TE ?

C'est difficile pour ne pas dire impossible à savoir à l'avance car ça dépend des réglages machines. En mode VC, le risque c'est que les angles (spécialement les intérieurs) soient arrondis, mais c'est très dépendant du couple Vitesse d'usinage/accélération maxi ; plus la V est grande par rapport à l'accélération, plus les angles seront arrondis, car dans ce mode, dès qu'un moteur ralentis à l'approche de l'angle, l'autre se met en marche, ce qui a tendance à créer un arc dans l'angle.

Pour ma part, j'utilise le mode TE lorsque je coupe des boites à créneau et que j'utilise le dégagement des angles.

En général, lorsqu'il y a des tas de courbes, il vaut mieux rester en Vitesse constante.

Peut-on si besoin, le verrouiller sur tel ou tel mode, dans TOUTES les opérations ?

Dans Cambam, lorsque tu crée une nouvelle op d'usinage, elle est remplie avec les paramètres du style par défaut, donc il suffit de régler le paramètre mode de déplacement sur la valeur que tu utilise le plus directement dans le style par défaut pour qu'il soit utilisé sur toute nouvelle opération.

Le style par défaut est le premier style sans nom de la bibliothèque de styles en cours d'utilisation. Si tu n'a pas choisi une biblio spécifique, alors ce sera le premier style sans nom de Standard-mm si tu bosse en mm ou de Standard-in si tu bosse en pouces.

http://www.atelier-des-fougeres.fr/Cambam/Aide/cam/CAMStyles.htm

Sur un fichier déjà existant, tu peux parfaitement sélectionner toutes tes op d'usinage et changer une valeur de propriété, comme le mode de déplacement, pour toutes les op sélectionnées d'un seul coup.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Cyrille6901 le Lun 30 Nov 2015 - 19:15

Bonsoir,

Décidément, je faisais tout de travers.. Alors entendu, vitesse constante dans la majorité des cas  ! Et fini le jerk  cheers

dh42 a écrit:
C'est difficile pour ne pas dire impossible à savoir à l'avance car ça dépend des réglages machines.

Alors justement, toi qui a eu entre les mains l'ID CNC (mon ancienne CN) puis la PFE (ma future CN encore sur sa palette...); est ce que ça change quelque chose concernant les risques d'angles arrondis en vitesse constante ?

Cordialement. Cyrille

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Lun 30 Nov 2015 - 21:10

Re

Les BZT peuvent aller plus vite que l'ID mais elles accélèrent/freinent aussi bien plus fort ce qui compense, et même largement à mon avis ; il faudrait le calculer.

si je me souviens bien, sur l'ID CNc, pour moi c'était V maxi en usinage 800 mm/min, accélération 30 mm/s² ; sur la PFE c'est 4000 mm/min et 400 mm/s²

En ce qui me concerne, avec cette accélération à 400, je peux usiner à 1600 / 2000 mm/min sans me soucier des arrondis dans les angles ; mais j'en tiens compte au delà.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Cyrille6901 le Mar 1 Déc 2015 - 19:40

Bonsoir,

Merci encore David pour les explications  Very Happy

Cordialement. Cyrille

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Mar 1 Déc 2015 - 20:21

Salut,

Je viens de faire vite fait un petit calculateur Excel qui donne la "distance de freinage/accélération", et donc par conséquent la valeur du rayon de l'arrondi maxi qu'il y aura dans les angles intérieurs en mode Vitesse constante.



Entre ta Vitesse d'usinage en mm/min dans la case verte Vitesse (mm/min), et entre la valeur d'accélération réglée pour tes moteurs dans la case accélération (mm/s²). Tu obtiendra le temps mis pour freiner/accélérer de 0 à la vitesse demandée dans T freinage/accél (s) et la distance effective en mm dans Distance freinage/acc (mm)

Exemple ici, pour un usinage à 1200 mm/min, et une accélération à 400 mm/s², le rayon généré dans un angle intérieur serait environ de 0.5mm

PS, le résultat n'est valable que si X et Y ont les mêmes valeurs d'accélération.

Note que ce problème d'angle arrondis ne se produit que sur des angles intérieurs car dans ce cas le parcours d'outil change brutalement de direction.

En extérieur, des arcs sont ajoutés de façon à ce que la fraise effectue une rotation autour de l'angle, sa périphérie servant de point de pivot autour du somment de l'angle, donc pas de changement brutale de direction.


(les parcours d'outils sont en bleu)

++
David
Fichiers joints
calcul_r_fonction_de_V_acc.zip Vous n'avez pas la permission de télécharger les fichiers joints.(3 Ko) Téléchargé 2 fois

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Cyrille6901 le Mer 2 Déc 2015 - 21:19

Bonsoir,

Merci David pour ce petit calculateur; j'avais remarqué des angles arrondis lors d'opérations de gravure de CI (à l'anglaise) avec l'ID CNC. C'est la raison pour laquelle j'avais, dans le doute pris l'habitude (à tort) de mettre en trajectoire exacte.

Donc, en principe, avec la PFE, si je grave à 200mm/min avec une accélération de 400mm/s, le rayon de l'angle sera de 0,01mm, autrement dit... négligeable. C'est parfait !

Cordialement. Cyrille

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Mer 2 Déc 2015 - 21:48

Salut,

Merci David pour ce petit calculateur; j'avais remarqué des angles arrondis lors d'opérations de gravure de CI (à l'anglaise) avec l'ID CNC. C'est la raison pour laquelle j'avais, dans le doute pris l'habitude (à tort) de mettre en trajectoire exacte.

Pas à tort, l'ID-CNc ayant de très faibles accélérations il est très souvent nécessaire d'utiliser "trajectoire exacte" avec cette machine ; la BZT par contre accélère 13x plus fort donc le phénomène est plus faible pour une même vitesse d'usinage.

Note aussi, que d'origine, sur le fichier BZT, l'accélération est même à 500 mm/s², c'est moi qui l'ai calmée un peu ... mais si je ne me trompe pas, tu a pris des drivers numériques ? .. dans ce cas il est bien possible que le système supporte 500 et même plus.

Sur la PF j'avais essayé à 600 et ça fonctionne, sauf que je dois réduire mes V maxi d'usinage (et aussi de rapide), sinon ça décroche (perte de pas) .... mais j'usine à des vitesses qui descendent rarement en dessous de 1500 mm/min et sont plus souvent proche des 3000 à 3500 ... donc il faut faire un choix pour tes réglages moteur, soit tu privilégie la V maxi mais tu dois utiliser une accélération plus faible, soit tu limite la V maxi (y compris en rapide) et tu peux augmenter l'accélération.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Cyrille6901 le Jeu 3 Déc 2015 - 19:36

Bonsoir David,

Oui, en effet, sur tes conseils et ceux de Herr Kloss alias Sorotec, j'ai pris des drivers numériques DM 556. En revanche, les moteurs sont des 4,2A.

Je partage tout à fait ton idée selon laquelle il vaut mieux avoir une CNC fiable qu'une CNC rapide... Alors, si j'ai bien compris, il vaut mieux limiter la vitesse max à 4000mm/min et l'accélération à 400mm/s; mais, avec mes drivers numériques, je peux éventuellement tenter d'améliorer les performances, c'est ça ?

Comment tester de manière fiable ces paramètres ?

J'aimerais, tant qu'à faire, profiter pleinement de ces drivers mais sans pour autant passer des journées entières à optimiser les réglages pour gagner 10mm/min et m'apercevoir 6 mois après que je perds des pas....

Cordialement. Cyrille

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Cyrille6901 le Jeu 3 Déc 2015 - 19:56

Re,

J'oubliais; est-ce que l'on peut trouver quelque part la doc de CamBam en PDF ? J'ai trouvé une version, mais qui date de 2011.... visiblement tu as fait beaucoup d'ajouts de depuis.

Merci d'avance et bonne soirée à tous !

Cordialement. Cyrille

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Jeu 3 Déc 2015 - 21:01

Re

Alors, si j'ai bien compris, il vaut mieux limiter la vitesse max à 4000mm/min et l'accélération à 400mm/s

Sur une PFE, tu peux monter à 5/6000 je pense, les guidages résistent beaucoup moins que sur une PF ...

Comment tester de manière fiable ces paramètres ?

A part l'expérience, je ne vois pas d'autre solution ... sur des 100 aines d'heures d'usinage tu pourra te rendre compte de la fiabilité ou non d'un réglage.

Ne changer qu'un seul réglage à la fois.

++
David


_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Cyrille6901 le Ven 4 Déc 2015 - 19:24

Bonsoir,

Merci pour ta réponse, 6000mm/min c'est déja beaucoup ! surtout comparé aux 700mm/min de l' ID CNC...

Je vais faire des test avec ces drivers et je te tiendrai au courant.

Bon Weekend. Cordialement.

Cyrille

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Ven 4 Déc 2015 - 20:38

Oui, à voir.

Pour ma part je viens encore d'avoir une grosse perte de pas avec la PFE, en rapide à 5000 mm/min, acc à 400, et sur un seul axe en mouvement.(X)

Contrairement à la PF le moteur n'a pas bloqué net, mais il perdait des pas en pagaille, l'axe se mettant à avancer à la moitié de sa vitesse .. machine froide, comme d'hab ... sauf qu’aujourd’hui il ne fait pas vraiment froid dans l'atelier (7°) ... donc j'ai baissé l'accélération à 300 .. comme sur la PF.

Je me demande pourquoi les autres (JP, zarkann, etc ..) ne semblent jamais avoir ce problème .. avec des V maxi supérieures aux miennes .. scratch

Je pense que je vais tenter les drivers 5.6A numériques (quand j'aurais 350€ à dépenser What a Face ) .... mais je ne comprends quand même pas ; j'ai essayé avec 3 PC différents, 3 machines différentes et 2 contrôleurs différents ... et même résultat ... perte de pas en rapide à froid, et très occasionnelles à chaud (1x toutes les 100 à 150h d'usinage si rapide à 5000, plus souvent avec les rapide à 6000, et jamais avec les rapides à 4000) .... et toujours en rapide (ou très proche de la V du rapide si c'est en usinage), que ce soit en manuel ou via un Gcode ...

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Ven 4 Déc 2015 - 20:54

re

j'ai oublié de te répondre au sujet de la doc de CB ; non il n'y a pas de PDF plus récent, désormais il faut soit utiliser le sire Web
http://www.atelier-des-fougeres.fr/Cambam/Aide/Contents.htm

soit l'installer dans Cambam (accessible par F1)
http://www.metabricoleur.com/t8177-cambam-mise-en-place-doc-fr-et-fichier-de-traduction#148623

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Cyrille6901 le Sam 5 Déc 2015 - 6:54

Bonjour David,

Ok pour Cambam, je vais tenter d'intégrer le fichier au programme.

Pour tes pertes de pas, si le phénomène n'est pas trop aléatoire je pourrais peut-être essayer le G-code en question avec les même paramètres machine que les tiens... histoire de voire si le driver digital y change quelque chose, non ?

Si j'ai bien compris c'est toujours en déplacement rapide que cela se produit, je dois donc pouvoir usiner "en l'air".

Par contre la machine n'est toujours pas opérationnelle; j'attends de l'aide pour l'installer sur son support; en principe ça devrait être fait dans les jours qui viennent.

Cordialement. Cyrille

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Sam 5 Déc 2015 - 15:23

Salut

Pour tes pertes de pas, si le phénomène n'est pas trop aléatoire je pourrais peut-être essayer le G-code en question avec les même paramètres machine que les tiens... histoire de voire si le driver digital y change quelque chose, non ?

Avec la PFE, les 2x ou ça s'est produit, c'était en déplacement manuel avec les flèches du clavier ; même pas sur un Gcode (de toute façon pour l'instant tout ce qu'elle à fait c'est les pièces de la télécommande !)

Si j'ai bien compris c'est toujours en déplacement rapide que cela se produit, je dois donc pouvoir usiner "en l'air".

Oui, et quand la machine est froide ; dans le cas présent, je venais juste de référencer et j'ai déplacer mon X pour l’amener au milieu du portique il à bougé de 10cm puis s'est mis à perdre des pas. Bon, ça l'a fait une seule fois, ensuite je l'ai malmené pendant une heure et pas de pb ... Je me suis donc refait un programme de "préchauffage" qui promène les axes de plus en plus vite et qui doit durer 5min ...

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Cyrille6901 le Sam 5 Déc 2015 - 19:20

Bonsoir,

Mais ça serait du à la graisse de lubrification des guidages qui s'épaissierait avec une température basse ? ou bien les moteurs qui n'apprécient pas ?

Cordialement. Cyrille

ps: Mon gentil voisin est venu avec son transpalette éléctrique, ça y est la machine est enfin en place sur son support !

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Sam 5 Déc 2015 - 19:30

Mais ça serait du à la graisse de lubrification des guidages qui s'épaissierait avec une température basse ? ou bien les moteurs qui n'apprécient pas ?

Je ne suis pas convaincu ...... mais quoi d'autre ? ... si ça durci un peu, je passe peut être juste à une dureté qui demande trop aux moteurs, mais pourquoi ça marche sans histoire chez les autres cheers (ou alors ils ne se plaignent pas quand ils ont une perte de pas, peut être !!)

de toute façon, je ne vois pas trop quoi faire d'autre à part essayer les numériques .... changer les moteurs pour plus gros .. ça chiffre (et de toute façon il faudrait aussi changer les drivers, ils sont déjà au max d'A) ... après il y a les servo + encodeur ... mais c'est totalement hors budget !! What a Face

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Cyrille6901 le Dim 6 Déc 2015 - 7:33

Bonjour,

En même temps, 7° ça fait pas beaucoup... y'a pas que les moteurs qui doivent se geler tongue

Lorsque j'aurai tout installé; je peux te proposer d'échanger nos contrôleurs le temps que tu fasses des essais avec les drivers numériques. Par contre je crois que nous ne sommes pas vraiment à coté, moi je suis entre Lyon et Mâcon. Dans tous les cas, n'hésite pas si ça te tente ! Je peux me déplacer, St Etienne ce n'est pas non plus le bout du monde.

Cordialement. Cyrille

Cyrille6901
très actif
très actif

Messages : 397
Points : 589
Date d'inscription : 13/08/2015
Age : 38

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  dh42 le Dim 6 Déc 2015 - 17:49

Salut,

Ici à cette époque, 7° c'est l'Amérique ! ... en principe c'est plutôt -7 dehors et 2 ou 3° dans l'atelier ... mais on s'habitue Very Happy

Merci pour ta proposition, mais ce serait trop galère pour nous 2, le problème étant très aléatoire ça prend du temps pour tester. Je pense que je vais changer progressivement mes drivers ; si j'ai bien compris, les 2 modèles peuvent coexister dans le même contrôleur, donc je pourrais étaler les frais et en plus voir la différence entre 2 axes.

Pour en revenir à un éventuel problème de dureté de la vis/masse à accélérer, je suis de moins en moins convaincu, car (sur la PFE), ça ne me l'a jamais fait sur le Y, qui doit faire dans les 70Kg, par contre, ça me l'ai fait sur le X, qui doit faire dans les 10Kg avec le Z, et pire encore, ça me l'a fait sur le Z en descente .... et il ne demande qu'à descendre ! ...  c'est pour ça que je pense plus à un pb de "qualité" des pulsations envoyées au moteurs.

Je ne pense pas non plus à un problème de puissance d'alimentation ; j'ai remplacé la 6.7A d'origine par une 15A ..

En fouillant sur le site de BZT j'ai d'autre part fini par trouver les caractéristiques des moteurs.



Si j'utilise le calculateur de V maxi, je trouve une valeur de 8.93 Tr/s soit ~536 Tr/min, ce qui ferais un rapide à maxi 5360 mm/min en XY et 2680 pour le Z (mais ça ne dit pas si il reste assez de couple pour maintenir une accélération à 400 à cette vitesse), donc 5000/2500 devrait être un réglage fiable du point de vue de cette limite liée au temps de magnétisation/démagnétisation des enroulements.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12406
Points : 25134
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Hervé-34 le Dim 6 Déc 2015 - 20:27

Bonsoir à tous,

David, il m'est arrivé une belle blague ces jours-ci;

Si tu t'en souvient, ( promis je fait un post la dessus !! )
j'ai une ID, et j'ai fabriqué une petite graveuse, sur le modèle ID.

C'est un peu compliqué à expliquer, mais en ce moment j'ai deux maisons,
( je croise les doigts on a un acheteur pour une !! ) et comme l'ID est
difficile à déplacer, j'ai conçu et fabriqué ma graveuse, là ou je n'ai pas l'ID.

Je l'ai essayée, réglée, tout content avec des guidages à billes, je faisait
bien mes 900 à 1000 mm/mn !! ravi j'étais !!!

Comme il nous semble que nous allons déménager, j'ai rapatrié ma graveuse,
il y a 3 jours, je l'ai remise en route avec un PC identique à celui dont
je me sert pour l'ID, un vieux DELL tout ce qui à de commun ( pas si identique )

Eh bien, pas moyen d'avancer !! je perdais des tours à qui mieux mieux !!
je suis descendu à 200 mm/mn et j'en perdais en accélération!! ( à 8 )
je me suis creusé la tête jusqu'à aujourd'hui !! j'y ai passé des heures !!!
Je lui ai passé ton prog de rodage pendant des dizaines de minutes,
croyant que les vis étaient en cause graissées etc.etc. !!

Jusqu'au moment ou j'ai eu l'idée de simplement brancher ma graveuse sur
l'ensemble PC de l'ID, juste brancher le câble // !!

Eh ben dans les 30 secondes qui ont suivi, j'ai retrouvé mes 900 mm/mn !!
Donc ça venait du PC !! et pourtant je l'ai testé !!

Alors, as-tu le même PC que l'autre machine ? ou est-il plus " faible " pour
la nouvelle ?

Merci de m'avoir lu !

Hervé

Hervé-34
complétement accro
complétement accro

Messages : 1014
Points : 1807
Date d'inscription : 07/07/2014
Age : 65
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Re: Question parcours d'outil

Message  Contenu sponsorisé Aujourd'hui à 21:37


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 4 1, 2, 3, 4  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum