Question parcours d'outil

Page 1 sur 5 1, 2, 3, 4, 5  Suivant

Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Sam 5 Déc 2015 - 15:23

Salut

Pour tes pertes de pas, si le phénomène n'est pas trop aléatoire je pourrais peut-être essayer le G-code en question avec les même paramètres machine que les tiens... histoire de voire si le driver digital y change quelque chose, non ?

Avec la PFE, les 2x ou ça s'est produit, c'était en déplacement manuel avec les flèches du clavier ; même pas sur un Gcode (de toute façon pour l'instant tout ce qu'elle à fait c'est les pièces de la télécommande !)

Si j'ai bien compris c'est toujours en déplacement rapide que cela se produit, je dois donc pouvoir usiner "en l'air".

Oui, et quand la machine est froide ; dans le cas présent, je venais juste de référencer et j'ai déplacer mon X pour l’amener au milieu du portique il à bougé de 10cm puis s'est mis à perdre des pas. Bon, ça l'a fait une seule fois, ensuite je l'ai malmené pendant une heure et pas de pb ... Je me suis donc refait un programme de "préchauffage" qui promène les axes de plus en plus vite et qui doit durer 5min ...

++
David

dh42
Admin
Admin

Messages : 20683
Date d'inscription : 21/06/2009

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Cyrille6901 Sam 5 Déc 2015 - 19:20

Bonsoir,

Mais ça serait du à la graisse de lubrification des guidages qui s'épaissierait avec une température basse ? ou bien les moteurs qui n'apprécient pas ?

Cordialement. Cyrille

ps: Mon gentil voisin est venu avec son transpalette éléctrique, ça y est la machine est enfin en place sur son support !
Cyrille6901
Cyrille6901
acharné du forum
acharné du forum

Messages : 492
Points : 704
Date d'inscription : 13/08/2015
Age : 42

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Sam 5 Déc 2015 - 19:30

Mais ça serait du à la graisse de lubrification des guidages qui s'épaissierait avec une température basse ? ou bien les moteurs qui n'apprécient pas ?

Je ne suis pas convaincu ...... mais quoi d'autre ? ... si ça durci un peu, je passe peut être juste à une dureté qui demande trop aux moteurs, mais pourquoi ça marche sans histoire chez les autres cheers (ou alors ils ne se plaignent pas quand ils ont une perte de pas, peut être !!)

de toute façon, je ne vois pas trop quoi faire d'autre à part essayer les numériques .... changer les moteurs pour plus gros .. ça chiffre (et de toute façon il faudrait aussi changer les drivers, ils sont déjà au max d'A) ... après il y a les servo + encodeur ... mais c'est totalement hors budget !! What a Face

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Cyrille6901 Dim 6 Déc 2015 - 7:33

Bonjour,

En même temps, 7° ça fait pas beaucoup... y'a pas que les moteurs qui doivent se geler tongue

Lorsque j'aurai tout installé; je peux te proposer d'échanger nos contrôleurs le temps que tu fasses des essais avec les drivers numériques. Par contre je crois que nous ne sommes pas vraiment à coté, moi je suis entre Lyon et Mâcon. Dans tous les cas, n'hésite pas si ça te tente ! Je peux me déplacer, St Etienne ce n'est pas non plus le bout du monde.

Cordialement. Cyrille
Cyrille6901
Cyrille6901
acharné du forum
acharné du forum

Messages : 492
Points : 704
Date d'inscription : 13/08/2015
Age : 42

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Dim 6 Déc 2015 - 17:49

Salut,

Ici à cette époque, 7° c'est l'Amérique ! ... en principe c'est plutôt -7 dehors et 2 ou 3° dans l'atelier ... mais on s'habitue Very Happy

Merci pour ta proposition, mais ce serait trop galère pour nous 2, le problème étant très aléatoire ça prend du temps pour tester. Je pense que je vais changer progressivement mes drivers ; si j'ai bien compris, les 2 modèles peuvent coexister dans le même contrôleur, donc je pourrais étaler les frais et en plus voir la différence entre 2 axes.

Pour en revenir à un éventuel problème de dureté de la vis/masse à accélérer, je suis de moins en moins convaincu, car (sur la PFE), ça ne me l'a jamais fait sur le Y, qui doit faire dans les 70Kg, par contre, ça me l'ai fait sur le X, qui doit faire dans les 10Kg avec le Z, et pire encore, ça me l'a fait sur le Z en descente .... et il ne demande qu'à descendre ! ...  c'est pour ça que je pense plus à un pb de "qualité" des pulsations envoyées au moteurs.

Je ne pense pas non plus à un problème de puissance d'alimentation ; j'ai remplacé la 6.7A d'origine par une 15A ..

En fouillant sur le site de BZT j'ai d'autre part fini par trouver les caractéristiques des moteurs.

Question parcours d'outil - Page 2 Pap_bz10

Si j'utilise le calculateur de V maxi, je trouve une valeur de 8.93 Tr/s soit ~536 Tr/min, ce qui ferais un rapide à maxi 5360 mm/min en XY et 2680 pour le Z (mais ça ne dit pas si il reste assez de couple pour maintenir une accélération à 400 à cette vitesse), donc 5000/2500 devrait être un réglage fiable du point de vue de cette limite liée au temps de magnétisation/démagnétisation des enroulements.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Hervé-34 Dim 6 Déc 2015 - 20:27

Bonsoir à tous,

David, il m'est arrivé une belle blague ces jours-ci;

Si tu t'en souvient, ( promis je fait un post la dessus !! )
j'ai une ID, et j'ai fabriqué une petite graveuse, sur le modèle ID.

C'est un peu compliqué à expliquer, mais en ce moment j'ai deux maisons,
( je croise les doigts on a un acheteur pour une !! ) et comme l'ID est
difficile à déplacer, j'ai conçu et fabriqué ma graveuse, là ou je n'ai pas l'ID.

Je l'ai essayée, réglée, tout content avec des guidages à billes, je faisait
bien mes 900 à 1000 mm/mn !! ravi j'étais !!!

Comme il nous semble que nous allons déménager, j'ai rapatrié ma graveuse,
il y a 3 jours, je l'ai remise en route avec un PC identique à celui dont
je me sert pour l'ID, un vieux DELL tout ce qui à de commun ( pas si identique )

Eh bien, pas moyen d'avancer !! je perdais des tours à qui mieux mieux !!
je suis descendu à 200 mm/mn et j'en perdais en accélération!! ( à 8 )
je me suis creusé la tête jusqu'à aujourd'hui !! j'y ai passé des heures !!!
Je lui ai passé ton prog de rodage pendant des dizaines de minutes,
croyant que les vis étaient en cause graissées etc.etc. !!

Jusqu'au moment ou j'ai eu l'idée de simplement brancher ma graveuse sur
l'ensemble PC de l'ID, juste brancher le câble // !!

Eh ben dans les 30 secondes qui ont suivi, j'ai retrouvé mes 900 mm/mn !!
Donc ça venait du PC !! et pourtant je l'ai testé !!

Alors, as-tu le même PC que l'autre machine ? ou est-il plus " faible " pour
la nouvelle ?

Merci de m'avoir lu !

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3064
Points : 4133
Date d'inscription : 07/07/2014
Age : 69
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Dim 6 Déc 2015 - 21:06

Salut Hervé,

Alors, as-tu le même PC que l'autre machine ? ou est-il plus " faible " pour la nouvelle ?

Même PC, même contrôleur, seule la machine change .... et le pb était le même sur la machine précédente ; je pensais juste que les guidages de la PF résistaient trop pour la vitesse demandée, mais sur la PFE ça glisse tout seul ! Le soucis, c'est que tu peux faire 200x le même mouvement et que ça ne bloquera qu'une fois ... ou pas du tout !!

Eh ben dans les 30 secondes qui ont suivi, j'ai retrouvé mes 900 mm/mn !!
Donc ça venait du PC !! et pourtant je l'ai testé !!

Sur que le PC semble aussi avoir son importance, ainsi que ses réglages de base (de windows et du BIOS) ; pour ma part j'ai utilisé 3 PC assez différents, et ça ne semble rien changer au problème. (qui se produit aussi sur les PF)

tu avais copié ton fichier .xml de config d'un PC à l'autre ? .. tu est sur que ce n'est pas un réglage oublié.

Je me souviens d'avoir lu plusieurs fois que des PC semblaient carrément inutilisables pour la CNc, et pas forcément à cause de "trop de modernité" ; pour ma part, j'ai un dual-core récent et un vieux mono-core et le comportement des machines est exactement le même.

Carte mère ou simplement port // défectueux ? ... ça reste une explication pour ton problème. Si tu en a une qui traine, tu peux tenter d'installer une carte PCI-// sur le PC qui ne veux pas.

http://www.ldlc.com/fiche/PB00036506.html

par "testé", que veux tu dire exactement, de quel test s'agit t'il ?. Je doute que ce soit un pb de perf du PC, car avec mach3 réglé à 25000 hz pour le noyau même un PC à 1Ghz à largement assez de rapidité pour gérer des moteurs à 1000 mm/min ... je vois plus une défaillance du port //

++
David



_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Cyrille6901 Dim 6 Déc 2015 - 21:28

dh42 a écrit: ce qui ferais un rapide à maxi 5360 mm/min en XY et 2680 pour le Z (mais ça ne dit pas si il reste assez de couple pour maintenir une accélération à 400 à cette vitesse), donc 5000/2500 devrait être un réglage fiable

Bonsoir à tous,

On est loin des 8000mm/min annoncés alors....

Sinon, je ne serai pas vraiment étonné si il s'agissait tout simplement d'un "bug" de windows ou du PC... et comme toi tu utilises ta machine 8h par jour, forcément ça doit t'arriver plus souvent qu'aux autres qui ont la même électronique.... enfin, c'est juste une idée, mais un ordinateur "grand public", ce n'est pas non plus de la qualité "Arianespace"

Cordialement.Cyrille
Cyrille6901
Cyrille6901
acharné du forum
acharné du forum

Messages : 492
Points : 704
Date d'inscription : 13/08/2015
Age : 42

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Dim 6 Déc 2015 - 22:41

et comme toi tu utilises ta machine 8h par jour, forcément ça doit t'arriver plus souvent qu'aux autres

"Utilisais" serait plus juste, elles ne tournent plus beaucoup depuis quelque temps les machines ; mais c'est vrai que la prod en série à l'avantage d'être un bon banc de test.

On est loin des 8000mm/min annoncés alors....

C'est sur, en fait même si je n'ai pas tenté sur la PFE, sur la PF c'est la limite à laquelle ça ne marche plus du tout ; à 7500 ça arrive à passer 9 x sur 10, à 6000 99x sur 100 ... etc .. ou alors il faut réduire drastiquement l'accélération ; mais en usinage il est plus utile d'avoir une forte accélération qu'une haute vitesse.

enfin, c'est juste une idée, mais un ordinateur "grand public", ce n'est pas non plus de la qualité "Arianespace"

Aussi, resterais à tenter le smoothsteper Ethernet ... peut être un jour ....

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Hervé-34 Lun 7 Déc 2015 - 0:00

Bonsoir à tous,
Bonsoir David,

 
dh42 a écrit:Salut Hervé,


Sur que le PC semble aussi avoir son importance, ainsi que ses réglages de base (de windows et du BIOS)

tu avais copié ton fichier .xml de config d'un PC à l'autre ? .. tu est sur que ce n'est pas un réglage oublié. Non, car comme je ne savais pas quoi copier, je me suis refait les réglages, avec les 2 PC allumés !!

Carte mère ou simplement port // défectueux ? ... ça reste une explication pour ton problème. Si tu en a une qui traine, tu peux tenter d'installer une carte PCI-// sur le PC qui ne veux pas. Je vais de ce pas, en " dépouiller " un pour voir si ça le fait !! sinon, c'est vrai que c'est pas cher une PCI

http://www.ldlc.com/fiche/PB00036506.html

par "testé", que veux tu dire exactement, de quel test s'agit t'il ?.oui, c'est le test que Mach 3 propose pour " tester " le PC  Je doute que ce soit un pb de perf du PC, car avec mach3 réglé à 25000 hz pour le noyau même un PC à 1Ghz à largement assez de rapidité pour gérer des moteurs à 1000 mm/min ... je vois plus une défaillance du port //

++
David



Je te redit ça bientôt,

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3064
Points : 4133
Date d'inscription : 07/07/2014
Age : 69
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Lun 7 Déc 2015 - 0:32

oui, c'est le test que Mach 3 propose pour " tester " le PC

Ok, en fait tout ce que ça teste c'est la stabilité de l'horloge, mais pas le port // (la preuve, je peux le lancer sur mon PC qui n'a même pas de port //).

Pour ma part, après quelques heures de recherches supplémentaires, je pense que je vais privilégier le SmoothStepper aux drivers numériques, ainsi je m'affranchirais complètement des perf du PC et des problèmes liés au fait que la moindre perturbation du système (windows) peux faire perdre des pas (simplement bouger la souris ou pire ce qui marche à tous les coups, trifouiller la vue des parcours sur mach3) ... en plus, le SS me coute moins cher que 4 drivers numériques avec à mon avis plus de chances de solutionner le pb (et en plus ça marche avec un portable, même si ce n'est pas vraiment le but recherché)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Hervé-34 Lun 7 Déc 2015 - 13:11

Bonjour !!!

dh42 a écrit: je pense que je vais privilégier le SmoothStepper aux drivers numériques,

++ David

Tu peux expliquer ce que c'est ? et comment ça marche ? ou comment on s'en sert ??

Je l'ai déjà entendu ce terme, mais je n'y ai rien compris !!

Merci à toi,

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3064
Points : 4133
Date d'inscription : 07/07/2014
Age : 69
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Lun 7 Déc 2015 - 16:13

Salut,

Et bien je ne suis pas électronicien donc je ne pourrais pas rentrer dans les détails ... ni garantir que j'ai tout compris ...

si j'ai bien capté:

Pour faire tourner des PàP, il faut envoyer des impulsions sur les drivers moteur ; chaque impulsion fait tourner le moteur d'un pas (ou fraction de pas si en mode µpas) ; donc le nb d’impulsions donne la distance à parcourir et le temps mis pour envoyer ces impulsions donne la vitesse.

En port //, Mach3 calcule combien il faut d'impulsions et en combien de temps elles doivent être envoyées aux drivers (fréquence), puis créé lui même ces impulsions ; ce qui nécessite une horloge du PC parfaitement stable et qui ne soit pas perturbée par le multitâche de Windows, qui est toujours susceptible de mettre mach3 "en pause" quelques millisecondes le temps de faire autre chose .... et c'est la cata, car les impulsions envoyées par le PC ne sont plus synchro et le moteur perd des pas.

Avec un SmoothStepper (SS), mach3 ne génère plus les impulsions lui même, il ne fait que dire au SS combien d’impulsions générer en combien de temps, et c'est le SS qui crée ces impulsions et les envoi aux drivers (via une BoB). Le SS ne peux donc pas être perturbé par ce qui se passe sur le PC, et bien sur, c'est un circuit spécialement fait pour ce type de job qui génère les impulsions, ce qui n'est pas vraiment le cas d'un port // ; ça permet donc une meilleure gestion des moteurs.

D'un point de vu pratique, le SS est intercalé entre le PC et le contrôleur, et il faut un plugin pour Mach3 pour le gérer. (donc s'assurer que c'est une version compatible)

D'un coté il est relié au PC en USB ou en Ethernet (préférable) et de l'autre, il dispose d'un port // qui se connecte directement au port // de ton contrôleur (BoB). (ça ne remplace donc pas le contrôleur)

Le "vrai" SS dispose de 3 ports // en sortie, ce qui permet en plus de gérer un tas d'entrées/sorties supplémentaires

http://www.ebay.fr/itm/CNC-Ethernet-SmoothStepper-for-Mach3-Mach-4-CNC-Smooth-Stepper-Motion-Control-/271242258619?hash=item3f274c68bb:g:yUAAAOSwQiRUl4sH

voila, si les électroniciens peuvent confirmer, ce serait bien Wink

++
David


Dernière édition par dh42 le Mer 4 Mai 2016 - 18:34, édité 1 fois

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Hervé-34 Lun 7 Déc 2015 - 17:44

!Bonsoir David,

Bon, j'ai à peut près tout compris !! merci !!

Sauf; qu'est-ce que le branchement Ethernet ? ça ce branche où ?

-- sur la photo du lien, je n'ai pas vu de prise pour le branchement du câble // ?
ou alors j'ai pas bien regardé !!

Merci

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3064
Points : 4133
Date d'inscription : 07/07/2014
Age : 69
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Cyrille6901 Lun 7 Déc 2015 - 19:29

Bonsoir tout le monde,

Je ne connaissais pas ce  truc... Si ça marche vraiment ça vaut le coup c'est sûr, même si ce n'est pas donné.

Au sujet des vitesses max et accélérations; j'ai fait quelques essais sur X et Y à 8000mm/min et 500mm/sec en accélération. Visiblement les moteurs ne brochent pas, ça à l'air de marcher; toutefois j'ai remarqué qu'en bout de course (avec limites logicielles), le freinage n'est pas très fluide et ça fait comme des petits a-coups si on regarde de près. Peut être est-ce normal vu la vitesse élevée, le poids du portique et donc le couple demandé au moteur pour le stopper.

Cordialement. Cyrille
Cyrille6901
Cyrille6901
acharné du forum
acharné du forum

Messages : 492
Points : 704
Date d'inscription : 13/08/2015
Age : 42

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Lun 7 Déc 2015 - 20:53

salut

Sauf; qu'est-ce que le branchement Ethernet ? ça ce branche où ?

Câble réseau, c'est une prise RJ45 sur le PC.

Question parcours d'outil - Page 2 80606.image0

Visiblement les moteurs ne brochent pas, ça à l'air de marcher; toutefois j'ai remarqué qu'en bout de course (avec limites logicielles), le freinage n'est pas très fluide et ça fait comme des petits a-coups si on regarde de près.

Tu peux gérer la zone de ralentissement ainsi que la V dans cette zone ; voir ici
http://www.metabricoleur.com/t1578-mach3-branchement-et-parametrage-contacts-home-et-e-stop#19339

++
David




_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Cyrille6901 Lun 7 Déc 2015 - 21:16

dh42 a écrit:salut
Tu peux gérer la zone de ralentissement ainsi que la V dans cette zone ; voir ici
http://www.metabricoleur.com/t1578-mach3-branchement-et-parametrage-contacts-home-et-e-stop#19339

Re,

Pour la taille de la zone j'ai mis comme toi, 50, ça me paraît raisonnable; en revanche je ne vois pas comment agir sur la vitesse dans cette zone (je parle des ralentissement en arrivant pleine vitesse en manuel). Cela semble être une déceleration linéaire sur la zone définie, mais j'ai peut-etre loupé quelque chose.

Cordialement. Cyrille
Cyrille6901
Cyrille6901
acharné du forum
acharné du forum

Messages : 492
Points : 704
Date d'inscription : 13/08/2015
Age : 42

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Lun 7 Déc 2015 - 21:25

Cela semble être une déceleration linéaire sur la zone définie.

Oui, je pense ; plus la zone de décélération est grande et moins c'est brutal.

La vitesse en fait c'est pas la V en freinage, mais la V en référencement. (speed %)  Embarassed

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Cyrille6901 Lun 7 Déc 2015 - 21:39

D'accord,

Par contre, les limites logicielles c'est bien, mais en cas de perte de pas ?

Je suppose que d'un coté le contact bloquera automatiquement la machine, mais pas à l'autre bout. Avec l'ID CNC, ça ne craignait pas grand chose vu la vitesse peu élevée mais là j'avoue que ça me fait un peu peur...

Pourquoi BZT n'a pas installé deux contacts par axe ? Par économie ou bien parce que dans la pratique c'est inutile ?

Cordialement. Cyrille
Cyrille6901
Cyrille6901
acharné du forum
acharné du forum

Messages : 492
Points : 704
Date d'inscription : 13/08/2015
Age : 42

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Lun 7 Déc 2015 - 22:02

Salut,

En cas de perte de pas, oui, ça peut taper.

Je suppose que d'un coté le contact bloquera automatiquement la machine

Non, pas du tout, ce sont des contacts de référencement, pas des fins de course, ils n'ont aucun effet si tu les appui pendant le fonctionnement de la machine.

Si tu a une perte de pas, il faut ramener manuellement tes axes à quelques cm des contacts et relancer un référencement. (et pour que ça tape, c'est une grosse perte de pas ; qui ne passe pas vraiment inaperçue). malgré des pertes de pas, je n'ai jamais eu le souci de taper en butée ; en général je me mange tj une vis de fixation de la pièce avant Very Happy

Le piège c'est si après une grosse perte de pas tu fait un "home", alors la oui, la machine peut taper en butée

Je ne crois pas voir vu la moindre CN du commerce ayant des fins de course, il n'y a que les contacts de référencement (au mieux !)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Hervé-34 Mar 8 Déc 2015 - 19:57

Bonsoir !!

Hervé-34 a écrit:Bonsoir à tous,

David, il m'est arrivé une belle blague ces jours-ci;

Si tu t'en souvient, ( promis je fait un post la dessus !! )
j'ai une ID, et j'ai fabriqué une petite graveuse, sur le modèle ID.

C'est un peu compliqué à expliquer, mais en ce moment j'ai deux maisons,
( je croise les doigts on a un acheteur pour une !! ) et comme l'ID est
difficile à déplacer, j'ai conçu et fabriqué ma graveuse, là ou je n'ai pas l'ID.

Je l'ai essayée, réglée, tout content avec des guidages à billes, je faisait
bien mes 900 à 1000 mm/mn !! ravi j'étais !!!

Comme il nous semble que nous allons déménager, j'ai rapatrié ma graveuse,
il y a 3 jours, je l'ai remise en route avec un PC identique à celui dont
je me sert pour l'ID, un vieux DELL tout ce qui à de commun ( pas si identique )

Eh bien, pas moyen d'avancer !! je perdais des Pas à qui mieux mieux !!
je suis descendu à 200 mm/mn et j'en perdais en accélération!! ( à 8 )
je me suis creusé la tête jusqu'à aujourd'hui !! j'y ai passé des heures !!!
Je lui ai passé ton prog de rodage pendant des dizaines de minutes,
croyant que les vis étaient en cause graissées etc.etc. !!

Jusqu'au moment ou j'ai eu l'idée de simplement brancher ma graveuse sur
l'ensemble PC de l'ID, juste brancher le câble // !!

Eh ben dans les 30 secondes qui ont suivi, j'ai retrouvé mes 900 mm/mn !!
Donc ça venait du PC !! et pourtant je l'ai testé !!

Alors, as-tu le même PC que l'autre machine ? ou est-il plus " faible " pour
la nouvelle ?

Merci de m'avoir lu !

Hervé

 Alors suite de mes aventures, après avoir eu tous ces problèmes,
Comme le conseillais David, j'ai effectivement songé à mettre une
nouvelle carte // !!

 Et puis, comme j'ai une pléiade de vieux PC, j'en ai essayé !!
et au deuxième, miracle !! je suis tombé sur un PC, ouah !!
Je viens de régler ma graveuse, je suis arrivé à des résultats !!

Vitesse ( de pointe ) : 1500 mm/mn
accélération : 50  !!

Alors qu'avec d'autres PC, qui allaient bien ma fois,
j'arrivais à 800 mm/mn !! et à 30 d'accélération !!

Comme quoi le PC compte beaucoup !! tout au moins la carte mère !!

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3064
Points : 4133
Date d'inscription : 07/07/2014
Age : 69
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Mar 8 Déc 2015 - 20:40

Salut,

Et puis, comme j'ai une pléiade de vieux PC, j'en ai essayé !!
et au deuxième, miracle !! je suis tombé sur un PC, ouah !!

Encore un vieux Geek jesors

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Hervé-34 Mar 8 Déc 2015 - 20:47

Salut David,

Mais reconnait que c'est rageant non ? selon le PC que tu as, tu peux avoir
une CNC de Me..e, ou une fusée ?? surtout que ( pour ma part ) je ne saurait
pas reconnaitre une " bonne " carte si je voulais en acheter une pour ma CNC !!

Demain, je met le PC sur mon ID !! je vais voir ce que ça donne !! car en ce moment
je " tourne " à 700 mm/mn et à 25 d'accélération, mais avec l'autre .........

Je fait ce post surtout pour que des collègues ne soient pas déçus par des perfs
faible de leurs CNC alors que c'est peut-être seulement leur vieux PC qui est en
cause !!

Merci à tous

Hervé


Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3064
Points : 4133
Date d'inscription : 07/07/2014
Age : 69
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Mar 8 Déc 2015 - 20:54

Ça pourrait donc justifier l’intérêt d'un SmoothStepper.

un comparaison entre un pilotage direct par Mach3, à la limite de ce que peut faire son PC, et ensuite avec un SS intercalé.



bon, c'est peut être extrême comme exemple mais j'ai bien envie d'essayer ..

apparemment à l'usine BZT toutes leurs machines tournent avec ça (pas le modèle du lien, mais une version pour USBCNC) ; c'est peut être pour ça qu'ils annoncent des vitesses que je n'arrive pas à atteindre de manière fiable ; car à aucun moment dans les infos qu'ils donnent il n'est précisé comment la machine est pilotée ... et si le PC à une telle influence ça expliquerait de telles différences.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  dh42 Mer 9 Déc 2015 - 1:02

Quelques infos de plus

http://cncloisirs.com/Pratique/PilotageMachine

http://cncloisirs.com/Pratique/CommandeDeMouvement

++
David


_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20683
Points : 33390
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Question parcours d'outil - Page 2 Empty Re: Question parcours d'outil

Message  Hervé-34 Mer 9 Déc 2015 - 1:07

Salut David,

Tu ne m'as pas répondu,

Sur ton lien je vois bien la prise Ethernet, mais pas l'endroit ou on branche le câble // ??

J'ai mal vu? ou je me trompe ?

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3064
Points : 4133
Date d'inscription : 07/07/2014
Age : 69
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Page 1 sur 5 1, 2, 3, 4, 5  Suivant

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum