Encore des histoires de référencements !!

Aller en bas

Encore des histoires de référencements !! Empty Encore des histoires de référencements !!

Message  Hervé-34 le Mar 7 Juin 2016 - 20:11

Bonjour à tous,

Je revient sur cette histoire de mon axe ( heu.. le X ?? ( le support de broche !! ) !! )

J'avais surement mal exprimé la chose au croisement d'un post !!

Voila ; pour mes essais et par prudence je fait des référencements un par un
à travers l'écran diagnostics. tout se passe bien et les axes se mettent à zéro.

Mais quand je fait un référencement " général " avec l'écran " automatique "

Le Z se fait, il revient à 0.00 -- le X se fait, clique le contact, se met à 0.00,
et immédiatement revient à 2.00 !! le Y va au contact
et se met à 0.00.

Ai-je mis un décalage quelconque ? si oui où ?? j'avoue qu'en écrivant je me
dit que je n'ai pas regardé sur l'écran décalage !!

Est-ce une piste ?

Merci,

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 2388
Points : 3365
Date d'inscription : 07/07/2014
Age : 67
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Encore des histoires de référencements !! Empty Re: Encore des histoires de référencements !!

Message  Hervé-34 le Mer 8 Juin 2016 - 19:31

Bonjour à tous,

Bon, j'ai regardé partout !! toutes les fenêtres !!
et bien, j'ai pas trouvé de solutions !!

Pourquoi ce X revient systématiquement à - 2.00 alors que les autres
se mettent gentillement à 0.00 ?? j'ai regardé les décalages, rien,

Bref le noir !!

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 2388
Points : 3365
Date d'inscription : 07/07/2014
Age : 67
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Encore des histoires de référencements !! Empty Re: Encore des histoires de référencements !!

Message  dh42 le Mer 8 Juin 2016 - 21:40

Salut,

Bizarre scratch

peut tu me dire ce qu'il y a comme code de programmation dans le bouton référencer:

- menu: opérateur/éditer bouton script -> puis clique sur le bouton référencer qui doit clignoter.

tu devrais avoir:

dobutton(24)
dobutton(23)
dobutton(22)  

si il y a autre chose, efface le, ferme la fenêtre de script et répond OUI quand il te demande si tu veux sauver HidenScript.m1s

PS ici par exemple je donne une macro a athanase pour décaler son Y de 2mm après référencement .... mais je ne vois pas trop comment ça aurait atterrie dans ta config .. scratch (à moins que je t'ai envoyé un écran qui contenait cette modif test par erreur ... c'est possible)

http://www.metabricoleur.com/t7543p20-mechmate-tarnaise-mise-au-point#135040

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16939
Points : 29619
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Encore des histoires de référencements !! Empty Re: Encore des histoires de référencements !!

Message  Hervé-34 le Jeu 9 Juin 2016 - 1:16

Bonsoir à tous,
Salut David !!

Non !! rassure-toi !! tu ne m'as rien envoyé !! ( même par hasard !! )

Non, j'ai ça, et je ne me souvient plus si c'est dès le début des essais !!
Par contre j'ai commencé par ma petite graveuse, et là ça ne le fait pas !
et pourtant, ( il faut que je vérifie ) je doit avoir la même version partout !!

Je l'ai chargée sur une clé une fois pour toute, et je l'ai installée sur mes
PC machine !! je vient de regarder c'est la 3.042.036, donc je vais essayer
la 3.043.062 pour voir si c'est mieux !!

Je regarde ça tout à l'heure !!

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 2388
Points : 3365
Date d'inscription : 07/07/2014
Age : 67
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Encore des histoires de référencements !! Empty Re: Encore des histoires de référencements !!

Message  dh42 le Jeu 9 Juin 2016 - 2:04

Re

Je précise que le code qui fait fonctionner le référencement n'est pas dans Mach3 mais dans les écrans (dans l'écran FR marron), donc changer de version de Mach3 naura pas d'effet si tu utilise les mêmes écrans. vérifie juste que le code de référencement est le bon dans ton écran FR.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16939
Points : 29619
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Encore des histoires de référencements !! Empty Re: Encore des histoires de référencements !!

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum