modification paramètres sunfar

Page 1 sur 3 1, 2, 3  Suivant

Aller en bas

modification paramètres sunfar

Message  silky le Mer 29 Mar 2017 - 18:32

bonsoir
je n'ai pas accès aux modifications des paramètres de mon variateur sunfar E300 2S0015L
j'arrive à faire défiler les paramètres et à visualiser les valeurs mais pas à les modifier
si  quelqu'un avait le même!
merci d'avance

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Jeu 30 Mar 2017 - 16:52

bonjour
personne n'a donc de variateur de broche sunfar?
merci

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Mar 18 Avr 2017 - 18:19

bonjour
je pense que c'est ok
pour accéder aux modifications des paramètres du variateur sunfar il fallait mettre le paramètre F0.10 à "0" et ensuite on a accès à tous les autres!

j'ai vu sur le forum que l'on pouvait piloter la broche de 3 façons:
1- piloter uniquement le M/A via mach3
2- piloter à la fois le M/A et la vitesse de rotation en mode 0-10V
3- piloter à la fois le M/A et la vitesse de rotation en utilisant une interface RS485

pour la solution 2 faut-il installer une carte supplémentaire qui gère le 0-10V ou alors la carte installée dans le contrôleur de chez BZT est suffisante pour régler la vitesse de rotation via Mach3?
merci pour vos réponses

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  dh42 le Mer 19 Avr 2017 - 17:24

Salut,

pour la solution 2 faut-il installer une carte supplémentaire qui gère le 0-10V ou alors la carte installée dans le contrôleur de chez BZT est suffisante pour régler la vitesse de rotation via Mach3?

En principe, si tu a la Benezan que l'on trouve dans les ST4xxx, il n'y a pas de problème.

http://www.metabricoleur.com/t7383p75-choix-et-installation-d-une-broche-cnc-2-2kw-water-cooled#237414

il te faudra aussi commander un mini-relais via la sortie 220 de la broche (la prise à l'ar du contrôleur) pour le M/A broche.

http://www.metabricoleur.com/t7383p50-choix-et-installation-d-une-broche-cnc-2-2kw-water-cooled#237235

attention, les ID de broches sur le vario ne sont pas forcément les mêmes que pour le tiens.

pour le 3, note qu'en plus d'avoir un vario disposant de cette interface, il faut aussi une petite carte RS232/RS485 sur le PC + un plugin pour faire fonctionner le système ... et le plugin doit être fait pour ton vario. Je sais qu'il en existe un pour les Yuanhang, mais je ne sais pas s'il existe pour le Sunfar.

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 16120
Points : 28792
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Mer 19 Avr 2017 - 22:10

bonsoir
merci pour tes réponses David,
je vais mettre tout cela en application après avoir rassembler le matériel adéquat
encore merci

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Ven 21 Avr 2017 - 17:43

bonjour
j'ai fait les tests mais je n'ai pas de variation de tension à la sortie du breakout "0-10V), j'ai toujours 10V
dans mach3 lorsque j'augmente ou diminue la vitesse avec "+" et "-" elle ne reste pas affichée, elle redescend tout de suite à 0
comment sait-on que "step pin" est 17?
merci d'avance

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  dh42 le Ven 21 Avr 2017 - 18:15

Salut,

j'ai fait les tests mais je n'ai pas de variation de tension à la sortie du breakout "0-10V), j'ai toujours 10V

Vérifie que le réglage de spindle pulley est dans une plage compatible avec la broche ; j'ai eu la même blague, la V maxi était réglée sur 2500tr, et bien sur je demandais des valeurs de 5000 à 25000 tr, donc tj > à 2500 et j'avais tj 10v.

comment sait-on que "step pin" est 17?

C'est marqué sur la doc de la benezan, page 3, définition des pins du port //

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 16120
Points : 28792
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Ven 21 Avr 2017 - 18:40

bonsoir
il y a autre chose qui me chiffonne, comme c'est un contrôleur 5 axes j'ai 2 cartes benezan( l'une sur l'autre) car une carte ne peut gérer que 4 axes, je constate que la prise lpt qui est branchée à mon pc est sur la carte supérieure alors que le branchement
0 - 10V est sur la carte inférieure!
maintenant est-ce que les 2 prises lpt doivent être branchées au pc( actuellement je n'en utilise qu'une) dans ce cas il me faut 2 prises à l'arrière du pc et est-ce qu'il y a une configuration initiale à faire lors de l'installation?
et comme il y 2 cartes j'ai les mêmes repères benezan sur les 2!

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  dh42 le Ven 21 Avr 2017 - 18:53

Re

Alors la, je n'ai pas la moindre idée de la façon dont les 2 cartes sont connectées ensemble, mais c'est sur que je brancherais mon 0-10v sur la carte qui est reliée au port // pou essayer.

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 16120
Points : 28792
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Ven 21 Avr 2017 - 21:11

bonsoir
j'ai fait un essai en déplaçant le branchement 0-10V ça ne marche pas non plus, je n'ai pas toujours de tension!
j'ai réinstallé comme avant, je vais voir pour câbler la deuxième prise LPT
non le réglage spindle pulley est correct

dans le tableau configuration/port et E/S / configuration de la broche, il est affiché "contrôle en MLI et non PWN control"  !

- au début de l'installation on installe un fichier(xml) dans mach3, ce fichier ne doit-il pas comporter tout le matériel électrique ou électronique installé sur la machine?

si je veux joindre un fichier j'ai une réponse comme quoi il me reste 711ko d'espace de stockage, dois-je vider mes boîtes de réception, envoi etc...?

y-a-t-il un rapport avec la version d'évaluation de mach3?

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  dh42 le Ven 21 Avr 2017 - 21:49

dans le tableau configuration/port et E/S / configuration de la broche, il est affiché "contrôle en MLI et non PWN control" !

MLI = traduction française de PWM (Pulse Width Modulation = Modulation de largeur d'impulsion)

- au début de l'installation on installe un fichier(xml) dans mach3, ce fichier ne doit-il pas comporter tout le matériel électrique ou électronique installé sur la machine?

c'est le fichier de config, et chaque fois que tu change un réglage dans Mach3 il est mis à jour ; si tu a acheté la machine complète avec le vario et la broche installés, alors oui, ça aurait du être configuré dans le XML que t'a fournis le vendeur.

si je veux joindre un fichier j'ai une réponse comme quoi il me reste 711ko d'espace de stockage, dois-je vider mes boîtes de réception, envoi etc...?

non, c'est les pièces jointes, voir ton profil, onglet fichiers joints, et fait du vide.

note que l'espace est limité à 1Mo (1024ko) par utilisateur.

y-a-t-il un rapport avec la version d'évaluation de mach3?

J'en doute ; en éval, tu est limité à 500 lignes de Gcode et il ne tourne qu'en 25khz, mais ça ne devrait en rien empêcher le fonctionnement du PWM.

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 16120
Points : 28792
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Ven 21 Avr 2017 - 23:00

bonsoir
j'ai reçu celui-ci mais je ne suis pas parvenu à le faire fonctionner
ci-joint le schéma du contrôleur

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  dh42 le Sam 22 Avr 2017 - 0:27

apparemment il y a déjà une prise câblée pour le vario (FU)

je ne vois rien d'anormal sur ton XML, j'ai les mêmes réglages pour mon vario.

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 16120
Points : 28792
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Sam 22 Avr 2017 - 14:55

bonjour
oui pour la prise FU
je vais quand même me procurer une carte pour la deuxième prise LPT car je pense que les infos de cette dernière n'arrive pas au PC, et mon PC n'en est pas équipé!

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  dh42 le Mer 26 Avr 2017 - 21:47

Salut,

En lisant la doc de la benezan, je viens de penser à un truc ; suivant la config des jumpers sur la carte, le signal PWM peut être reçu soit sur la pin 1 soit sur la pin 17 de la carte ; c'est peut être ça qui n'est pas bon ? dans ta config il est envoyé sur la pin 17

pour des drivers leadshine, les jumpers doivent se trouver sur 4-5, 6-7 et 10-11. (le 1 à gauche est dans le vide d'un coté, donc non connecté)

le jumper sur 6-7 active la réception du signal PWM sur la pin 17



++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 16120
Points : 28792
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Jeu 27 Avr 2017 - 12:14

bonjour David
excuses-moi mais je n'ai pas trop bien compris ta réponse
mes jumpers sont comme indiqués sur ton schéma, j'ai noté les numéros(JP1-JP2-JP3-JP4-JP5) pour voir si j'ai bien suivi!
à part le jumper noté "?" qui n'est en fait pas relié puisqu'il n'est que sur une broche! (je ne possède pas ce jumper sur ma carte)


"pour des drivers leadshine, les jumpers doivent se trouver sur 4-5, 6-7 et 10-11. (le 1 à gauche est dans le vide d'un coté, donc non connecté)"
(ps:j'ai copié-collé ton texte car je ne sais pas comment reprendre un texte d'un message!)
qu'entends-tu par 4-5, 6-7, 10-11 est-ce les pins de la fiche LPT?

pour ma part j'ai reçu une nouvelle carte pour rajouter une deuxième prise LPT sur mon pc, mais je ne l'ai pas encore installée
dès que cela sera fait je contrôlerai les tensions 0-10V sur les 2 cartes

merci

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  dh42 le Jeu 27 Avr 2017 - 17:55

Salut,

qu'entends-tu par 4-5, 6-7, 10-11 est-ce les pins de la fiche LPT?

Non, ce sont les broches ou mettre les jumpers (JP1, JP2, etc), le n° 1 à gauche par rapport au schéma ci-dessus.

Si tes jumpers sont bien dans cette position, alors je sèche ... je ne vois pas pourquoi tu n'a pas de variation de tension en sortie de carte scratch

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 16120
Points : 28792
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Ven 28 Avr 2017 - 14:52

bonjour
j'ai fait d'autres essais voici les résultats:
j'ai installé la carte pour la 2ème prise LPT, elle est reconnue par le PC c'est déjà ça!
j'ai donc relié cette carte au contrôleur et j'ai activé le port 2 de la LPT2 et j'ai mis comme adresse celle qui apparaît en premier dans la config du matériel en l'occurrence : "0xccf0"

remarques:
- les leds "1 - 3 - 6" de la carte câblée avec la LPT2 sont toujours allumées (LPT1 et LPT2 branchées ou que LPT1 branchée)
- les leds "3 et 6" de la carte câblée avec la LPT1 sont toujours allumés

- quand la prise LPT2 n'est pas branchée au contrôleur les leds "4 et 5" des relais "1 et 3" sont allumées, j'ai 10V sur les bornes 0-10V des 2 cartes Benezan
- quand la prise LPT2 est branchée au contrôleur les leds "4 et 5" des relais "1 et 3" s'éteignent, j'ai 10V uniquement sur la carte Benezan supérieure c'est-à-dire où est branchée la LPT1

- donc quand j'appuie sur le bouton "broche" de mach3, le relai "1" de la carte câblée avec la LPT1 s'active et sa led s'allume, dans ce cas j'ai une tension variable en fonction du réglage de vitesse dans mach3, plus la vitesse réglée est élevée moins plus la tension se rapproche de 0V aux 2 bornes et vice versa plus la vitesse réglée est basse plus la tension se rapproche des 10V
par contre si je modifie la vitesse dans mach3 avec le bouton"+ ou -", la tension chute à 0

je n'ai fait que des essais à vide c'est à dire sans la broche!
dans mach 3 j'ai mis les réglages préconisés!

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  dh42 le Ven 28 Avr 2017 - 23:00

Salut,

plus la vitesse réglée est élevée moins plus la tension se rapproche de 0V aux 2 bornes et vice versa plus la vitesse réglée est basse plus la tension se rapproche des 10V

Bizarre ! ... Ça marche à l'envers scratch

normalement si ta 'pulley 1' est bien réglée sur 0 à 24000 dans la config, et si la 'pulley 1' est bien sélectionnée dans le panneau 'Réglages' alors tu devrais avoir 0v pour 0 RPM, 10V pour 24000 RPM

(en principe, le fait de sélectionner une poulie dans la liste change automatiquement le réglage dans le panneau 'réglages')

peut être faut il inverser le 'step low active' dans le port&pins (pin 17)

++
David


Dernière édition par dh42 le Dim 30 Avr 2017 - 1:43, édité 2 fois

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 16120
Points : 28792
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  dh42 le Sam 29 Avr 2017 - 6:36

re
jette aussi un oeil ici
http://www.metabricoleur.com/t13407p50-aide-configuration-pfe-1512-pf#262707

j'ai peut être oublié de vérifier que le enable 2 qui est souvent actif sur la pin 17 sur les config BZT soit bien desactivé.

++
david

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 16120
Points : 28792
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Sam 29 Avr 2017 - 23:01

bonsoir
je vais tester cela demain
sinon je vais faire un essai avec une seule carte, donc débrancher la deuxième et tout ce qui va avec, de manière à avoir la bonne configuration de mach3
puis une fois que tout sera OK (j'espère),je verrai ensuite pour la configuration de la deuxième carte
merci

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Mar 2 Mai 2017 - 21:29

bonsoir
j'ai laissé les 2 cartes branchées, mais j'ai déplacé le branchement 0-10V sur la carte supérieure
ci-joints mes réglages:




j'obtiens dorénavant une variation de tension donc une variation de vitesse sur ma broche, mais quand j'appuie sur le bouton "broche" dans mach3, la tension devient 10V et la broche se met à tourner au max, je dois arrêter la broche en appuyant sur le bouton dans mach3 puis je dois appuyer à nouveau sur le bouton "broche" et j'obtiens alors la vitesse choisie.(je n'ai pas vérifié la vitesse réelle de la broche car je n'ai pas de tachymètre, je dois en avoir un à prêter prochainement)
les vitesses affichées par le variateur me semblent de la moitié de la valeur réelle( ex: au lieu de 24000 il est affiché 1200, je n'ai que 4 chiffres sur l'afficheur!)

je pense que cela est encore génant car en automatique, si je veux modifier la vitesse en cours d'usinage la broche va passer par la phase Vmax avant de prendre en compte la modif!

le sens 0 - 10V est maintenant correct(il était inversé auparavant)
j'ai fait un relevé des fréquences obtenues à des vitesses variant de 1000 en 1000 tours:

tout n'est pas encore au top, mais il y a déjà du progrès grâce à vos conseils!

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  dh42 le Mer 3 Mai 2017 - 19:45

Salut,

Que se passe t'il si au lieu de mettre la broche en marche via le bouton M/A broche, tu le fait via l'écran manuel, en rentrant du Gcode à la main dans la ligne de commande ?

S12000 > rotation 12000 tr
M3 > marche
M5 > arrêt

essais de charger un autre jeux d'écran pour voir si le pb est le même.

les vitesses affichées par le variateur me semblent de la moitié de la valeur réelle( ex: au lieu de 24000 il est affiché 1200, je n'ai que 4 chiffres sur l'afficheur!)

Il faut voir si la broche tourne réellement à la moitié de la vitesse, ou si c'est l'affichage qui est mal paramétré.

je ne connais pas les Sunfar, mais sur les Yuanhang, il y a un paramètre à changer pour que les RPM affichés correspondent bien à la vitesse, par contre après un rapide coup d’œil sur la doc, je n'ai rien vu de tel sur le Sunfar (qui ressemble beaucoup à mon FUJI je trouve)

avec le potar, tu avais les bonnes vitesses ?

++
David


_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 16120
Points : 28792
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  silky le Jeu 4 Mai 2017 - 17:55

bonjour David
j'ai eu le tachymètre donc j'ai vérifié les vitesses
les vitesses affichées dans mach3 semble se rapprocher des valeurs lues par le tachymètre
ci-joint le tableau des valeurs relevées

par contre à 1000tr/mn affiché dans mach3 la broche ne tourne pas, alors je n'ai pas fait attention la dernière fois si elle tournait étant trop absorbé par mes relevés!
j'ai essayé avec un autre écran d'affichage je constate les mêmes résultats, j'ai affiché celui avec la modification de la vitesse à l'aide d'un curseur, quand je modifie donc la vitesse, la broche passe en vitesse maxi comme la dernière fois, je dois alors arrêter la broche et redémarrer pour avoir la vitesse affichée dans mach3

j'ai essayé en manuel comme tu me l'a conseillé, j'ai les bonnes vitesses de la broche vérifié au tachymètre, c'est le sunfar qui n'affiche pas les vraies vitesses
avec le potar, l'afficheur du sunfar n'indique pas les vraies valeurs elles sont environ de moitié (vérifié avec le tachymètre)

je n'ai pas trouvé le moyen d'y remédier pour le moment, de toute manière comme c'est un écran à 4 chiffres je ne pourrais pas voir la vitesse réelle, après je devrais peut-être faire un tableau de correspondance et travailler avec la fréquence pour l'affichage, je vais voir!

le problème qui demeure c'est la vitesse qui passe au max quand je modifie la vitesse dans mach3 sans avoir arrêter la broche au préalable
encore merci

richard
avatar
silky
très actif
très actif

Messages : 234
Points : 342
Date d'inscription : 08/10/2013
Age : 63

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  dh42 le Jeu 4 Mai 2017 - 18:32

Salut

le problème qui demeure c'est la vitesse qui passe au max quand je modifie la vitesse dans mach3 sans avoir arrêter la broche au préalable

essais de décocher 'estimation de la vitesse' (je pense que c'est pour les systèmes qui renvoient une info de vitesse, ce que tu ne peut pas faire en 0-10v)



par contre à 1000tr/mn affiché dans mach3 la broche ne tourne pas, alors je n'ai pas fait attention la dernière fois si elle tournait étant trop absorbé par mes relevés!

essai de mettre 'rapport cyclique mini' à 0 (mais de toute façon, il vaut mieux ne pas descendre si bas en vitesse)

Je vois que les vitesses réelles correspondent bien aux vitesses demandées, et avec un faible écart, c'est une bonne chose.

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 16120
Points : 28792
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: modification paramètres sunfar

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 3 1, 2, 3  Suivant

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum