problème de rendu avec openscad

Aller en bas

problème de rendu avec openscad Empty problème de rendu avec openscad

Message  gwez67 le Lun 8 Mai 2017 - 13:43

bonjour tout le monde,

j'utilise avec bonheur openscad mais j'ai assez régulièrement un petit souci de rendu qui apparaît et que je ne m'explique pas scratch

l'ordinateur est sous windows 10 et la carte graphique est une NVidia 840 M.

je précise toutes les mises à jours sont faîtes et que je n'observe ce phénomène qu'avec Openscad.

une fois le rendu lancé, la pièce s'affiche sans problème et puis au bout de quelques minutes, ça donne ça

problème de rendu avec openscad Vue_110

un petit rafraîchissement et ça revient nickel puis ça recommence.

si quelqu'un a une idée où utilise ce logiciel cheers
gwez67
gwez67
très actif
très actif

Messages : 309
Points : 317
Date d'inscription : 21/03/2017
Age : 54
Localisation : france

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  gwez67 le Mar 9 Mai 2017 - 19:27

aucun utilisateur d'openscad sur ce forum scratch
gwez67
gwez67
très actif
très actif

Messages : 309
Points : 317
Date d'inscription : 21/03/2017
Age : 54
Localisation : france

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  momoclic le Mar 9 Mai 2017 - 19:58

Bonjour,
Es-tu sûr d'avoir la dernière version du pilotes de ta carte graphique ?
Même question pour le logiciel, es-tu en possession de la version la plus récente ?
Pour le reste je ne connais pas ce logiciel Wink
momoclic
momoclic
acharné du forum
acharné du forum

Messages : 542
Points : 550
Date d'inscription : 12/10/2016
Age : 71
Localisation : Nantes

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  gwez67 le Mar 9 Mai 2017 - 20:06

merci de ta réponse momoclic hélas oui car c'est la première chose qui m'est venue à l'esprit. Le dernier driver date du 4 mai 2017 c'est tout récent mais ça ne s'est pas amélioré
gwez67
gwez67
très actif
très actif

Messages : 309
Points : 317
Date d'inscription : 21/03/2017
Age : 54
Localisation : france

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  Alain37 le Mer 10 Mai 2017 - 0:15

Bonsoir,

Vois dans les réglages de ta carte graphique ,lequel des réglages conviendrait le mieux:
-open GL
-laisser la carte graphique gérer automatiquement
-ou un autre type de réglage....

Cordialement
Alain
Alain37
Alain37
posteur Régulier
posteur Régulier

Messages : 127
Points : 152
Date d'inscription : 12/12/2011
Age : 72
Localisation : Canton de Chateau Renault

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  gwez67 le Mer 10 Mai 2017 - 8:59

@Alain37, OpenGL est à jour, je suis à la 4.4 sachant que la 4.5 n'est pas supportée par ma carte.

j'ai essayé des tas de réglages mais ça ne change rien et puis surtout c'est qu'il y a 6 mois ça ne le faisait pas donc un problème hardware étant exclu sinon je verrais apparaître des problèmes sur d'autres programmes / jeux hors rien, reste un problème software lié à une mise à jour scratch mais windows faisant ce qu'il veut où à peut prêt ...
gwez67
gwez67
très actif
très actif

Messages : 309
Points : 317
Date d'inscription : 21/03/2017
Age : 54
Localisation : france

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  nono30 le Mer 8 Nov 2017 - 8:25

bonjour gwez67, rassure toi ta carte vidéo va bien, ton problème est connu c'est lié à ce qu'on appelle le Z buffer. Je te donne quelques liens pour mieux comprendre ce qui cloche

https://www.khronos.org/opengl/wiki/Depth_Buffer_Precision

https://fr.wikipedia.org/wiki/Z-buffer

c'est un problème de précision et ton problème doit apparaître plus lors des aperçus F5 et moins lors des rendus F6. Comme tu l'auras compris en lisant les différents articles ça dépend beaucoup de la position et de l'objet lui même.

si tu veux éviter ça, ça c'est vrai que c'est gênant et qu'on fini par ne plus rien voir, arrange toi quand tu peux pour ne jamais avoir des surfaces qui seront sur le même plan. Par exemple lorsque que tu programmes un alésage dans une plaque par différence, fait la hauteur de l'alésage un peu plus grande des 2 côtés (surface entrante et sortante) et ainsi ton affichage sera toujours propre.

si tu as des questions, n'hésites pas.

nono30
nono30
complétement accro
complétement accro

Messages : 1881
Points : 1941
Date d'inscription : 17/07/2017
Age : 51
Localisation : nîmes

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  gwez67 le Mer 8 Nov 2017 - 23:10

bonsoir nono30, bon je vais lire tout ça à tête reposée. En tout cas merci d'avoir pris le temps de me répondre car ce truc me tracasse mais si tu me dis que ma carte n'a pas de souci, déjà c'est pas mal. Si j'ai des questions je reviens vers toi
gwez67
gwez67
très actif
très actif

Messages : 309
Points : 317
Date d'inscription : 21/03/2017
Age : 54
Localisation : france

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  nono30 le Mer 8 Nov 2017 - 23:33

bonsoir

gwez67 a écrit:Si j'ai des questions je reviens vers toi

pas de problème. J'ajouterais à mon explication, car tu dis ds un de tes messages il y a 6 mois tu n'avais pas ce problème, soit tu n'as pas fait gaffe à cela soit tes pièces n'avaient pas d'éléments sur le même plan.
nono30
nono30
complétement accro
complétement accro

Messages : 1881
Points : 1941
Date d'inscription : 17/07/2017
Age : 51
Localisation : nîmes

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  nono30 le Jeu 9 Nov 2017 - 17:39

bonsoir, pour bien comprendre le problème et la solution

le petit bout de code

difference () {
cube (100,100,100);
translate ([ 30, 50, 0]) cylinder (d=20, h=100);

translate ([ 60, 50, -5]) cylinder (d=20, h=110); // la solution un z de 110 pour traverser une pièce de 100
}

ce que ça donne en mode Aperçu F5 (l'ordinateur ne sait pas ce qu'il doit afficher à droite plein où vide ???)

problème de rendu avec openscad Captur12

et en mode Rendu F6 (parce que l'algorithme affiche dans un certain ordre le conflit disparaît mais *)

problème de rendu avec openscad Captur13

*le fait qu'il n'y ai pas de pb d'affichage dans le mode Rendu c'est parce que la pièce est simple et le Z buffer n'est pas saturé.

un site où le problème est très bien expliqué http://raphaello.univ-fcomte.fr/IG/ZBuffer/ZBuffer.htm

voilà Very Happy
nono30
nono30
complétement accro
complétement accro

Messages : 1881
Points : 1941
Date d'inscription : 17/07/2017
Age : 51
Localisation : nîmes

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  gwez67 le Ven 10 Nov 2017 - 7:44

bonjour nono30 et grand merci

c'est clair maintenant entre les liens et ton exemple, c'est devenu limpide. Il faut juste maintenant que je prenne cela en compte lors des conceptions.
gwez67
gwez67
très actif
très actif

Messages : 309
Points : 317
Date d'inscription : 21/03/2017
Age : 54
Localisation : france

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  nono30 le Ven 10 Nov 2017 - 8:48

tant mieux Very Happy

un petit truc qui simplifie bien la vie lors des modélisations

mettre # devant un ligne fait que le volume concerné apparaîtra en rouge lors de l' Aperçu F5.

exemple

le code

problème de rendu avec openscad Captur14

l' Aperçu

problème de rendu avec openscad Captur15

ça permet de voir les positions, les alignements etc

bonne journée



nono30
nono30
complétement accro
complétement accro

Messages : 1881
Points : 1941
Date d'inscription : 17/07/2017
Age : 51
Localisation : nîmes

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  gwez67 le Jeu 30 Nov 2017 - 13:44

bonjour et merci nono30, pas trop le temps en ce moment de passer par ici mais je crois avoir compris la logique
gwez67
gwez67
très actif
très actif

Messages : 309
Points : 317
Date d'inscription : 21/03/2017
Age : 54
Localisation : france

Revenir en haut Aller en bas

problème de rendu avec openscad Empty Re: problème de rendu avec openscad

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum