Mise en route BZT PFL330c

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Mise en route BZT PFL330c

Message  lg01 le Jeu 8 Juin 2017 - 12:04

Bonjour,

J'ai donc acheté une BZT PFL330c, le contrôleur est un ST 43.1, avec le vendeur m'a vendu un PC pour la contrôler, il y a mach3, Cambam, etc... la liaison se fait avec le port parallèle, le PC a une carte vidéo intégrée (j'ai lu je ne sais plus ou que ça n'était pas le top ?).

Tout était censé être "fonctionnel" mais ça c'était dans la conversation !

Donc après avoir reçu ma machine, j'ai tout branché, mis le PC en marche, démarré Mach3, mis en route du contrôleur, chargement d'un G-code de démo et "start"

Bon évidemment, rien ne se passe, je bouquine le manuel mach3 pour voir un peu la configuration.

Alors dans la configuration :
Pour le port, c'est bien le 1 qui est coché avec une adresse 0x378 ce qui parait normal (c'est bien le port parallèle intégré et pas une carte ajoutée et c'est bien adresse donnée dans le panneau de config est 0378 - 037F, paramètres automatiques coché)
La vitesse est de 25000hz

Pour les moteurs :
- X axis : Enabled : ok (vert) - Step Pin# : 2 - Dir Pin# : 6 - Step port : 1 - Dir port : 1
- Y axis : Enabled : ok (vert) - Step Pin# : 3 - Dir Pin# : 7 - Step port : 1 - Dir port : 1
- Z axis : Enabled : ok (vert) - Step Pin# : 4 - Dir Pin# : 8 - Step port : 1 - Dir port : 1
- A axis : Enabled : No (rouge) - Step Pin# : 5 - Dir Pin# : 9 - Step port : 1 - Dir port : 1
Tout le reste est également "Disabled"
D'après mes recherches, ça me parait bizarre d'avoir sur X les pins 2 et 6, sur Y les pins 3 et 7, etc... j'ai plutôt trouvé des couples logiques 2-3, 4-5, etc...

Pour les entrées, je n'ai que l'Estop d'enabled avec le port # : 0 et Pin number : 11
Pareil, ça me parait bizarre, je croyais que le port // est le #1, non pas le 0 ?

Comme j'ai des fins de courses, j'ai tenté de les "auto-détecter", je me suis assuré qu'aucun n'était activé (j'ai lu qu'il pouvais être en série ?), je sélectionne donc le X++ ou le X-- ou le X home, je clique sur l'autoselect et j'actionne le fin de course à la main, rien ne se passe.

De là j'en déduis que j'ai un problème de configuration du port //, je coupe tout, je redémarre et je lance un drivertest.exe mais j'ai un message d'erreur "Mach1 OSX et Driver Loader a rencontré un problème et doit fermer. etc..."

Donc là, je suis dans la mouise car j'ai plus d'idée !!!

Je lance drivertest.exe depuis le répertoire c:\mach3 car je ne peux pas le copier sur le bureau, j'ai un message d'erreur "redondance cyclique" ???? là c'est au-dessus de mes capacités !!!!!!

J'oubliais : dans l'onglet diagnostique, quand j'appuie sur l'arrêt d'urgence ou sur un fin de course, aucune LED ne s'allume, sur le contrôleur ST 43.1 je n'ai pas d'erreur, quand j'appuie sur l'arrêt d'urgence j'ai bien la LED eStop qui s'allume.

Merci d'avance pour votre aide Wink
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Jeu 8 Juin 2017 - 21:52

Salut,

C'est vrai que les n° pour les pin moteur ne correspondent pas à ce qu'il y a habituellement sur les BZT scratch ... ceci-dit, je ne connais pas du tout la PFL.

c'est une machine achetée d'occas ?

X: 3,2
Y: 5,4
Z: 7,6
A: 9,8

step port et dir port à 1 pour tous le monde.

La fréquence devrait être de 45Khz (sinon on ne peut pas atteindre les V maxi)

Pour les entrées, je n'ai que l'Estop d'enabled avec le port # : 0 et Pin number : 11
Pareil, ça me parait bizarre, je croyais que le port // est le #1, non pas le 0 ?

C'est bien la pin 11, mais en port 1

tj en input, tu devrais avoir les contact home

X home enabled, 1, 13
même chose pour Y et Z, tj en 1, 13
rien pour le A

dans les output

output#1: enabled, 1,1 (M/A broche)

charge pump: enabled, 1,16 (sécurité activation des drivers)

tu a quelle version de windows, et quelle version de Mach3.

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Ven 9 Juin 2017 - 6:30

Bonjour David,

Merci pour ta réponse Wink

Alors : Oui c'est une machine d'occaz, avec un win xp pro SP3 et Mach3 ver R2.63

Question bête : Y'a-t-il une séquence de démarrage ?
Je veux dire par là, faut-il démarrer le PC, Mach3, puis mettre le contrôleur sous tension ou au contraire faut-il que le contrôleur soit sous tension avant de démarrer le PC ou Mach3, etc... ?

J'ai également 2 CD livrés avec la machine
Dans le 1er j'ai un dossier "PFL330C_neue Steuerung" et les fichiers suivant :
- Info.txt contenant :
Info
****************************************************
Parameterdateien in den Programmordner kopieren !!!
****************************************************
- WCNCCON.SYS
- Winpcnc.WPI
- Winpcnc.WPW

Le 2nd est un soft "WinPC-NC" Light 2.0

J'ai donc entré les réglages donnés :
X: 3,2 (Step Pin# : 3 et Dir Pin# : 2) J'avais lu/vu l'inverse ?
Y: 5,4
Z: 7,6
A: 9,8 (il faut qu'il soit "Enabled" celui-là ?)

Et les autres !

Ca ne change rien !
Sur les tutoriels vidéo, (Youtube, tuto N2 - config de base à 9:40 environ), quand le gars appuie sur l'AU de la machine il y a le carré rouge qui clignote, pas chez moi !

Bref, j'ai l'impression que je n'arrive pas à communiquer avec la CNC pourtant quand j'allume le PC après le contrôleur (ou redémarrage du PC), la CNC émets des claquements notamment au niveau du Z, enfin on dirai qu'il y a communication scratch scratch scratch scratch scratch
Détail également, quand je lance Mach3, j'ai parfois le message d'erreur suivant : "Mach4 - Failed to create empty document."
Je relance et ça fonctionne scratch
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Ven 9 Juin 2017 - 18:00

Salut,

Question bête : Y'a-t-il une séquence de démarrage ?

En port //, non, ça n'a pas une grande importance, mais en général, on commence par le PC, Mach3, puis on met la machine en route.

Les fichiers que tu a, c'est pour WinPC, pas utilisables avec Mach3

A: 9,8 (il faut qu'il soit "Enabled" celui-là ?)

Si tu n'a pas de 4ieme axe, non, il doit être disabled.

Sur les tutoriels vidéo, (Youtube, tuto N2 - config de base à 9:40 environ), quand le gars appuie sur l'AU de la machine il y a le carré rouge qui clignote, pas chez moi !

Oui, ça indique que l'AU est mis ; Active Low doit être coché en vert dans la ligne Estop du port&pins

voila la séquence de démarrage.









Détail également, quand je lance Mach3, j'ai parfois le message d'erreur suivant : "Mach4 - Failed to create empty document."

Jamais vu ce message ; par contre tu utilise une version antique de Mach3 ; il serait préférable d'installer la dernière version stable.

https://warp9td.com/files/Software/Mach3/Mach3Version3.043.062.exe

Avant de désinstaller/installer, il serait bien de t'assurer que tu charge bien la bonne config machine ; comment lance tu Mach3 ? ; par le 'Loader'  (donc avec choix des machines), ou directement par l'icone Mach3Mill sur le bureau ?

Les fichiers de config machine se trouvent dans le dossier racine de Mach3, avec une extension .xml

Tu peux savoir quelle config est lancée sur l'écran principal de Mach3, dans le champ 'profile' en bas à droite (ici, IDcncPremium, ce qui correspond à un fichier IDcncPremium.xml dans le dossier de Mach3)



++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Ven 9 Juin 2017 - 18:40

Merci David,

Je télécharge la version de Mach3 et je l'installerai lundi, plus là ce week end !

Il faut que je sauvegarde le fichier de licence, Mach3 se désinstalle ensuite depuis le gestionnaire de programme ?

Wink
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Ven 9 Juin 2017 - 18:51

Avant de désinstaller, il faut bien regarder que tu ne perde pas le .xml de config ; regarde ce que tu a comme xml dans le dossier racine.

Il faut que je sauvegarde le fichier de licence, Mach3 se désinstalle ensuite depuis le gestionnaire de programme ?

Oui, et en plus il faut désinstaller le pilote du port //, mais c'est dans le gestionnaire de périphériques (Mach3 pulse engine en principe)

Attention, assure toi que ce n'est pas une licence pirate ! , sinon elle ne marchera pas avec les dernières versions de Mach3 (Papa Fabio)
(menu Help/about > licenced to:)

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Mer 14 Juin 2017 - 19:08

Bonjour,

Me revoilà après 3 jours de galère de business, mais bon !

Voici le bureau du PC :


Ce qui me donne ceci soit sur "Mach3loader" puis "fraisage" ou directement sur "Mach3Fraisage" (je n'ai pas essayé les autres icones) :


Question licence, ça sent déjà moins bon :


Dossier c:\mach3 :


Merci Wink
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Mer 14 Juin 2017 - 20:49

Salut,

Alors : Oui c'est une machine d'occaz, avec un win xp pro SP3 et Mach3 ver R2.63

Ça ne ressemble pas vraiment à Windows XP ... on dirait un Windows 7 scratch

essai le mach3 loader, et regarde si dans la liste il y a la BZT.

sinon si il n'y a pas de profil BZT, alors c'est soit Mach3_mill soit Mach3_fraisage, mais impossible de savoir lequel ton vendeur utilisait.

Tu devrais le contacter pour lui demander, ça éviterais de passer des plombes à paramétrer un truc qui l'est peut être déjà.

Question licence, ça sent déjà moins bon :

Oui What a Face , donc ne tente pas une réinsta car il y a de fortes chance que la licence ne marche pas avec les dernières versions de Mach.

++
David


_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Mer 14 Juin 2017 - 22:20

Je regarderai demain, ça coûte combien une licence ?
De plus j'ai vu que mach4 est sorti ?
Et mach3 sans licence ça n'est pas juste un bridage à 500 lignes ?
Parce que déjà il faut la faire tourner, par la suite si pas trop cher je prendrai la licence.
J'ai laissé un message au vendeur mais je dois bien avouer que je ne suis pas certain qu'il me rappelle...
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Mer 14 Juin 2017 - 23:09

Re

Et mach3 sans licence ça n'est pas juste un bridage à 500 lignes ?

Oui limité à 500 lignes ; je ne sais pas si il y a d'autres limitations.

Parce que déjà il faut la faire tourner, par la suite si pas trop cher je prendrai la licence.

De toute façon, une fois configurée, elle tournera aussi bien sur la v3.043 que sur ta v2.6 le fichier de config est portable donc ce n'est pas du job pour rien.

De plus j'ai vu que mach4 est sorti ?

plus cher, et en plus il faut acheter le plugin pour gérer le port //, qui n'est plus de série .. au total ça doit tourner dans les 230$

Mach3 coute 175$
http://www.machsupport.com/shop/mach3/

++
David


_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Jeu 15 Juin 2017 - 15:27

Bonjour David,

C'est bien un win xp :


Voici ce que j'ai dans le mach3loader :


Pas de nouvelles de mon vendeur, il ne faut pas compter dessus à mon avis et de plus je pense qu'il a formaté avant de me vendre la machine, puis réinstallé vite fait bien [mal] fait !

Laurent
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Jeu 15 Juin 2017 - 16:30

Salut,

Ah ok, ton XP a été customisé Very Happy .. mais bon, c'est un XP français, donc forcément en 32bits ; c'est ce qui m'inquiétait un peu si ça avait été un vrai Win 7 ; la V64 bits ne fonctionnant pas en port //

Bon, donc tu n'a pas des tas de choix de config.

sous windows, si ce n'est pas déjà le cas, active l'affichage des extensions de fichier (.xxx), ensuite vas dans le dossier d'insta de Mach3, localise les 2 fichiers Mach3Mill.xml et Mach3Fraisage.xml, compresse les en .zip et met les en PJ, je regarderais s'il y en a un des 2 qui semble avoir des paramètres en relation avec ta machine.

J'ai vu que ce modèle n'est plus tout jeune ; j'ignore si BZT utilisait déjà les 'standard' actuels en terme de réglage (n° pin moteur, contacts, etc)

Si aucun des 2 fichiers ne semble être prévu pour cette machine, on essaiera avec mon fichier de config de la PF ; avec un peu de chance ça limitera le nombre de trucs à régler Very Happy

à mon avis et de plus je pense qu'il a formaté avant de me vendre la machine, puis réinstallé vite fait

Tu peux savoir quand Windows à été installé:

- ouvre une fenêtre shell (cmd.exe)

- à l'invite de commande tape:

systeminfo | find "installation"



++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Ven 16 Juin 2017 - 7:39

Bonjour David,

Mon windows a été installé le 25/09/2016, donc pas de réinstal récente comme je l'imaginais...

Ci-joint les deux fichiers demandé

Merci beaucoup !

Laurent
Fichiers joints
Mach3fraisage.zip Vous n'avez pas la permission de télécharger les fichiers joints.(32 Ko) Téléchargé 1 fois
Mach3Mill.zip Vous n'avez pas la permission de télécharger les fichiers joints.(11 Ko) Téléchargé 1 fois
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Ven 16 Juin 2017 - 18:29

Salut,

Le plus proche des réglages habituel des BZT, c'est Mach3 Mill, mais il y a quand même certaines choses qui ne sont pas réglées (les limites), et d'autres ou le réglage me surprend. (le steps/per des moteurs)

On va partir sur ce Mach3 Mill comme base de réglage ; essai déjà de voir si la machine bouge avec cette config.

-1) enlève l'arrêt d'urgence (AU) sur la machine

-2) clique sur le bouton AU sur l'écran, il devrais arrêter de clignoter.

-3) essai de faire bouger les axes avec les flèches du clavier.

ce serait bien si tu pouvais faire des photos de l'intérieur du contrôleur, et en particulier, des réglages des drivers (les micro switch) ; des photos de la machine ne seraient pas inutiles, elle n'est pas très connue celle la.

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Sam 17 Juin 2017 - 16:45

Bonjour David,

Merci pour ton aide Wink

Donc j'ai essayé avec Mach3Mill, rien ne bouge avec les flèches du claviers, sur Mach3 les valeurs de X ou Y changent tout comme la valeur "mm/min" dans le carré rouge "Avances", mais rien au niveau matériel :


Question machine voici la bête :


La broche :


Le X avec son fin de course :


Détail du moteur :


Le Y :


Le Z :


L'arrière du contrôleur avec le câblage :


L'intérieur du contrôleur :


Les drivers :


Quand on branche tout (notamment l'AU) ils sont bien alimentés sous 48vcc :


Détail des switchs :


Donc moi pas comprendre, à priori l'alim, les drivers, l'AU, tout semble fonctionner, je ne vois pas ou il pourrait y avoir un pb au niveau du contrôleur (à part les switchs  scratch ), mais je re-précise, quand j'appuie sur l'AU de la machine je n'ai pas ce petit carré rouge qui s'allume dans Mach3 et l'autodetect des entrées m'indique que la configuration du port // du PC ne doit pas être bonne puisque Mach3 ne détecte rien du tout scratch


Merci Wink

EDIT : Après avoir chargé la doc des drivers (http://www.leadshine.com/UploadFile/Down/ME742d.pdf) je ne vois pas ou il y aurai un pb sur les switchs...
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Sam 17 Juin 2017 - 18:14

Salut,

je ne vois pas ou il y aurai un pb sur les switchs...

Le but c'est de savoir comment est réglé le mode de µ-pas, afin de voir si les valeurs pour le Steps/per sont correctes (calibration des axes) ainsi que les valeur d'intensité moteur ; mais on n'en est pas encore la ! , il faut déjà qu'elle bouge avant de vérifier ça. Je voulais aussi savoir si l'électronique était la même que dans les BZT plus récentes ; à peu de chose prêt, c'est le cas.

Vas dans Motor Tuning, et remplace les 2 valeurs qui sont à 0 dans Step pulse et Dir pulse par 4, puis clique sur 'save axis settings' ; ce n'est a faire que pour un axe, les valeurs sont communes aux autres axes.

Dans port&pins, onglet input signals

x home, y home, z home et E-stop doivent avoir Active Low coché en vert.

même chose dans Output signals, Charge pump doit avoir Active low coché en vert.

assure toi que Activer Limites ne soit pas allumé (écran principal)

Dans le panneau de config de Windows, vérifie que le port // est bien activé et ses drivers installés.

Au même endroit, vérifie qu'il y a bien le 'Mach3 pulse engine' (c'est le pilote du port // installé par Mach3)

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Lun 19 Juin 2017 - 9:31

Salut David,

Vas dans Motor Tuning, et remplace les 2 valeurs qui sont à 0 dans Step pulse et Dir pulse par 4, puis clique sur 'save axis settings' ; ce n'est a faire que pour un axe, les valeurs sont communes aux autres axes.

Fait !

Dans port&pins, onglet input signals

x home, y home, z home et E-stop doivent avoir Active Low coché en vert.

Fait !

même chose dans Output signals, Charge pump doit avoir Active low coché en vert.

Fait !
Par contre pour "Output #1" "Active Low" n'est pas coché en vert

assure toi que Activer Limites ne soit pas allumé (écran principal)

Fait !

Dans le panneau de config de Windows, vérifie que le port // est bien activé et ses drivers installés.
Voici ce que j'ai :






Au même endroit, vérifie qu'il y a bien le 'Mach3 pulse engine' (c'est le pilote du port // installé par Mach3)

C'est où ça ????

Merci

Laurent
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Lun 19 Juin 2017 - 17:37

Salut,

C'est où ça ????



Ne le désinstalle pas, contrôle juste qu'il est installé.

Par contre pour "Output #1" "Active Low" n'est pas coché en vert

Oui, c'est normal (c'est le relais de M/A Broche)

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Lun 19 Juin 2017 - 19:56

Bonjour David,

Bon, voilà d'ou vient le 1er problème à mon avis :


Laurent Wink
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Lun 19 Juin 2017 - 21:28

Ah oui, sans les pilotes ça ne risque pas de marcher en port // Very Happy

il va falloir télécharger la même version de mach3 que tu a, et la réinstaller par dessus.

on trouve les vielles versions sur le FTP de Mach3 (onglet FTP download)
http://www.machsupport.com/software/downloads-updates/

assure toi que l'insta du driver est cochée.



++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Lun 19 Juin 2017 - 22:33

Ok, c'est téléchargé j'installe ça demain Wink

Comme dit plus haut, je sauvegarde les fichiers de configuration .xml la licence et je re-instal par dessus ou si il faut d'abord tout désinstaller ?

Laurent
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Lun 19 Juin 2017 - 22:45

Il faut juste réinstaller par dessus, pas besoin de désinstaller.

ceci dit, ça ne coute rien de sauver le xml et le licence Wink on ne sais jamais !

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Mar 20 Juin 2017 - 18:38

IT'S ALIVE !!!!!!!!!

YES !!!!!!!!

Ca roule !!!

Merci David !




Enfin :


Bon, maintenant que ça bouge, je vais tenter de valider le sens de rotation de mes axes, calibrer les limites dans Mach3, essayer de comprendre comment on gère les vitesses d'avances, faire un programme simple pour procéder à un essai, j'ai tout bon ou si j'ai oublié des étapes essentielles ?

En tout cas merci encore David Wink

vive le faux rhum cheers cheers cheers cheers cheers
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  dh42 le Mer 21 Juin 2017 - 1:02

Salut,

Good news cheers

Il était doué ton vendeur pour arriver à la faire marche sans le pilote Very Happy

Bon, maintenant que ça bouge, je vais tenter de valider le sens de rotation de mes axes, calibrer les limites dans Mach3, essayer de comprendre comment on gère les vitesses d'avances, faire un programme simple pour procéder à un essai, j'ai tout bon ou si j'ai oublié des étapes essentielles ?

Alors le plus simple c'est de se faire le menu config dans l'ordre pour ne rien oublier. (ou essayer !) de select native units à homing/limits.

pour le coté confort, déjà on va mettre l'affichage en Français ; menu View/load screen, et cherche un fichier appelé Mach3FR-Fraisage.set (dans le dossier d'insta de Mach3) çà te remettra l'interface marron FR que tu avais.

si ton écran est écrasé en hauteur, menu config/general config > décoche Auto screen enlarge, et redémarre Mach3.

un truc qu'il faudra faire dès que tes axes tourneront dans le bon sens, et avant même de t'occuper des limites, c'est de vérifier la calibration des axes, autrement dit de vérifier si quand tu te déplace de 50mm sur Mach3 (visu) tu a bien les 50mm de déplacement sur l'axe en question ; sans te prendre la tête avec les 1/10iemes, c'est juste pour voir si les réglages ne sont pas carrément dans les choux, et si c'est le cas, en général tu te retrouve avec de gros écarts (souvent du simple au double). Le calibrage fin se fera en dernier si ça s'avère utile.

concernant tes drivers, sur cette image on peux voir qu'ils sont réglés en 4.2A en 1/4 pas (800 pas/tr) et le courant de maintient est sur 50% ; donc le réglage est OK.



http://www.leadshine.com/UploadFile/Down/ME742d.pdf

Par contre les réglages du steps/per des moteurs dans Mach3 (motor tuning) me semble sans rapport avec cette machine .. ou il y a un truc que je ne pige pas !

d'après la doc BZT, les vis sont censées être du TR 12x3, donc pas de 3 ; avec un réglage des drivers en 1/4 de pas ; le steps/per de chaque axe devrait donc être de 266.6666... et non de 2000 comme sur le fichier  scratch

soit prudent quand tu fera bouger les axes, il y a de forte chances que les déplacements soit 10x plus importants que demandés avec cette valeur de 2000

http://www.ebay.de/itm/CNC-Fraese-Fraesmaschine-BZT-PFL330C-Steuerung-Software-/310317854771

Quand aux valeurs de vitesse (velocity) et accélération ; elles ont complètement à l'ouest (c'est des valeurs pour les machines en pouces) ; je doute franchement que ton vendeur ai jamais utilisé aucun des profils machine qui se trouvent sur le PC ... (voir même la machine elle même ; ou alors il utilisait un autre soft de pilotage)

dans velocity, met 2000 pour X et Y, et 1000 sur Z
dans acceleration, met 200 pour tout le monde (il faudra peut être y revenir plus tard)

pour chaque axe, il faut sauver avec le bouton save axis settings

Elle est sympa cette petite machine, je ne connaissais pas ce modèle. Les nouvelles PFL n'ont pas du tout la même tronche.

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13901
Points : 26635
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mise en route BZT PFL330c

Message  lg01 le Mer 28 Juin 2017 - 12:35

Merci David,

L'interface était resté en FR, pas de soucis là dessus.

J'ai rentré tes valeurs (266.66 pour le STEP, 2000 pour X et Y et 1000 pour Z pour la vitesse, 200 en accélération), maintenant quand je lance un G0 X50 par exemple, elle avance de 50mm (c'est dingue Very Happy )

Par contre les zéros sont où généralement ?
Sur le Z, quand il est en haut j'ai un fin de course, je me mets 3mm en dessous et je fixe le zéro, donc je n'ai que des valeurs négatives pour Z et si on dépasse et qu'on vient activer le fin de course, la machine s'arrête (quand on a activé les limites).
Sur X et Y, le zéro se calibre vers les fdc, donc on aura que des valeurs positives ou négatives suivant les sens de rotation, ou au milieu de l'axe ?

Wink
avatar
lg01
petit nouveau
petit nouveau

Messages : 18
Points : 22
Date d'inscription : 08/06/2017
Age : 41
Localisation : Ain

Revenir en haut Aller en bas

Page 1 sur 2 1, 2  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum