apparition de nouveau probleme palpeur et message sur mach3

Page 1 sur 2 1, 2  Suivant

Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Mar 1 Aoû 2017 - 18:48

bonjour à tous
me croyant enfin à l'abri de nombreux soucis avec mon nouveau matériel et mach3, en voici des nouveaux auxquelles je cherche des solutions. scratch
1, le palpeur = mach3 ne prend pas en compte l'ordre de positionnement aprés palpage. j'ai changé le fichier mach3fraisage.set comme l'indique le revendeur de licence francais sur son site mach3fr =rien non plus. aprés palpage la remonté de z ne s'arrète plus et s'envole vers les cieux !
2, ma machine est equipé maintenant d'une nouvelle carte usb mk4. et maintenant en cours de lecture de programme d'usinage, mach3 s'arrète et indique "Need help - Is the Xpod inserted OK? it has ceased to respond"
j'ai lu des info sur ce problème sur d'autre site, notemment mise à la masse broche, carte de pilotage usb etc... sauf que tout est déjà à la masse donc le soucis est ailleurs je pense mais où ????? je ne trouve pas aprés réflexion et recherche.
3, n'arrivant pas à piloter ma broche avec le PWM de ma carte usb pour je ne sais quelle raison car j'ai vérifié mon cablage et programmation vfd ?????, j'ai recours au pilotage par rs485. (sauf que depuis nouvelle carte usb, le plugins de matty ne fonctionne plus (les "99" restent grisé) et maintenant c'est celui de royaume éole qui accepte de fonctionner seulement si je met "0" dans estop threhold ( clignotement de la fréquence de rotation ???)au lieu de 8 ou autre= broche ne fonctionne pas !
par contre tjrs aucun soucis avec l'exellent programme spindel talker V2 !
je recherche donc infos et solutions, aide pour résoudre ces derniers déboires avec les trop nombreux caprices de mach3.
un grand merci par avance.



gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Mer 2 Aoû 2017 - 17:02

Salut,

1, le palpeur = mach3 ne prend pas en compte l'ordre de positionnement aprés palpage. j'ai changé le fichier mach3fraisage.set comme l'indique le revendeur de licence francais sur son site mach3fr =rien non plus. aprés palpage la remonté de z ne s'arrète plus et s'envole vers les cieux !

Je ne peux pas garantir que ce soit ça, mais certaines cartes USB Chinoises ne gèrent pas certaines variables internes de Mach3 (position de l'axe lors du contact) et cette variable peut donc contenir n'importe quelle valeur aléatoire ce qui fait que l'axe Z peut remonter en buté, ou au contraire descendre et écraser le palpeur.

Tu peux tenter de régler ça en éditant le code de programmation du palpage.

Menu operator/Edit button script > le(s) bouton(s) Palper vont clignoter ; clique sur le bouton palper que tu utilise et dans le code, remplace

ZPALP = GETVAR(2002)

par

ZPALP = GETOEMDRO(802)

puis sauve le script avec file/save

Pour le reste, je ne connais pas ta carte ; peux être y a t'il une déconnexion USB en cours de route, une faiblesse de l'alim si elle est alimenté séparément, un mauvais contact du cable USB (ou trop long = parasitage) ..

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Mer 2 Aoû 2017 - 19:18

merci david pour ta réponse. je vais essayer d'appliquer ta solution dés que ça refonctionnera. car ce soir plus rien ne fonctionne apres réinstallation et reprogrammation pour tenter de trouver les faiblesses et disfonctionnement. cela fait 1 an et demi que ma machine devrait produire.. maintenant je sais que c'est pas encore pour demain à la vue de mes nouveaux déboires de ce jour. pffffff violent embarras mess
gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Mer 2 Aoû 2017 - 19:49

ce soir plus rien ne fonctionne apres réinstallation et reprogrammation pour tenter de trouver les faiblesses et disfonctionnement.

Si tu veux faire des économies de coiffeur, achète une CNc Very Happy jesors

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Mer 2 Aoû 2017 - 20:18

je pense plutôt arrèter la cnc ou mach3 au profit d'un soft comparable. j'ai beau faire ce qu'il faut, la partie électronique un peu mais surtout l' informatique n'arrète pas de me nuir. dommage que je connais personne prés de moi pour me seconder car plus j'avance moins je m'y retrouve. ou bien c'est encore le matériel neuf qui encore une fois est défectueux ou incompatible avec PC ! ça serait la gigne scratch
je pourrai effectivement acheter une cnc mais si j'ai construit la mienne, c'est que dans le commerce ou chez les amateurs je ne trouve pas l'objet de mes désirs. puis j'y tiens à mes cheveux !
cdt
gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Mer 2 Aoû 2017 - 21:07

Salut,

je pense plutôt arrèter la cnc ou mach3 au profit d'un soft comparable.

Oui, mais lequel ? .. ta carte est faite pour Mach3, elle ne sera pas gérée par LinuxCNc, ni par USBCNC (Eding CNc) ... donc obliger de changer encore d'électronique.

Pour ma part, j'ai préféré y mettre le prix et avoir du matos 'connu' et réputé fiable, comme le Smoothstepper Ethernet (Warp9) par exemple, que j'ai ajouté suite à mes soucis de port // ; c'est sur que c'est pas donné par contre. (et il ne remplace pas la BreakOut board, il viens juste s’intercaler entre la BoB en port // d'origine et le PC en port Ethernet)

Ma BoB (d'origine dans le controleur BZT)
https://www.sorotec.de/shop/Breakout-Board-Advanced-PRO.html

Le SmoothStepper Ethernet
http://www.cnc-shop.ch/interface-ethernet.htm

Mes drivers sont de banals LeadShine M542
https://www.sorotec.de/shop/M542-V2-0-Leadshine-20-50VDC-1-0---4-2A.html

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Mer 2 Aoû 2017 - 21:17

http://www.cnczone.com/forums/omni-cnc/325088-cnc-software.html

http://www.mycncuk.com/threads/11042-Machine-keeps-stopping

http://www.cambam.co.uk/forum/index.php?topic=6537.msg52566#msg52566

dans tous les cas, il semble que ce soit un pb de parasitage de l'USB

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Mer 2 Aoû 2017 - 21:47

apres avoir testé ma precedente carte usb, je me suis laissé tenté par la mk4 car une de mes connaissance la possède avec ça cnc qu'il a acheté en direct de chine et personnalisé avant de passer commande. les mouvements étaient trés fluides, vitesse en prise directe jusqu'à 600mm/min, tout les paramètres et programmation faitent en usine. tout fonctionnent superbement bien. il en est super content.
j'ai testé 2 cartes port // mais passé les 1500mm/min il y avait de décrochage ou grognement, puis lors du mouvement il y avait des micros coupures ou comme des pic de tension (dont j'ignore la cause une fois de plus). puis il y a eu les problèmes de faire fonctionner la broche via mach3 par rs485 car pas de pwm avec la premiere carte //. voulant du moderne et du réputé bon fonctionnement j'ai pris la décision de mettre à jour mon équipement ce printemps ci. maintenant que j'ai de nouveaux drivers, de nouvelles alim de 36 passer à 48v et la nouvelle carte usb mk4 pour m'affranchir du port//, et qui j'avoue au premier essai a transformé le fonctionnement de ma cnc de façon signifiante. sauf que le pwm je n'arrive pas à le faire fonctionner et que j'ai découvert le soucis du palpeur cette semaine. en ce qui concerne la commande de broche par rs485 étant un soucis n'appartenant qu'a mach3. samedi je retourne à l'atelier et je vais tout reprendre depuis le début car j'ai dù mal faire quelque chose, sinon j'emmene un autre pc car je me pose des questions sur celui de l'atelier.
si la solution du palpeur fonctionne, ma cnc sera opérationnel mais pas parfaite pour autant. j'espère juste commencer tres vite mes travaux d'usinage dont les projets s'accumulent à la queue leuleu. je vais peut être me remettre à cambam car il y a des choses que je ne comprend pas avec mastercam 2018, bien que les gcodes fournis fonctionnent en simulation. mais je n'arrive pas à comprendre comment on fait des pénétration hélicoïdale avec rampe ou du débourage en mode perçage. puis la doc est inexistante et rien dans les tutaux et vidéos. ggrrrr
cdt
gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Mer 2 Aoû 2017 - 21:55

j'ai testé 2 cartes port // mais passé les 1500mm/min il y avait de décrochage ou grognement, puis lors du mouvement il y avait des micros coupures ou comme des pic de tension

Oui, j'ai eu les mêmes soucis ; le pilotage par le port // est assez aléatoire ; ça marche bien avec certains PC et pas avec d'autres ... pour des raisons mystérieuses (ça ne viens pas de la BoB, mais du PC ... et j'en ai essayé 3) ; c'est la raison pour laquelle j'ai intercalé l'ESS, ainsi ce n'est plus Mach3 qui génère les signaux moteur, mais la carte ... et ça change tout, la ou j'étais limité à 4000 mm/min 300 mm/s² en port // direct et pas tj fiable, je suis maintenant à 7500 mm/min 500mm/s² et ça marche nickel, plus de ratées, de petits bruits bizarres ou de blocages nets ...

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Mer 2 Aoû 2017 - 22:11

Pour tes problèmes de déconnexion USB, vérifie la qualité de ton câble, et surtout des contacts ; un exemple, j'ai 2 clefs USB de qualité (contacts dorés), et je n'ai jamais eu de problèmes avec pourtant elles ont des années de service, par contre j'ai un adaptateur USB/SD de m** fourni avec mon imprimante 3D qui à tout juste un an, et j'ai souvent des déconnexions, ou même la clef n'est pas reconnue, et si on regarde les contacts, ils ne sont pas dorés .. je dois gigoter la clef dans le port USB pour qu'elle se reconnecte .... il suffit d'un rien pour que ça merde ces machines ... qualité des contacts, blindage, mises à la masse/terre, longueur du câble USB, poussière dans les ports ... tu ne serais pas le 1ier à t'arracher les cheveux à cause d'un petit détail de ce genre.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Jeu 3 Aoû 2017 - 20:24

salutation. je suis retourné à l'atelier cette aprés midi et j'ai fait du ménage dans le pc et tout ré-installé comme il faut et sans doublon de mach3 (installé autre part pour récupérer un fichier originel, et ça ne fait pas bon ménage à 2 sur un PC). tout à parfaitement fonctionné mise à part que je suis revenu à 1500mm/min (au lieu de 2500 désiré) comme avance car la machine étant lourde et possède de l'inertie, mon moteur Z décroché en sortie rapide d'usinage d'un programme d'essai en l'air. reste plus qu'à solutionner mon soucis de PWM pour ma broche dés que j'en aurait le courage.
il se peut vraisemblablement que j'ai homis un parametre dans mon VFD et faut que je retrouve dans la doc tous les paramètres autres que PD01 et PD02 pour pilotage broche par pwm.
merci à toi david pour ta solution de réglage palpeur. c'est nickel, ça marche !
pour en revenir à ta constitution de cnc, donc tu pilotes ta BOB par cable // mais tes drivers sont commandé par ta BOB secondé de ton ethernet via une liaison USB ou cable ethernet au PC.
ça fait un peu machine à gaz mais je suis mal placé. car dans mon armoire j'ai une BOB classique monté en secours si ma carte USB MK4 venait à faire défaut. celle si est commandé en amont entre elle et le pc d'un boitier IPL5X. cette dernière me permettant avec les excellents logiciels fourni, de faire de la découpe fil chaud et piloté une cnc 3 axes autre que par mach3 (oui j'avais oublié que j'avais cette possibilité quand je disais vouloir abandonner mach3 pour un autre log !). le fait est que je me consacre uniquement à mach3 que j'en oublie de essayer IPL5X voir si lui fonctionne !
ce WE j'essaierai pour voir si j'ai le temps.
cdt
gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Jeu 3 Aoû 2017 - 21:02

il se peut vraisemblablement que j'ai homis un parametre dans mon VFD et faut que je retrouve dans la doc tous les paramètres autres que PD01 et PD02 pour pilotage broche par pwm.

http://www.metabricoleur.com/t13407p125-aide-configuration-pfe-1512-pf#263122

pour en revenir à ta constitution de cnc, donc tu pilotes ta BOB par cable // mais tes drivers sont commandé par ta BOB secondé de ton ethernet via une liaison USB ou cable ethernet au PC.

Oui, ainsi je n'ai rien modifié à mon contrôleur, la carte (en version boite) est juste intercalée entre le PC et la BoB ; et cerise sur le gâteau, il n'y a rien à changer dans mes réglages Mach3 par rapport au pilotage en port // (si ce n'est que je peux utiliser des V et accélérations plus élevées)

apparition de nouveau probleme palpeur et message sur mach3 Ess210

apparition de nouveau probleme palpeur et message sur mach3 Ess110

++
David




_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Jeu 3 Aoû 2017 - 22:01

fort interessant ton montage. si j'avais su cela plus tôt peut être que j'aurai réfléchi à 2 fois avant l'achat de carte usb.
merci pour le lien, cela confirme que je ne me trompe pas avec les réglages de mon VFD. chose stupide que je n'ai pas encore faite est celle de tester mon voltage en sortie PWM. faut que j'identifie la cause de ma panne. surtout qu'avec ma carte MK4 je pourrais aussi piloter mon tube laser en analogique car elle accepte aussi bien le 0-10v que le 0-5v en commande analogique. je pourrai finalement faire de la gravure en nuance de gris sur ma principale cnc. héhééee
sinon ce laser était simplement destiné à la découpe et éventuellement en gravure simple par commande TTL. pour faire de la gravure artistique et reproduction de photo, j ai commencé à me construire une autre machine sur le principe de celle de gravure par diode laser de quelques watts en transmission de mvt, mais capable de graver sur 1m carré, piloter par mach3 plutôt que les montages proposé sur base GRBL diy, et utilisant aussi un tube laser de 40W. mais pour la terminer faut que ma cnc principale fonctionne, puis que je réalise aussi trés vite comme premier travail d'usinage mon imprimante 3D maison, car ensuite j'aurai des pièces plastique à produire pour réaliser cette machine laser et peut être que j'équiperai ton module ethernet cette machine car je dois avoir des mouvement fluide et des hautes vitesses de mouvement. à savoir si c'est compatible avec le BOB chinoise bon marché ou s'il faut aussi la même BOB que toi ?
en tout cas que du boulot en perspective. cheers
au plaisir
gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Jeu 3 Aoû 2017 - 22:53

Salut,

à savoir si c'est compatible avec le BOB chinoise bon marché ou s'il faut aussi la même BOB que toi ?

Je ne sais pas, je n'y connais rien en électronique ; j'ai cru comprendre que la vitesse des optocoupleurs de la BoB pouvait être un frein si tu veux la faire tourner à haute fréquence, mais dans quel ordre de grandeur, je ne sais pas ; en tout cas, l'ESS semble fonctionner sur d'autres BoB, y compris Chinoises. Par contre, bien prendre la version Ethernet, elle est un poil plus cher, mais plus fiable que la version USB (en fait c'est surtout Windows qui gère mal les USB, et l'USB c'est facilement parasitable contrairement à l’Ethernet )

Il y a surement des BoB qui marchent bien sans couter aussi cher que la benezan ; je trouve d'ailleurs qu'ils abusent un peu sur le tarif pour une BoB aussi simple What a Face

le site de Warp9 (le 'vrai' smoothstepper) ça t'en dira peut être plus

https://warp9td.com/

apparemment l'ESS/USS n'est pas très regardant ; ils proposent des BoB à 9$ (c13) dans les produits qu'ils connaissent ('Please keep in mind that we are not endorsing any particular BOBs, but rather letting you know which ones we know of. ')

https://warp9td.com/index.php/bob-vendors

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Sam 5 Aoû 2017 - 20:27

salutation, aujourd’hui hui mon premier usinage avec ma cnc ......super ! et en plus je fait mon maxi bâtis de imprimante 3D et ce en presque toute confiance....première planche impeccable mais lors d'un arrêt intempestif en début d'usinage dû à ma carte usb avec le fameux message "is the Xpoinserted ok?....." j'ai branché un fil direct de la prise PE de ma carte usb à une fiche de terre de ma prise multiple. du coup plus de soucis avec ça.
j'attaque ma seconde planche avec le même cycle d'usinage. 1er job cycle de perçage que je termine avec difficulté car à de nombreuses reprise (3/4) j'ai des arrêts d'urgence intempestives qui se manifeste. après changement d'outil et palpage, impossible de faire quoi que ce soit dans le second cycle de contournage. dés que j'active la relance du programme = arrêt d'urgence et aucune anomalie dans fenêtre diagnostique mach3. j'ai écarté mon câble usb des fil électrique, mon boitier VFD est à 1.5m de l'armoire électrique /électronique et séparée par la table d'usinage, la broche est à + de 70/80cm et consomme 2 à 2.5 A maximum, l’armoire électrique possède une cage de faraday, l'arrivée du jus est filtré, tout relier à la terre par les fiches terre des prises. même aprés un pause en arrêtant tout sauf PC, ça ne repart pas. et je suis sûr que demain matin ça repartira nikel jusqu'à ce que le phénomène se re-manifeste.
plusieurs pistes à voir:
A,mes prises de terre par fil électrique sont mauvaise ou quasi inexistant= inefficace.
B,je dois retirer mes 3 alimentions spèciale cnc (2x 48v et 1X 24v) de mon armoir électrique /électronique.
C,tirer un câble de grosse section jusqu'à dehors et relier à une barre de fer plantée dans le sol, pour ma super mise à la terre.
des suggestions, des recommandations, des ordres à donner des travaux à faire, autres ? je suis preneur de tout !
merci par avance. cdt
gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Sam 5 Aoû 2017 - 22:33

Salut,

Un truc à vérifier, regarde que dans Config/general config, Use watchdog soit décoché (colonne de droite en haut).

Ça peut faire une erreur 'watchdog triggered' dans la barre de status de Mach3. (et la machine s'arrête)

Ta carte USB, elle a une alim séparée, ou elle est alimentée par le PC ?

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Sam 5 Aoû 2017 - 23:17

wathdog n'est pas activé, et la carte possède une alim spécifique (alim cnc de 24v 1 A) pour son fonctionnement et celui des accessoires dont elle gère (relais, fin de course). pour dire, j'ai déjà remarqué ce phénomène lors de précédente manipulation voici un an ou plus lors de transformation et amélioration de ma cnc (c'es le même phénomène qui perturber à cette époque plus le fonctionnement de la broche lors des essais des 3 premiers module rs485 avant achat du 4eme et définitif. la source de la panne monte crescendo jusqu'au point où il devient puissant pour perturber le bon fonctionnement de façon efficace. je croyais avoir éradiquer cette perturbation avec les précaution prise mais il semble que non. est ce la broche qui crée ce puissant champs mgt, ou un element electronique qui joue un role de condensateur qui se charge jusqu'a saturation et pour lequel l'attente hors fonctionnement de la machine lui permet d'évacuer l'energie emmagasiné. car c'est sûr au démarrage demain la panne aura disparut me laissant tranquil 1h ou2. un specialiste serait apprécié mais faute, peut être que une personne avec la même expèrience pourrait se manifester.
gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Sam 5 Aoû 2017 - 23:36

j'oubliais de signaler que pour l'usinage perçage seconde planche, j'ai usé de spindel talker car la broche ne fonctionnait plus par mach3. et même si le pwm ne fonctionne pas, j'ai deconnecté les fils de ma carte usb. mais pas de changement, même lors du changement d'outil et lancement du cycle contournage. pourquoi spindel talker fonctionne et pas mach3 usant tous les 2 du même cable usb et module rs485 ?????
gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Dim 6 Aoû 2017 - 0:06

pourquoi spindel talker fonctionne et pas mach3 usant tous les 2 du même cable usb et module rs485 ?????

je ne connais pas ce soft, mais je suppose qu'il n'utilise pas le même plugin que Mach3 pour piloter le RS485 ?

Pour tes 'parasites' tu a essayé de débrancher les contacts de référencement/fins de course ?

Au fait, je ne sais plus si je te l'ai déjà demandé, mais tu utilise quelle version de Mach3 ? la dernière V3.043.066 est connue pour être buguée ; Warp9 par exemple, préconise d'utiliser la 062 avant toute tentative de dépannage.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Dim 6 Aoû 2017 - 0:31

effectivement j'utilise celle ci. mais j'ai découvert avec l'achat d'une de mes cartes usb une version r3 .84.....je vais voir si je peux me procurer cette version 62 en français ou si on peut la franchisé ou installé l’écran français de la 66. et non je n'ai pas débranché ceux là. avant re-cablage je l'ai avait en câble blindé et mise à la terre. mais ce n'est plus le cas depuis chgt fin de course et home soit 12 fins de courses installés pour la sécurité double (donc sans doute exagéré) car je me rappelle certaines fausses manipulations. heureusement bien que très rigide, la construction bois CP bouleau de 18mm offre une flexibilité qui sauve la mécanique.

gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Dim 6 Aoû 2017 - 1:02

La 062

https://warp9td.com/files/Software/Mach3/Mach3Version3.043.062.exe

Installe la par dessus la 066, sans rien enlever ; ensuite tu vas dans 'view/loadscreen' et tu recharge le screenset français (mach3fr-fraisage.set) et le tour est joué Wink

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Dim 6 Aoû 2017 - 7:32

super ! merci bien à toi. mes recherche n'ont pas été fructueuse hier soir sauf une possibilité en usant de Emule.
cette nuit aura été aussi fructueuse. la mémoire me fait défaut de l'expérience du passé. lors du recablage de ma cnc et installation de prise de qualité avec un ami à la place des miennes trop bon marché, il m'a dit d'essayer maintenant sans protection de relais optocouplé pour simplifié le circuit électrique et si les ennuis revenaient (estop intempestif qui se déclenché sans que la fenêtre diagnostique détecte une anomalie, ceci dû à la trop grande longueur de câble et donc de la resistance induite du fil+peut être fluctuation par perturbation chps electromgt= valeur de tension en mV différente aux bornes des entrées de la carte BOB, juste de quoi faire oscillé la commande estop mais pas détectable par mach3 car valeur inférieur à celle attendu par le programme. exemple avec une alimentation de 5 v en entrée, il me revenait 4.5v en retour suffisant pour foutre sa m...e) je n'aurais plus qu'a le refaire. ces problèmes déjà énoncés et connus par moi apparaissés à l'époque pas si lointaine avec ma carte //.
je vais déjà faire ce correctif pour voir si la correction est aussi efficace qu'à l'époque (1 an)et sinon j'appliquerai les autres solutions tel mach3 moins buggeur, recréation d'une araignée de câble pour mise à la terre, etc....
gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  dh42 le Dim 6 Aoû 2017 - 20:32

Salut,

juste de quoi faire oscillé la commande estop mais pas détectable par mach3 car valeur inférieur à celle attendu par le programme.

Oui, et en plus de ça, en port USB, Mach3 ne reçoit pas les infos en direct comme en port //, mais au travers du plugin de la carte USB, il est donc possible que le plugin ne transmette pas certaines infos et codes d'erreur, comme pour ton palpeur ou il ne transmet pas la valeur pour les variables Var 2000 à 2002.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 16937
Points : 29617
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  gentipierrot67 le Mar 8 Aoû 2017 - 7:35

salutation, dimanche j'ai ôté les fins de course et le Estop et continué mon usinage en tranquilité. j'ai découvert que finalement ça ne sert à rien pour faire des pièces si le gcode est bien fait ! (simplififions nos machine au plus strict nécessaire ! MDR j'ai aussi découvert que mach3 ne lit pas toutes les infos du gcode sans doute parce que postprocesseur trop vieux ou incomplet récupéré sur site mach3us pour faire les écriture conforme et en totalité du programme d'usinage (notemment déplacement en sécurité (retrait), donc adieu à merveilleux mastercam (snif) et re-écriture de tout mes programmes avec cambam. hier j'ai passé toute la journée jusque tard en soirée à usiner mes pièces d'imprimante 3D en faisant des corrections de dernière minute, celles de fautes d'ecriture gcode ou oubli de réalisation de pièce. ceci dit objectif réussi, avec en tout une seule erreur dans la journée par coupure liaison USB (message ......), 3 casses de outil dont les fautes se répartissent entre moi cambam et mach3. je ne dirais pas encore que l'investissement est amorti mais cela prend bonne voie. maintenant à mon retour de vacances de 5 jours à assembler notamment ma maxi super imprimante de perfection 3D, il me faudra installer le vaccin pour remettre en fonction mes fins de course et Estop, installer mon circuit d'aspiration car suivre les mouvement avec l'aspirateur en main ça va 5 minutes mais toute la journée... tape , puis me consacrer au autres modules de ma cnc (plasma laser et fil chaud). A+
gentipierrot67
gentipierrot67
je prends du galon
je prends du galon

Messages : 56
Points : 84
Date d'inscription : 04/07/2015
Age : 47
Localisation : haguenau

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  hares01 le Mer 7 Mar 2018 - 14:23

Bonjour

Quelques pistes pour ce genre de soucis même si le post est pas récent ça peut servir au prochain

Mon expérience avec depuis peu deux CNC chinoise munis de carte USB XHC m'a appris plusieurs chose :

Quand c'est possible mettre un parafoudre à minima sur la prise d'alimentation de la machine
Dans mon cas l'atelier servant pour de la serrurier les postes à souder voir certaines machines ainsi que l'installation électrique pas toute jeune arrive à créer des retours électrique ou je ne sais quoi dans les prises. Je pense d'ailleurs que ça m'a cramé un contacteur de puissance sur l'une des deux CNC et le PC qui l'a contrôlait. Depuis parafoudre sur la prise de la machine et onduleur pour le PC

Ensuite le bâti de la machine, l'armoire de commande et tous les accessoires qui le peuvent doivent être relié à la terre indépendamment

Le câble USB doit être blindé et posséder des olives de protection électromagnétique des deux côtés et dans la mesure du possible le plus court possible

Enfin les alimentations à différents voltage doivent sortir un courant de qualité
Comme avec une batterie de voiture qui indique 12v en sortie ce n'est pas assez. Une alimentation pour de l'électronique doit sortir une tension supérieur à sa tension nominale.

Toutes ces précautions devrait empêcher ce genre de bugue électronique aléatoire et très énervant
hares01
hares01
complétement accro
complétement accro

Messages : 712
Points : 1105
Date d'inscription : 20/07/2013
Age : 30
Localisation : Nantua

Revenir en haut Aller en bas

apparition de nouveau probleme palpeur et message sur mach3 Empty Re: apparition de nouveau probleme palpeur et message sur mach3

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 2 1, 2  Suivant

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum