Problème après changement d'outil - Newbie

+3
Jivé
speedjf37
Pascal Vallier
7 participants

Page 1 sur 2 1, 2  Suivant

Aller en bas

Problème après changement d'outil - Newbie Empty Problème après changement d'outil - Newbie

Message  Pascal Vallier Dim 1 Nov 2020 - 16:37

Hello guys!
Je viens de faire mon premier usinage avec un programme qui vient de fusion 360.
Mon set up contient 3 étapes, 2 avec le même outil (fraise droite), et une avec une fraise à bout rond.
Après les 2 premières étapes, il s'est arrêté pour le changement d'outil, j'ai changé l'outil, et après comment on fait pour régler la nouvelle hauteur, le nouveau z0? En mode programme on ne peut pas jogger, il faut passer en manuel? En plus la broche était juste au dessus d'une rainure, donc pas moyen de régler à l'aide d'une feuille car c'est dans un trou... J'ai le palpeur de hauteur, mais il n'est pas encore implémenté.
Donc là, j'ai arrêté la machine, je peux ne regénérer que la 3ème étape pour reprendre l'usinage? Si je fais reprendre après m'être remis manuellement sur cette étape (dans la fenêtre code) il me sort une erreur de radius incompatible à laquelle je ne comprends rien...
Merci d'avance
Pascal Vallier
Pascal Vallier
très actif
très actif

Messages : 218
Points : 258
Date d'inscription : 23/10/2020
Age : 57
Localisation : Quimper

http://www.tepsart.com

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  speedjf37 Dim 1 Nov 2020 - 16:47

Pascal Vallier a écrit:
Après les 2 premières étapes, il s'est arrêté pour le changement d'outil  

Bonjour,

Qui c'est arrété ?

Cordialement JF
speedjf37
speedjf37
je prends du galon
je prends du galon

Messages : 95
Points : 104
Date d'inscription : 03/03/2015
Age : 64
Localisation : TOURS

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Pascal Vallier Dim 1 Nov 2020 - 16:54

speedjf37 a écrit:
Pascal Vallier a écrit:
Après les 2 premières étapes, il s'est arrêté pour le changement d'outil  

Bonjour,

Qui c'est arrété ?

Cordialement JF
Le programme Gcode dans mach3 me disant de ré appuyer sur start après le changement d'outil
Pascal Vallier
Pascal Vallier
très actif
très actif

Messages : 218
Points : 258
Date d'inscription : 23/10/2020
Age : 57
Localisation : Quimper

http://www.tepsart.com

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  speedjf37 Dim 1 Nov 2020 - 16:58

Pascal Vallier a écrit:
Le programme Gcode dans mach3 me disant de ré appuyer sur start après le changement d'outil

Je ne connais que Linuxcnc , je ne peux t'aider !

JF
speedjf37
speedjf37
je prends du galon
je prends du galon

Messages : 95
Points : 104
Date d'inscription : 03/03/2015
Age : 64
Localisation : TOURS

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Problème suite à changement d'outil

Message  Pascal Vallier Dim 1 Nov 2020 - 17:20

Hello guys!
Je viens de faire mon premier usinage avec un programme qui vient de fusion 360.
Mon set up contient 3 étapes, 2 avec le même outil (fraise droite), et une avec une fraise à bout rond.
Après les 2 premières étapes, il s'est arrêté pour le changement d'outil, j'ai changé l'outil, et après comment on fait pour régler la nouvelle hauteur, le nouveau z0? En mode programme on ne peut pas jogger, il faut passer en manuel? En plus la broche était juste au dessus d'une rainure, donc pas moyen de régler à l'aide d'une feuille car c'est dans un trou... J'ai le palpeur de hauteur, mais il n'est pas encore implémenté.
Donc là, j'ai arrêté la machine, je peux ne regénérer que la 3ème étape pour reprendre l'usinage? Si je fais reprendre après m'être remis manuellement sur cette étape (dans la fenêtre code) il me sort une erreur de radius incompatible à laquelle je ne comprends rien...

De manière générale, comment fait on pour revenir à la position x0 y0 de début d'usinage?
merci
Pascal Vallier
Pascal Vallier
très actif
très actif

Messages : 218
Points : 258
Date d'inscription : 23/10/2020
Age : 57
Localisation : Quimper

http://www.tepsart.com

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Jivé Dim 1 Nov 2020 - 17:20

Dans ta configuration (set up), tu as 3 opérations. Tu peux enregistrer séparément le gcode pour chacune (clic droit générer ou post Pro, de mémoire) .
Jivé
Jivé
complétement accro
complétement accro

Messages : 1262
Points : 2239
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Hervé-34 Dim 1 Nov 2020 - 17:23

Normalement tu peux déplacer "à la main" ta broche, tu changes l'outil
tu refais ton 0 tu peux revenir à la main à l'endroit probable du départ
et tu cliques sur départ !
Voilà !

David t'expliquera surement mieux que moi !!

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3506
Points : 4611
Date d'inscription : 07/07/2014
Age : 70
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  nagut Dim 1 Nov 2020 - 17:26

tu avais fait le "Z" zéro sur la surface du brut ?
si c'est le cas, tu viens  (avec les flèches clavier), à un endroit du brut ou tu pourra refaire le zéro avec une feuille de papier et mettre le Z à zéro sur l'écran
n'oublie pas de remonter un peu le Z pour revenir à peu près ou tu était avant le changement d'outil.
tu appuie sur star et çà repart (n'oublie pas non plus de relancer la broche si comme moi tu ne pilote pas celle ci par le soft)
nagut
nagut
complétement accro
complétement accro

Messages : 2203
Points : 2469
Date d'inscription : 17/08/2010
Age : 70
Localisation : Haut Jura

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Pascal Vallier Dim 1 Nov 2020 - 17:43

nagut a écrit:tu avais fait le "Z" zéro sur la surface du brut ?
si c'est le cas, tu viens  (avec les flèches clavier), à un endroit du brut ou tu pourra refaire le zéro avec une feuille de papier et mettre le Z à zéro sur l'écran
n'oublie pas de remonter un peu le Z pour revenir à peu près ou tu était avant le changement d'outil.
tu appuie sur star et çà repart (n'oublie pas non plus de relancer la broche si comme moi tu ne pilote pas celle ci par le soft)

Donc il faut passer de programme à manuel, faire le zero, mettre à zero le z, repasser en programme, et appuyer sur start ?

Comment on revient à x0 y0 du début automatiquement ?
Pascal Vallier
Pascal Vallier
très actif
très actif

Messages : 218
Points : 258
Date d'inscription : 23/10/2020
Age : 57
Localisation : Quimper

http://www.tepsart.com

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Jivé Dim 1 Nov 2020 - 18:00

Tu as terminé les 2 premières opérations. Tu arrêtes ton programme : pause, fermer le GCODE dans Mach3. Change ton outil, fais ton zéro comme la première fois sur la surface du brut ou sur le martyr.
Reviens dans Fusion. Va sur ta 3e opération dans ton setup. Clic droit post Pro ou générer GCODE. Enregistre le.
Retour dans Mach3. Charge ce nouveau GCODE. Exécute le
Jivé
Jivé
complétement accro
complétement accro

Messages : 1262
Points : 2239
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  nagut Dim 1 Nov 2020 - 18:14

Pascal Vallier a écrit:
Donc il faut passer de programme à manuel, faire le zero, mettre à zero le z, repasser en programme, et appuyer sur start ?

Comment on revient à x0 y0 du début automatiquement ?
pourquoi passer en "manuel"; le programme est arrêté sur la ligne de changement d'outil et il ne faut pas changer de ligne
tu déplace la broche avec les flèches du clavier, tu fait ton zéro z et tu remonte un peu la broche pour ne pas toucher pendant le retour à la position ou le programme
s'était arrêté
tu ne t'occupe pas de x0 et y0
la broche va ce repositionner ou elle s'était arretée et le programme va continuer normalement.
nagut
nagut
complétement accro
complétement accro

Messages : 2203
Points : 2469
Date d'inscription : 17/08/2010
Age : 70
Localisation : Haut Jura

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  nagut Dim 1 Nov 2020 - 18:18

Jivé a écrit:Tu as terminé les 2 premières opérations. Tu arrêtes ton programme : pause, fermer le GCODE dans Mach3.  Change ton outil, fais ton zéro comme la première fois sur la surface du brut ou sur le martyr.
Reviens dans Fusion. Va sur ta 3e opération dans ton setup. Clic droit post Pro ou générer GCODE.  Enregistre le.
Retour dans Mach3. Charge ce nouveau GCODE. Exécute le

je faisais "pose" au début pour les changement d'outil, et parfois çà repart n'importe ou ! la pose c'est Mach3 qui la fait tout seul  Very Happy
mais je n'utilise pas Fusion
nagut
nagut
complétement accro
complétement accro

Messages : 2203
Points : 2469
Date d'inscription : 17/08/2010
Age : 70
Localisation : Haut Jura

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Pascal Vallier Dim 1 Nov 2020 - 18:30

Ah oui mais entre temps j'ai dû rebooter le PC. J'avais bien quitté mach3 correctement, et là il part avec des coordonnées qui n'ont rien à voir avec celles d'avant. Je pourrai jamais retrouver le 0?
Pascal Vallier
Pascal Vallier
très actif
très actif

Messages : 218
Points : 258
Date d'inscription : 23/10/2020
Age : 57
Localisation : Quimper

http://www.tepsart.com

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  nagut Dim 1 Nov 2020 - 18:31

Pascal Vallier a écrit:Ah oui mais entre temps j'ai dû rebooter le PC. J'avais bien quitté mach3 correctement, et là il part avec des coordonnées qui n'ont rien à voir avec celles d'avant. Je pourrai jamais retrouver le 0?

Non Very Happy
nagut
nagut
complétement accro
complétement accro

Messages : 2203
Points : 2469
Date d'inscription : 17/08/2010
Age : 70
Localisation : Haut Jura

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Pascal Vallier Dim 1 Nov 2020 - 18:31

nagut a écrit:
Pascal Vallier a écrit:
Donc il faut passer de programme à manuel, faire le zero, mettre à zero le z, repasser en programme, et appuyer sur start ?

Comment on revient à x0 y0 du début automatiquement ?
pourquoi passer en "manuel"; le programme est arrêté sur la ligne de changement d'outil et il ne faut pas changer de ligne
tu  déplace la broche avec les flèches du clavier, tu fait ton zéro z et tu remonte un peu la broche pour ne pas toucher pendant le retour à la position ou le programme
s'était arrêté
tu ne t'occupe pas de x0 et y0
la broche va ce repositionner ou elle s'était arretée et le programme va continuer normalement.

Quand j'ai voulu jogger, ça ne marchait pas. Impossible de bouger les axes en mode programme.
Pascal Vallier
Pascal Vallier
très actif
très actif

Messages : 218
Points : 258
Date d'inscription : 23/10/2020
Age : 57
Localisation : Quimper

http://www.tepsart.com

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Pascal Vallier Dim 1 Nov 2020 - 18:33

nagut a écrit:
Pascal Vallier a écrit:Ah oui mais entre temps j'ai dû rebooter le PC. J'avais bien quitté mach3 correctement, et là il part avec des coordonnées qui n'ont rien à voir avec celles d'avant. Je pourrai jamais retrouver le 0?

Non Very Happy

Et bien c'est nul. En plus c'est sous windows, j'ai déjà eu plusieurs plantages de mach3...
Donc il faut tout recommencer?
Pascal Vallier
Pascal Vallier
très actif
très actif

Messages : 218
Points : 258
Date d'inscription : 23/10/2020
Age : 57
Localisation : Quimper

http://www.tepsart.com

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  meles Dim 1 Nov 2020 - 19:06

Fusion des sujets en doublon

_________________
meles
meles
Admin
Admin

Messages : 13607
Points : 20534
Date d'inscription : 13/05/2011
Localisation : Aubagne

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Pascal Vallier Dim 1 Nov 2020 - 19:14

J'ai retrouvé mon x0 et y0, car je n'avais bougé que le x, donc c'est bon mais ma 3ème opération a merdé, mais pas à cause de ça. En fait ça n'ai rien fait lol!!
Donc, ma pièce c'est une rondelle de tabouret, avec des congés circulaires, que je veux faire avec une fraise ronde. J'ai utilisé parallel ope sur fusion 360 mais le z ne descend jamais, donc ça ne fait rien. Vous feriez quoi à ma place comme ope pour un filet sur un disque?
Pascal Vallier
Pascal Vallier
très actif
très actif

Messages : 218
Points : 258
Date d'inscription : 23/10/2020
Age : 57
Localisation : Quimper

http://www.tepsart.com

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  dh42 Dim 1 Nov 2020 - 19:21

Salut,

Quand j'ai voulu jogger, ça ne marchait pas. Impossible de bouger les axes en mode programme.

Normalement ça ne pose pas de problème et il n'est pas nécessaire de changer d'écran pour avoir le déplacement manuel ; si tu utilise le screenset FR (marron), assure toi que "Déplacement manuel" soit bien activé (LED allumée)

Ah oui mais entre temps j'ai dû rebooter le PC. J'avais bien quitté mach3 correctement, et là il part avec des coordonnées qui n'ont rien à voir avec celles d'avant. Je pourrai jamais retrouver le 0?

Assure toi que dans la config générale "Optionnal offset save" soit coché ; si c'est bien le cas, quand tu quitte Mach3, il te demandera "fixture save ?" ; répond oui, ça sauve tous les décalages sur le DD.

Au redémarrage, fait d'abord ton référencement pour retrouver ton 0 machine, comme les décalages ont été sauvés sur le DD, une fois le 0 machine fait, tu retrouvera tout tes décalages comme avant (les G54, 55, etc ; le 0 pièce n'est qu'un décalage de coordonnées par rapport au 0 machine)

Le fait que Mach3 ne sauve les décalage qu'en quittant fait que si tu à un plantage, ils ne seront pas sauvés, il peut donc être utile de les sauver manuellement après avoir fait ton référencement et ton 0 de travail. Menu config/fixtures, clique sur SAVE dans la fenêtre pour forcer la sauvegarde.

Pour retourner aux 0,0,0 pièce, tu peux soit utiliser l'interface manuelle et rentrer un G0 X0 Y0 dans la zone de saisie, soit si tu utilise l'UI française marron, il y a un bouton Aller à 0,0,0 sur l'écran principal... mais attention, le Z bouge aussi et va descendre à 0 donc risques importants si tu a des brides qui dépassent ou si tu travaille avec le 0 à la base de la pièce ...

Avec Mach3, il n'est pas du tout nécessaire de faire un GCode par outil comme c'est le cas avec LinuxCNc ou GRBL ; lors d'un changement d'outil, tu peux déplacer tes axes et refaire ton 0 en Z exactement comme si tu étais hors programme.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 22521
Points : 35226
Date d'inscription : 21/06/2009
Age : 58
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  dh42 Dim 1 Nov 2020 - 19:22

Re

Je ne connais pas du tout Fusion360 ... par contre si tu n'a pas de licence tu n'aura plus les changements d'outil ; ils les ont supprimés de la version gratuite début Octobre ansi que d'autre fonctions d'usinage. (plus de G0)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 22521
Points : 35226
Date d'inscription : 21/06/2009
Age : 58
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Jivé Dim 1 Nov 2020 - 19:37

nagut a écrit:
Jivé a écrit:Tu as terminé les 2 premières opérations. Tu arrêtes ton programme : pause, fermer le GCODE dans Mach3.  Change ton outil, fais ton zéro comme la première fois sur la surface du brut ou sur le martyr.
Reviens dans Fusion. Va sur ta 3e opération dans ton setup. Clic droit post Pro ou générer GCODE.  Enregistre le.
Retour dans Mach3. Charge ce nouveau GCODE. Exécute le

je faisais "pose" au début pour les changement d'outil, et parfois çà repart n'importe ou ! la pose c'est Mach3 qui la fait tout seul  Very Happy
mais je n'utilise pas Fusion
Dans Mach3, je n'utilise "Pause" que pour interrompre un programme si je vois que quelque chose ne va pas.
Je ferme aussitôt après le Gcode et là, je peux bouger mes axes XY, reprendre le zéro Z, par exemple.
Je relance ensuite le programme ou le programme modifié si besoin.
Avec cette méthode, il n'y a aucune perte de pas a contrario de l'utilisation de Stop puis bouger les axes sans fermer le gcode)
Jivé
Jivé
complétement accro
complétement accro

Messages : 1262
Points : 2239
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Jivé Dim 1 Nov 2020 - 19:43

Pascal Vallier a écrit:Ah oui mais entre temps j'ai dû rebooter le PC. J'avais bien quitté mach3 correctement, et là il part avec des coordonnées qui n'ont rien à voir avec celles d'avant. Je pourrai jamais retrouver le 0?


De quel zéro parles-tu ?
Si c'est le zéro XY que tu avais déterminé avec précision (une pointe à l'angle de ton brut, ou sur les bords du brut avec une pinule), tu peux te replacer au même endroit pour refaire ton zéro.
Idem pour ton Z sur le martyr ou le brut à condition qu'il reste un peu de surface non usinée sur ton brut). Si ce n'est pas le cas, dans Fusion, tu vas dans Configuration (set up) et tu changes le point de référence (sur las bas du brut par exemple, le mrtyr). Attention, il te faudra régénérer le gcode de l'opération que tu vas lancer, sinon gare à la traversée de la tabe...

Auparavant, il te faudrait refaire un Reff all home pour retrouver les mêmes coordonnées absolues (machine) que lors de ton usinage précédent.
Jivé
Jivé
complétement accro
complétement accro

Messages : 1262
Points : 2239
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Jivé Dim 1 Nov 2020 - 19:47

Pascal Vallier a écrit:J'ai retrouvé mon x0 et y0, car je n'avais bougé que le x, donc c'est bon mais ma 3ème opération a merdé, mais pas à cause de ça. En fait ça n'ai rien fait lol!!
Donc, ma pièce c'est une rondelle de tabouret, avec des congés circulaires, que je veux faire avec une fraise ronde. J'ai utilisé parallel ope sur fusion 360 mais le z ne descend jamais, donc ça ne fait rien. Vous feriez quoi à ma place comme ope pour un filet sur un disque?

Poste un zip de ton fichier.
Si pas possible (trop volumineux), mets un lien type webtransfer ou dlfree.

Il sera plus facile de donner une réponse validée par des essais.
Jivé
Jivé
complétement accro
complétement accro

Messages : 1262
Points : 2239
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Jivé Dim 1 Nov 2020 - 20:03

C'est un congé de surface  (avec une fraise à congé, quart de rond) ou une rainure  sur les bords avec une fraise boule ?
"Fraise ronde", je ne vois pas bien...
Problème après changement d'outil - Newbie Captur11
Ou ça ? Celle-ci se fait bien avec un usinage 3D évidement de poche (testé à l'instant)
Problème après changement d'outil - Newbie C210


Dernière édition par Jivé le Dim 1 Nov 2020 - 20:20, édité 1 fois
Jivé
Jivé
complétement accro
complétement accro

Messages : 1262
Points : 2239
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Pascal Vallier Dim 1 Nov 2020 - 20:15

Je vais lire tout ça, mais sinon comment fait on pour revenir a X0 Y0 sans aussi revenir à Z0?
Pascal Vallier
Pascal Vallier
très actif
très actif

Messages : 218
Points : 258
Date d'inscription : 23/10/2020
Age : 57
Localisation : Quimper

http://www.tepsart.com

Revenir en haut Aller en bas

Problème après changement d'outil - Newbie Empty Re: Problème après changement d'outil - Newbie

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 2 1, 2  Suivant

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum