Ce n'ai pas écrit dans le manuel !...

Aller en bas

Ce n'ai pas écrit dans le manuel !... Empty Ce n'ai pas écrit dans le manuel !...

Message  AIRPOPCIE Mer 25 Nov 2020 - 19:05

Bonsoir, il vient de nous en arriver une qui n'est pas dans le manuel. Ayant "KC" la carte LPT2 sur laquelle j'ai câblé le contrôle du niveau d'eau et du débit de la pompe voir:
http://www.metabricoleur.com/t13634-pompe-de-refroidissement-de-la-broche#267482
j'ai proposé à un ami qui a la même CNC que moi et sur laquelle on a installé les mêmes contrôles que sur la mienne de déplacer le contrôle de débit d'eau qui entrait en PORT 2 PIN 13 (câblé directement sur le composant sans protection RC) sur PORT 1 PIN 15 ( sur la carte dans le coffret les entrées P10 P15 sont protégées par des opto-coupleurs)...

Ce n'ai pas écrit dans le manuel !... Photo_12


Donc débrancher le fil venant du câble relié sur le LPT2 de la sortie (sur un contact sec) et réaliser une liaison entre cette borne et la borne sur laquelle PORT 1 PIN 15 était en attente. Et j'en ai profité pour lui expliquer que dans la configuration des ENTREES on pouvait intégrer une touche clavier en émulation dans la colonne HotKey.

Ce n'ai pas écrit dans le manuel !... Emulat11

Mais il y a un MAIS... a la suite de cette modification "soft" le lendemain, des entrées ne fonctionnait plus... En fait il lui a fallu 2 jours plus des liaisons via skype avec moi pour avancer et il a câblé une carte proto avec une prise DB25 et des switch pour constater avec un petit logiciel de contrôle du Port LPT1 qu'il fonctionnait correctement et que Mach3 ne les voyait pas. Jusqu'au moment ou celui branché sur ARU fonctionnait et plus les autres  et qu 'ARU (Port 1 Pin 10) n'était pas simulé par un code HotKey... HI..

Es ce que c'est normal?.... pour l'instant on a supprimer toutes les émulations dans la colonne HotKey..
A suivre.
AIRPOPCIE
AIRPOPCIE
très actif
très actif

Messages : 319
Points : 388
Date d'inscription : 04/08/2016
Age : 70
Localisation : CENTRE FRANCE

Revenir en haut Aller en bas

Ce n'ai pas écrit dans le manuel !... Empty Re: Ce n'ai pas écrit dans le manuel !...

Message  dh42 Jeu 26 Nov 2020 - 0:17

Salut,

Pour ce que j'en sais, si on assigne une hotkey à une entrée, ça désactive l'entrée physique au profit de l'entrée simulée ; il faut donc décocher le "emulated" sur tes Home X Y et Z pour que les contacts refonctionnent.

pour l'instant on a supprimer toutes les émulations dans la colonne HotKey..

Même si à 0, ça risque quand même de poser problème, c'est dans la colonne "emulated" qu'il faut les désactiver.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20723
Points : 33430
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Ce n'ai pas écrit dans le manuel !... Empty Re: Ce n'ai pas écrit dans le manuel !...

Message  dh42 Jeu 26 Nov 2020 - 0:42

... et si, c'est écrit dans le manuel Wink (page 65)

5.3.3 Emulated Input Signals
If you check the Emulated column for an input, then the Port/Pin number and active-lo state for that
signal will be ignored
but the entry in the Hotkey column will be interpreted.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 20723
Points : 33430
Date d'inscription : 21/06/2009
Age : 57
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum