Mechmate Tarnaise [Mise au point, suite...]

Page 2 sur 18 Précédent  1, 2, 3 ... 10 ... 18  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  athanase le Mar 22 Juil 2014 - 21:11

Faut pas être désolé...avec tout le boulot que tu fais, on va pas non plus être pressé ! Very Happy 
L'orage c'est pas cool....moi je débranche tout au moindre coup de tonnerre, à la campagne ça ne pardonne pas.

Bon je vais voir cette doc, merci  Very Happy 
A+
Denis

athanase
acharné du forum
acharné du forum

Messages : 510
Points : 1020
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  dh42 le Mar 22 Juil 2014 - 21:22

Salut,

L'orage c'est pas cool....moi je débranche tout au moindre coup de tonnerre, à la campagne ça ne pardonne pas.

Moi aussi, d'autant plus que je suis en bout de ligne (et en hauteur) ... mais aujourd’hui j'étais en veine, ça à tout pété au premier coup  Twisted Evil ... pas eu d'avertissement .... même le chat à perdu son flegme ..

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  athanase le Mar 22 Juil 2014 - 21:42

être en bout de ligne c'est mortel, faudrait peut-être un onduleur pour avoir le temps d'arrêter l'ordi proprement.

Pour la doc, j'ai due me concentrer un peu plus car la doc est anglaise....mais je crois avoir compris dit moi si j'ai tout faux:

alors la fonction dobutton est équivalente à une action sur un bouton, donc j'imagine que le n° correspond au bouton.
Donc en premier tu fais une action sur le bouton Réf Z puis une action sur Réf Y là si le capteur est activé, soit la valeur O alors tu lui dit en Gcode d'avancer de 2mm. En dernier tu fais une action sur Réf X.

Il me semble n'avoir pas vu dans la doc un tableau avec les n° correspondant aux boutons ? (je suis peut-être allé trop vite !)

Je vais tester ça demain, j'ai quartier libre  Very Happy 


athanase
acharné du forum
acharné du forum

Messages : 510
Points : 1020
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  dh42 le Mar 22 Juil 2014 - 23:16

Salut,

Oui, c'est bien ça Wink

J'ai du passer par les DoButton() à cause d'une particularité du fonctionnement des macro de Mach3 ; les commandes comme REFCOMBINATION sont effectuée comme Gcode en // du VBscript, autrement dit les 2 tournent en même temps (multitache) ... ce qui mettait une belle pagaille dans le cas de cette macro ... j'ai bien cru que je n'y arriverais pas, jusqu'à ce que je pense à utiliser cette ruse .. avec les DoButton(), l'exécution du script reste séquentielle.

Les OEM codes sont à la fin de la doc.

Il peuvent aussi être affichés par MachScreen (sur la dernière version) lorsqu'un bouton, led, visu est sélectionné et que l'on clique sur Functions Code



++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  athanase le Mer 23 Juil 2014 - 21:10

Hello,

Alors merci David, car ton code fonctionne très bien, c'est nickel  cheers , il faudrait juste que j'arrive à mettre automatiquement la visu Y a Zéro au lieu de +2.
A la fin de la doc il y a bien les codes OEM mais pas l'explication pour les numéros présent dans le code.

Sinon j'ai récupéré deux grand panneaux de mdf de 22mm pour faire le martyr. Je pense faire une bande amovible au cas où je décide de faire un axe rotatif (j'ai un moteur en plus). Je me demande si une fois usiné je ne vais pas lui donner un petit coup de vernis je pensais aussi usiner un peu fort, + ou - 1 mm (avec un martyr + grand que la zone de travail). Cela fera un petit rebord pour aligner facilement les grands panneaux. .

J'ai aussi rassemblé les fraises que l'on m'avait données + celles achetés il y a longtemps. Je ferais une photo pour avoir quelques conseils pour leurs utilisations.

Voilà
A+
Denis

athanase
acharné du forum
acharné du forum

Messages : 510
Points : 1020
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  dh42 le Mer 23 Juil 2014 - 21:52

Salut,

il faudrait juste que j'arrive à mettre automatiquement la visu Y a Zéro au lieu de +2.

J'ai essayé, mais Mach3 ne semble pas autoriser la modif des coordonnées machines ; si je tente de mettre la dro à 0, ça ne marche que pour les coordonnées courante (G54 ...).

Si je tente d'accéder à la dro via son n° OEM de "visu Y coord machine" (84), je peux la lire, mais si je tente d'écrire dedans il ne se passe rien.

De toute façon, ça n'a pas d'importance, tu ne travaille pas en coord machine mais en coord pièce, et tu fait bien ta RAZ ou tu veux. avant de lancer ton usinage.

Si le but est d'utiliser un retour auto au point de parking (G28) sans que ça touche le contact , il suffit de paramétrer le point de retour dans mach3 avec des coord à +2 (config/Homing-limits, en bas de la fenêtre, G28 home location.)



pour ma part, ce G28 est inséré en fin de Gcode, juste avant le M30 (automatiquement par Cambam, après retouche du post pro)

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  Thiman le Jeu 24 Juil 2014 - 17:50

Bon, autant une Mechmate semble prendre son envol, autant la mienne s'enlise ! Crying or Very sad 

 Je ne veux pas polluer la discussion mais là je commence à perdre mon latin avec ces fichus capteurs de proximité !

J'ai un souci de fonctionnement et j'ai recherché une explication sur les différents forums français et US mais sans succès.

J'ai acheté ces capteurs:
http://www.technimaniacs.fr/fr/electricite/102-cnc3ax-en-kit.html

et ces relais:
http://www.findernet.com/fr/products/sku/403190120000

Les capteurs sont alimentés en 12V et doivent, lorsqu'ils arrivent en butée sur l'axe, générer 12V en sortie pour déclencher les relais.

Souci: le capteur sort bien du 12V mais cela ne déclenche pas le relais.

Après mesure, le capteur sort bien du 12V "à vide", mais dés qu'il est connecté au relais, la tension chute à 0,2V et le relais ne bouge pas du tout.

Je commence à me demander si ce n'est pas le modèle de capteur que j'ai qui est insuffisant au niveau de sa sortie pour actionner le relais. Mais difficile de savoir car j'ai demandé une fiche technique au vendeur mais aucune réponse. Sympa ...

Y aurait-il une référence plus appropriée à un usage avec relais ?

 Merci !

Thiman
petit nouveau
petit nouveau

Messages : 8
Points : 24
Date d'inscription : 11/05/2014
Age : 44

Revenir en haut Aller en bas

Re: Mechmate Tarnaise

Message  Lulu 21 le Jeu 24 Juil 2014 - 18:21


Bonjour Thiman

si je lis bien, tu écris "mes capteurs en butée "un capteur inductif ne doit jamais appuyer sur quelque chose
il détecte la position, d'une came , ou autre pièce en ferraille ( pas de plastique et assimilé) et doit être positionné
entre 2 et 4 mm de distance
c'est ce que je fais sur les machines que je monte

à + Lulu

Lulu 21
complétement accro
complétement accro

Messages : 2397
Points : 5736
Date d'inscription : 18/06/2011
Age : 62
Localisation : grande banlieu dijonnaise

http://les2m-de-lba.e-monsite.com

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  le pat le Jeu 24 Juil 2014 - 19:18

Thiman a écrit:


Souci: le capteur sort bien du 12V mais cela ne déclenche pas le relais.

Après mesure, le capteur sort bien du 12V "à vide", mais dés qu'il est connecté au relais, la tension chute à 0,2V et le relais ne bouge pas du tout.

Je commence à me demander si ce n'est pas le modèle de capteur que j'ai qui est insuffisant au niveau de sa sortie pour actionner le relais. Mais difficile de savoir car j'ai demandé une fiche technique au vendeur mais aucune réponse. Sympa ...

Y aurait-il une référence plus appropriée à un usage avec relais ?

 Merci !

salut thiman

t'as 0.2 V en sortie du capteur quand tu le branches au relais mais  t'as mesuré la tension en entrée pour savoir si ça chute aussi ?

A+ patrice

le pat
complétement accro
complétement accro

Messages : 644
Points : 1492
Date d'inscription : 10/03/2011
Age : 49
Localisation : champagne

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  athanase le Jeu 24 Juil 2014 - 21:17

Hello,

Ah, les galères...j'y suis passé aussi et c'est peut-être pas fini !!

Bon voici mon montage et mes capteurs :
capteur M8

avec ce montage:

Pont diviseur de tension

la tension d'entrée entre le fil du signal et le fil + ou - du capteur suivant si c'est un NPN ou PNP
Il faut déterminer les résistances pour avoir un peu moins de 5 Volt en sortie de pont comme ça tu peux directement attaquer ton entrée de ta carte de commande.

J'ai fais comme ça ça marche nickel sans relais. Solution donné par un membre d'usinage.

A+

athanase
acharné du forum
acharné du forum

Messages : 510
Points : 1020
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  Thiman le Jeu 24 Juil 2014 - 22:33

le pat a écrit:
Thiman a écrit:


Souci: le capteur sort bien du 12V mais cela ne déclenche pas le relais.

Après mesure, le capteur sort bien du 12V "à vide", mais dés qu'il est connecté au relais, la tension chute à 0,2V et le relais ne bouge pas du tout.

Je commence à me demander si ce n'est pas le modèle de capteur que j'ai qui est insuffisant au niveau de sa sortie pour actionner le relais. Mais difficile de savoir car j'ai demandé une fiche technique au vendeur mais aucune réponse. Sympa ...

Y aurait-il une référence plus appropriée à un usage avec relais ?

 Merci !

salut thiman

t'as 0.2 V en sortie du capteur quand tu le branches au relais mais  t'as mesuré la tension en entrée pour savoir si ça chute aussi ?

A+ patrice

Bonsoir Patrice,

en entrée du capteur ? non, effectivement, je n'ai pas eu la présence d'esprit de faire ce test.

Par contre, le relais directement relié à l'alim fonctionne correctement.

Il s'agit d'une alim 12v / 2A qui a déjà récemment alimenté un autre appareil sans souci.

Je vais quand même faire un test demain et je communiquerais la mesure.

Merci !

Thiman
petit nouveau
petit nouveau

Messages : 8
Points : 24
Date d'inscription : 11/05/2014
Age : 44

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  Thiman le Jeu 24 Juil 2014 - 22:44

athanase a écrit:Hello,

Ah, les galères...j'y suis passé aussi et c'est peut-être pas fini !!

Bon voici mon montage et mes capteurs :
capteur M8

avec ce montage:

Pont diviseur de tension

la tension d'entrée entre le fil du signal et le fil + ou - du capteur suivant si c'est un NPN ou PNP
Il faut déterminer les résistances pour avoir un peu moins de 5 Volt en sortie de pont comme ça tu peux directement attaquer ton entrée de ta carte de commande.

J'ai fais comme ça ça marche nickel sans relais. Solution donné par un membre d'usinage.

A+

Bonsoir Denis,

 merci pour les infos, c'est très sympa, d'autant que tu as aussi du boulot avec ta machine ! Wink 

 Je pense que le premier défaut des capteurs c'est de ne pas avoir de led indicatrice, ça n'aide pas.

 J'avais vu la solution du pont diviseur en lisant les forums et d'ailleurs je vais faire un test pas plus tard que demain !

 En fait, je suis dans une configuration où il y a de grandes longueurs de câble.

  L'armoire contenant toutes les cartes et alims se trouve dans une pièce, à côté du PC.

 Par contre, la Mechmate est dans la pièce à côté, ce qui permettra d'isoler des bruits et de la sciure.

 Revers de la médaille, il y a 15m de câble pour aller à la machine (donc aux capteurs) et 15m pour revenir à l'armoire et la carte électronique.

 C'est pour cela que la solution des relais me semblait pas mal pour séparer un peu les longueurs de boucle.

  Je vais tester demain en espérant que cela puisse fonctionner !

Thiman
petit nouveau
petit nouveau

Messages : 8
Points : 24
Date d'inscription : 11/05/2014
Age : 44

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  mondeo2 le Ven 25 Juil 2014 - 8:25

bonjour,

je suis le post pour le plaisir.
tu peux trouver des rallonges avec connecteurs qui possèdent une led d'indication d'état si tu n'en as pas sur tes capteurs.

mondeo2
posteur Régulier
posteur Régulier

Messages : 126
Points : 281
Date d'inscription : 26/05/2012

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  athanase le Ven 25 Juil 2014 - 17:21

Hello,

Merci David pour tes dernières infos. tu as raison c'est pas important si la visu reste à +2. On pourrait d'ailleurs se passer du référencement si il n'y avait pas les limites logicielles, non ? (si j'ai bien compris les limites logicielles fonctionnent avec les coordonnées machine qui sont mise à zéro (étalonnées) lors du référencement )

Coté news:

J'ai reçu mon paquet  Very Happy  avec les petits cadeaux...sympa et rapide comme fournisseur.

 

J'ai regardé de plus près le palpeur et le contact s'ouvre pour 32mm environ...pas très précis comme mesure, il existe un autre moyen pour le paramétrer dans mach3 ?

Photo un peu pourrie


J'ai aussi mis en place le martyr: un peu galère pour aller visser les écrous...



J'ai fait dessiner sur le martyr (avant usinage) un grand rectangle de 1500X2500mm et après contrôle de la diagonale j'ai une erreur de - 1mm.

J'ai ensuite dessiné un cercle dans un carré de 200X200


Le point de départ est le coin inférieur gauche, et si on regarde bien on voit que les 3 angles sont légèrement arrondi  scratch  (sauf celui de départ )



J'ai loupé quelque chose dans Cambam ?  je suis je crois en vitesse constante... study 

Sinon je vais débuter mes premiers usinages en commençant par le martyr avec ça: (récupéré dans mon fourbi)



Il y a plusieurs vitesses par une molette avec des couleurs différentes:

Jaune 8000t/mn
Vert 9500t/mn
Rouge 13500t/mn
Bleu 20500t/mn
Noir 24000t/mn

Je veux rectifier mon martyr avec ça



Alors comment je détermine les paramètres de coupe ?  existe t-il une formule pour évaluer la vitesse de rotation et la vitesse d'avance de l'outil pour du MDF, Bois tendre, Bois dur.  Cela existe ou c'est du pifoexpérience après quelques bris de fraises  scratch  ?

Beaucoup de questions aujourd'hui (il m'en reste pas mal en réserve  jesors  pour les prochaines fois !!)
Voilà les dernières news.

A+
Denis

athanase
acharné du forum
acharné du forum

Messages : 510
Points : 1020
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  dh42 le Ven 25 Juil 2014 - 21:45

Salut,

Merci David pour tes dernières infos. tu as raison c'est pas important si la visu reste à +2. On pourrait d'ailleurs se passer du référencement si il n'y avait pas les limites logicielles, non ? (si j'ai bien compris les limites logicielles fonctionnent avec les coordonnées machine qui sont mise à zéro (étalonnées) lors du référencement )

Oui, toutefois ça sert aussi si tu veux te rendre à une position machine qui ne change jamais, comme par exemple une position de changement d'outil, de palpage ... etc.

C'est aussi TRES utile en cas de perte de pas en cours d'usinage ... ça te permettra de reprendre le 0 machine, et par delà le 0 pièce (qui n'est qu'un décalage de coordonnées par rapport au coords machine) et donc de te recaller sur ton usinage. Le(s) zéro(s) pièces pouvant d'autre part être sauvés sur le disque dur ; il t'est possible de reprendre un usinage, ou simplement d'utiliser un montage d'usinage dont tu a fait le 0 même après extinction du PC .. mais il faut pouvoir reprendre la référence machine au démarrage. (ou être sur que rien n'a bougé lorsque la machine était arrêtée, dans ce cas tu peux ne pas référencer)

J'ai regardé de plus près le palpeur et le contact s'ouvre pour 32mm environ...pas très précis comme mesure, il existe un autre moyen pour le paramétrer dans mach3 ?

Il faudra trouver sa hauteur exact en mettant une valeur de hauteur de palpeur plus faible que sa hauteur réelle (par ex: 30mm dans ton cas), après palpage, tu descend à Z=0 ; tu devrait te retrouver environ 2mm au dessus du martyre lorsque la visu marquera 0.

Ensuite tu continu de descendre (en mode pas par pas, c'est plus prudent) jusqu'à ce que tu effleure le dessus de ton martyre. L'écart que tu lira dans la visu Z devra alors être ajouté à la hauteur que tu avais choisi ; exemple, si tu lis -1.89 dans la visu Z, tu palpeur a donc une hauteur de 30 + 1.89 = 31.89.

Le point de départ est le coin inférieur gauche, et si on regarde bien on voit que les 3 angles sont légèrement arrondi scratch (sauf celui de départ )

C'est normal, c'est parce que tu est en vitesse constante ; plus tu avance vite pour une valeur d'accélération donnée, plus la machine "coupera les virages". Il faut soit, passer en mode trajectoire exacte, soit augmenter l'accélération, soit diminuer la vitesse d'avance.

Alors comment je détermine les paramètres de coupe ? existe t-il une formule pour évaluer la vitesse de rotation et la vitesse d'avance de l'outil pour du MDF, Bois tendre, Bois dur. Cela existe ou c'est du pifoexpérience après quelques bris de fraises scratch ?

On en a pas mal parlé sur le forum récemment ; je ne me souviens plus sur quels posts exactement .. regarde sur les réalisations de Juleo68 et de Diomedea ... ce sont les derniers acquéreurs de CNc ; ça doit être par la ..

Pour ta fraise de 25, pour surfacer tu peux essayer 13500 tr/min, avance de 3000 à 5000 mm/min suivant ce que peut faire ta machine ... ne prends pas de trop grosses passes (0.25mm maxi) ... avec 600W à la broche il ne faudrait pas la caler ..

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  athanase le Ven 25 Juil 2014 - 22:11

Merci pour toutes ces réponses.

C'est aussi TRES utile en cas de perte de pas en cours d'usinage ... ça te permettra de reprendre le 0 machine, et par delà le 0 pièce (qui n'est qu'un décalage de coordonnées par rapport au coords machine) et donc de te recaller sur ton usinage. Le(s) zéro(s) pièces pouvant d'autre part être sauvés sur le disque dur ; il t'est possible de reprendre un usinage, ou simplement d'utiliser un montage d'usinage dont tu a fait le 0 même après extinction du PC .. mais il faut pouvoir reprendre la référence machine au démarrage. (ou être sur que rien n'a bougé lorsque la machine était arrêtée, dans ce cas tu peux ne pas référencer)

Je vais reprendre cette explication demain car là j'ai pas tout compris(un peu de fatigue ce soir) , mais c'est super intéressent car je voulais justement pouvoir faire une pause dans un usinage et le reprendre plus tard. Faut que j'analyse ce que tu as écrit.  study 

Je vais aussi relire les anciens posts de Juleo68 et de Diomedea, j'avais zappé l'info !

J'ai du boulot en perspective et c'est tant mieux car c'est le weekend  Very Happy 

Bon weekend à tous

A+
Denis

athanase
acharné du forum
acharné du forum

Messages : 510
Points : 1020
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  athanase le Sam 26 Juil 2014 - 16:43

Hello,

Aujourd'hui pas d'atelier mais beaucoup de lecture.
J'ai donc relu les post préconisés et j'ai trouvé pas mal d'infos. Notamment la calculette (Excel)

J'ai pu retenir une info pour le MDF :
Profondeur de passe= dia de fraise
Vitesse de coupe 250m/mn
une avance par dent de 0.075 (=1/60 du dia de la fraise)

Cette vitesse de coupe est-elle valable pour tout type de bois ?
On peut alors suivant la dureté du bois changer la valeur de l'avance par dent, non ?


Alors si je reprends les calculs avec les infos que tu m'as données:
Pour ta fraise de 25, pour surfacer tu peux essayer 13500 tr/min, avance de 3000 à 5000 mm/min suivant ce que peut faire ta machine

La calculette excel me donne:
Rien car j'ai pas réussi à saisir les infos... scratch  je me sent très nul sur ce coup !

Bon je vais laisser reposer le cerveau...y-a surchauffe avec tous ses paramètres.

C'est l'heure du thé

athanase
acharné du forum
acharné du forum

Messages : 510
Points : 1020
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  dh42 le Sam 26 Juil 2014 - 17:16

Salut,

Cette vitesse de coupe est-elle valable pour tout type de bois ?

Non, et elle dépend aussi du type de fraise. Avec des fraises de méca il faut rester sous les 500m/min, mais dans ton cas, c'est une fraise à bois, j'ai donc pris une Vc plus haute, surtout à cause du fait que ta broche n'aurais rien dans le ventre à 6300 tr/min (Vc =500) ; à 13500 (Vc = 1061) ça devrait passer.

On peut alors suivant la dureté du bois changer la valeur de l'avance par dent, non ?

C'est surtout la Vc qu'il faut réduire si le bois est dur, sinon on le brule, surtout aux endroits ou la fraise ralentis (dans les virages)
Si tu prend une avance/dent trop faible, tu fais de la poudre et pas des copeaux ... et ça fait chauffer la fraise aussi.

Profondeur de passe= dia de fraise

Oui, mais c'est indicatif ... et déconseillé avec une fraise de Ø 25 Wink

La calculette excel me donne:
Rien car j'ai pas réussi à saisir les infos... scratch  je me sent très nul sur ce coup !

Seules les cases à fond noir sont éditables.

Les valeurs calculés sont à prendre comme base de travail, mais peuvent/doivent être modifiées en fonction du comportement de la machine .. qui n'est pas vraiment toujours prévisible. Certaines vitesses de rotation ou d'avance peuvent être sources de vibrations, suivant les moteurs, l'électronique utilisée et le mode micropas sélectionné sur les drivers, et bien sur la rigidité de la machine à aussi son mot à dire. Dans tous les cas, si ça vibre c'est pas bon.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  Thiman le Dim 27 Juil 2014 - 19:44

Bonsoir à tous,

je vous remercie pour toute votre aide. J'ai enfin réussi à faire fonctionner mon circuit. Ouf !  Very Happy 

Quasiment tous les schémas de branchement qui circulent sont faux.

J'ai sans doute eu le tort de ne pas me faire suffisamment confiance mais bon quand le concepteur de la Mechmate balance un schéma, j'ai tendance à faire confiance.

D'autant que naturellement, on évite de jouer à l'apprenti sorcier pour faire claquer les composants ! surtout à ce prix là !

Ce qui m'a aussi induit en erreur, c'est que je mesurais en sortie ( certes, à vide) une tension de 12V.

Ce qui est annoncé dans les schémas pour du NPN et qui est faux:

Fil marron du capteur au +12V
Fil bleu du capteur au 0V
Fil noir sur une des bornes du relais
L'autre borne du relais connecté au 0V

Ce qui est bon pour du NPN et qui fonctionne:

Fil marron du capteur au +12V
Fil bleu du capteur au 0V
Fil noir sur une des bornes du relais
L'autre borne du relais connecté au +12V !!

Et là, ça fonctionne nickel.

Quand le capteur est proche du métal, il s'allume et colle le relais.
Quand le capteur est sur le trou, il s'éteint et le relais se coupe.
Il faudra bien relier les fils aux bonnes polarités du relais pour que l'inter se commute lorsqu'il passe sur le trou.

Comme mes capteurs "chinois" avaient rendu l'âme, je me suis fourni en Télémécanique chez un grossiste du coin (deux fois plus cher !).

Bon, on est passé de 8mm à 12mm et cordon 10m avec connecteur aussi.

J'ai testé en comparaison avec le dernier capteur chinois qui restait valide et je note une réelle différence de réactivité.
Le Télémécanique étant beaucoup plus vif pour coller le relais.

Bon, on va pouvoir passer au référencement sur Mach3, encore une autre aventure ...

Dommage que je n'ai pas trouvé de tuto clair sur ce sujet ...  scratch 

Surtout que j'ai une bizarrerie supplémentaire quand je teste un interrupteur (Télémécanique à roulette) à la main en simulant une fin de course:

Je fait avancer le portique. J'appuye sur l'inter. La diode sur la pin de la BOB s'allume un instant et s'éteint.Le portique s'arrête.
Je reset l'AR.
 Je fait avancer le portique. J'appuye sur l'inter. La diode sur la pin de la BOB s'allume un instant et s'éteint.Le portique s'arrête.
Je reset l'AR.
 Je fait avancer le portique. J'appuye sur l'inter. La diode sur la pin de la BOB s'allume et reste allumé.Le portique s'arrête.
Je reset l'AR.
 Je fait avancer le portique. J'appuye sur l'inter.Le portique continue d'avancer. Je relâche l'inter. Le portique s'arrête et la diode s'éteint !  Shocked  Shocked  Shocked 

 Là, j'en perds mon latin ...

Thiman
petit nouveau
petit nouveau

Messages : 8
Points : 24
Date d'inscription : 11/05/2014
Age : 44

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  athanase le Mer 30 Juil 2014 - 22:03

hello,

Là, j'en perds mon latin ...

Ben là je pige pas !  scratch 
Si le capteur est actionné la led de la bob doit rester allumé... sinon il y a des interférences quelque part. Bon courage pour la suite.

En ce qui me concerne j'ai peu travaillé sur la machine (famille oblige) j'ai quand même pu installer le palpeur d'outil(merci David). J'ai aussi changé le câble de la broche pour en mettre un blindé.

Je travaille toujours sur les paramètres de coupe, je recherche sur le net différentes docs pour usiner le bois mais pour l'instant je suis bredouille. Les docs aperçu récemment sur le forum sont uniquement pour le métal...dommage. Je vais me replonger dans ta calculette...j'étais un peu fatigué l'autre jour...là ça devrait le faire  Very Happy 
J'ai aussi vu sur le net des panneaux appelé Batipin, quelqu'un connaît ? ça à l'air pas mal comme matériau.

Le laser(croix) que j'avais monté est trop puissant (50mW) j'en ai commandé un de 5mw(Comme je n'ai pas de lunette, j'ai peur des reflets). Il me semble ne pas avoir vu sur mach3fr une zone où je pourrais paramétrer mon laser qui est décalé par rapport au centre de ma broche. Il faut peut-être faire une macro spécifique ?

A+
Denis

athanase
acharné du forum
acharné du forum

Messages : 510
Points : 1020
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  dh42 le Jeu 31 Juil 2014 - 15:25

Salut,

Je travaille toujours sur les paramètres de coupe, je recherche sur le net différentes docs pour usiner le bois mais pour l'instant je suis bredouille. Les docs

Oui, c'est introuvable, et quand tu en trouve, c'est toujours pour des outils spécifiquement fait pour le bois et ce n'est pas utilisable avec des fraises de méca (Vc trop élevée). Mais ne te casse pas la tête, le bois ce n'est pas du métal, même si tu n'a pas les paramètres parfait ce n'est pas catastrophique ..

Tu trouvera rapidement ce qui vas bien lorsque tu utilisera la machine ; au début il faut faire pas mal d'essais pour tout mettre au point (y compris le mec qui utilise la machine Wink)

De toute façon, à part les dérivés de bois, si tu usine du massif il y a tellement de différence de dureté d'une planche à l'autre, voir sur une même planche (noeuds) qu'il faut de toute façon prendre des paramètres "à la baisse" pour pouvoir "passer partout".

Il me semble ne pas avoir vu sur mach3fr une zone où je pourrais paramétrer mon laser qui est décalé par rapport au centre de ma broche. Il faut peut-être faire une macro spécifique ?

Oui, il faut faire une macro (pas très compliquée à faire), ou peut être changer de screenset ; je crois (mais pas sur) qu'il y a ça dans le ScreenSet 2010.

Mach3 permet aussi de gérer une Webcam en guise de "viseur", mais il ne gère pas non plus le décalage XY, donc même chose il faut une petite macro pour faire ça.

Attention, ton laser (ou ta webcam) ne doit pas se déplacer en Z pour que ça reste précis.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  Thiman le Jeu 31 Juil 2014 - 18:32

athanase a écrit:hello,

Là, j'en perds mon latin ...

Ben là je pige pas !  scratch 
Si le capteur est actionné la led de la bob doit rester allumé... sinon il y a des interférences quelque part. Bon courage pour la suite.

A+
Denis

Bonsoir,

j'ai installé les 4 capteurs inductifs et ils répondent bien, je ne comprends pas ce qui s'est passé avec le contacteur mécanique.

A partir de là, je vais enfin pouvoir faire un référencement automatique.

Problème (encore ...), j'ai essayé pendant une bonne 20aine d'heures toutes les configurations possibles (X++, Y--, home, reversed etc etc), j'ai énormément cherché sur internet, j'ai aussi suivi scrupuleusement le tuto de notre ami DH42, rien n'y fait.

Le chariot bouge un peu puis me met un message d'erreur (en anglais, j'ai pourtant bien acheté une licence français pas plus tard que la semaine dernière pourtant ...  pale )

"Requested home axis home switch is active. Please fix then home"

 Je suis super preneur de toute info !

  Merci !

Thiman
petit nouveau
petit nouveau

Messages : 8
Points : 24
Date d'inscription : 11/05/2014
Age : 44

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  dh42 le Jeu 31 Juil 2014 - 20:16

"Requested home axis home switch is active. Please fix then home"

Salut,

Ça veux dire que ton contact est déjà actif lorsque tu lance ton référencement.

Vérifie bien que ton axe est suffisamment éloigné du capteur avant de lancer le référencement.

Les 3 LED Origine X, Origine Y, Origine Z doivent être éteintes avant de lancer le référencement ; (voir sur écran diagnostics de Mach3 pour les LED)

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  Thiman le Ven 1 Aoû 2014 - 22:42

dh42 a écrit:
"Requested home axis home switch is active. Please fix then home"

Salut,

Ça veux dire que ton contact est déjà actif lorsque tu lance ton référencement.

Vérifie bien que ton axe est suffisamment éloigné du capteur avant de lancer le référencement.

Les 3 LED Origine X, Origine Y, Origine Z doivent être éteintes avant de lancer le référencement ; (voir sur écran diagnostics de Mach3 pour les LED)

++
David

Bonsoir David,

 merci pour cette info, en effet, lorsqu'un des axes est en butée, il faut "le sortir" sinon il invalide tout le processus.

Ensuite, mauvaise interprétation de ma part avec le "actif à 0", je pensais qu'on parlait de l'état du capteur au moment du contact, alors qu'en fait, il s'agit de l'état de fonctionnement global du circuit.

On va pouvoir enfin se concentrer sur la préparation des fichiers avec notamment CamBam !  Wink 

Je viens de prendre la licence Mach3fr (Jazial très sympa et disponible pour aider les débutants dans mon genre  Very Happy ).

Maintenant, il va me falloir CamBam (en français), et je crois que Cutviewer est un additif qui est conseillé pour simuler le travail ?

 A quel endroit puis-je prendre la licence en Français ?

Thiman
petit nouveau
petit nouveau

Messages : 8
Points : 24
Date d'inscription : 11/05/2014
Age : 44

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  dh42 le Sam 2 Aoû 2014 - 1:26

Salut,
A quel endroit puis-je prendre la licence en Français ?
http://sites.fastspring.com/hexray/product/all

Cambam est multi-langue ; tu choisi à l'insta (ou plus tard) ..

merci pour cette info, en effet, lorsqu'un des axes est en butée, il faut "le sortir" sinon il invalide tout le processus.

Sur mon interface de Mach3, j'ai ajouté ces led sur l'écran principal, à coté du bouton de référencement ... c'est plus pratique que de changer d'écran à chaque fois pour vérifier que les contacts ne sont pas actifs.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Mechmate Tarnaise [Mise au point, suite...]

Message  Contenu sponsorisé Aujourd'hui à 14:26


Contenu sponsorisé


Revenir en haut Aller en bas

Page 2 sur 18 Précédent  1, 2, 3 ... 10 ... 18  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum