Encore un mystère...

Voir le sujet précédent Voir le sujet suivant Aller en bas

Encore un mystère...

Message  diomedea le Ven 22 Aoû 2014 - 16:29

Bonjour à tous,
Voici ce qui ce passe quand j'importe ce DXF sous CamBam:


Il y a deux traits qui partent des deux cercles du "O" vers les centre de la croix X Y Z.
Et peu importe l'endroit ou je déplace le dessin, ces deux lignes reste ancrées sur la croix.
Je pourrais faire abstraction, mais je elles m’empêches de transformer le "O" en zone, et donc de pouvoir le graver.
Je ne peux pas les supprimer, elles restent intimement liées à leurs cercles, j'ai essayé plusieurs méthodes, et rien à faire...


Si vous avez une idée...
D'avance, merci!
JP

diomedea
complétement accro
complétement accro

Messages : 8949
Points : 19577
Date d'inscription : 14/01/2009
Age : 56
Localisation : Bretagne (29)

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  ramses le Ven 22 Aoû 2014 - 19:29

bonjour a tous,

as-tu essaye de selectionner et ensuite de faire "decomposer" dans l'onglet "edition" ? Ca devrait le faire et ensuite te permettre de "virer" ce qui t'embete et en final faire "joindre".

Bien a toi

ramses
acharné du forum
acharné du forum

Messages : 450
Points : 871
Date d'inscription : 10/07/2011
Age : 56
Localisation : Province de Namur en BELGIQUE

http://users.skynet.be/ramsesrecharge/

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  dh42 le Ven 22 Aoû 2014 - 22:43

Salut,

Lors de la sauvegarde de tes DXF, assure toi d'avoir le format Autocad 2000, ou Autocad R12 ..

Si tu dispose de la police de caractère qui à été utilisée pour faire le dessin, tu peux aussi directement taper le texte sous cambam. (et il n'est pas nécessaire dans ce cas de le décomposer/transformer en région pour le graver ou le "pocher"  Very Happy )

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  diomedea le Sam 23 Aoû 2014 - 9:19

Bonjour à tous les deux,
dh42 a écrit:Lors de la sauvegarde de tes DXF, assure toi d'avoir le format Autocad 2000, ou Autocad R12 ..
Ou vais je trouver cette info?  scratch 
Je ne vois vraiment pas:
(Notez mes deux calques fait sous SW)


Il ne s'agit pas d'une police, mais d'un dessin SW, les lettres rondes sont faites avec des splines.
Ramsès, J'ai effectivement essayé de décomposer l’ensemble, mais il n'y rien à faire... Finalement j'ai réussi en utilisant la fonction "Couper à l'intersection".


Une dernière question...
Il me semble que David en a déjà parlé, mais je me retrouve parfois avec des fichiers cb.b1, 2, voir 3, à quoi correspondent ils?


Finalement j'ai réussi, même avec CV, mais bon, il n'y a pas de changement d'outil!


Le logo original (scan calendrier):


Merci pour vos réponces
JP

diomedea
complétement accro
complétement accro

Messages : 8949
Points : 19577
Date d'inscription : 14/01/2009
Age : 56
Localisation : Bretagne (29)

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  Totem le Sam 23 Aoû 2014 - 15:37

Salut,

Dans SW, quand tu fais Enregistrer sous pour exporter le DXF, il y a un bouton Options, tu cliques dessus après avoir choisi le format DXF, et en haut à gauche (il me semble) de la boîte de dialogue qui s'ouvre, tu peux choisir le format de DXF.

Logiquement, AutoCad 2000 devrait être par défaut.

++
Lio

Totem
complétement accro
complétement accro

Messages : 4106
Points : 11007
Date d'inscription : 23/12/2011
Age : 21
Localisation : 67 alsace

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  diomedea le Sam 23 Aoû 2014 - 15:50

Salut Lio,
Effectivement!
Donc voila ce que j'ai:


Je remarque que j'ai un choix au niveau des splines, et que la bizarrerie vient justement de l'une d'elle...
Il me semble que je suis déjà intervenu dans cette fenêtre, mais je suis incapable de dire pourquoi! mais c'était avant la CN.
++
JP

diomedea
complétement accro
complétement accro

Messages : 8949
Points : 19577
Date d'inscription : 14/01/2009
Age : 56
Localisation : Bretagne (29)

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  dh42 le Sam 23 Aoû 2014 - 16:19

Salut,

@JP: c'est bien une mise en plan que tu exporte ? ... le 2010 a une apparence différente et je ne m'y retrouve pas.

J'ai les mêmes réglages que toi dans la fenêtre d'exportation.

Le .b1 .b2  etc sont des fichiers de sauvegarde ; ils correspondent aux fichiers .cb  Quand tu sauve un projet Cambam, l'ancien fichier est renommé .b1, puis .b2 etc ...

tu peux régler le nb de sauvegardes dans Outils/Options: Fichiers de sauvegarde.

ces sauvegardes existent aussi pour les biblio d'outils, les styles ...

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  diomedea le Sam 23 Aoû 2014 - 16:32

Il faut que ça soit impérativement une mise en plan? Parce que je créer toujours mes DXF à partir des modélisations....
Voici se que j'ai avec la mise en plan:


Je ne vois pas de différence!

diomedea
complétement accro
complétement accro

Messages : 8949
Points : 19577
Date d'inscription : 14/01/2009
Age : 56
Localisation : Bretagne (29)

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  dh42 le Sam 23 Aoû 2014 - 16:33


_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  diomedea le Sam 23 Aoû 2014 - 16:44

Maintenant que tu le dit!
Je savait que j'avais déjà rencontré ce phénomène! Mais je ne me souvenais plus en avoir parlé.
Seul point commun au deux cas, la spline.
Je vais refaire un essai en cochant "Exporter toutes les splines comme polylignes" pour voir...

diomedea
complétement accro
complétement accro

Messages : 8949
Points : 19577
Date d'inscription : 14/01/2009
Age : 56
Localisation : Bretagne (29)

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  dh42 le Sam 23 Aoû 2014 - 16:48

Il faut que ça soit impérativement une mise en plan? Parce que je créer toujours mes DXF à partir des modélisations....

Comment fais tu ? .. je n'ai pas vu cette option (pour ma part je ne fais qu'avec des mises en plan)

Le format DXF est une plaie, il y en a des tas de versions, et même une même version peut avoir des différences suivant le soft qui l'a créée .. et ça donne parfois des résultats curieux dans CB. Je n'ai par contre jamais eu cette ligne qui part de 0,0 avec les sauvegardes de mise en plan depuis le 2008.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  diomedea le Sam 23 Aoû 2014 - 17:19

Alors!
Voici ce que j'ai quand j'enregistre directement la modélisation:
DXF me demande quelle(s) vue(s) m'intéresse (face dans le cas présent).


J'ai donc coché "Exporter toutes les splines comme polylignes" et:



Et si je repasse en "Exporter toutes les splines comme splines":


C'était donc bien ça!

diomedea
complétement accro
complétement accro

Messages : 8949
Points : 19577
Date d'inscription : 14/01/2009
Age : 56
Localisation : Bretagne (29)

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  Totem le Sam 23 Aoû 2014 - 17:22

Salut David, JP,

Comment fais tu ? .. je n'ai pas vu cette option (pour ma part je ne fais qu'avec des mises en plan)

Ce n'est qu'à partir du 2010 que c'est possible, et c'est surtout pratique pour la tôlerie (pas besoin de faire le déplié à chaque fois)

Par contre il est très probable (et même certain) qu'il y a plus de bugs dans ce mode qu'en mise en plan, deux ou trois fois au boulot j'avais des bizarreries en exportant des pièces et j'ai du passer par une mise en plan pour résoudre le problème (avec des pièces pliées et des évidements en splines qui traversent les plis)

Par contre, ce qui est étrange c'est que j'ai déjà exporté plusieurs fois des splines (en volumique, pas en tôlerie) depuis SW vers CamBam, sans avoir besoin de les convertir en polyligne, et je n'ai jamais eu de problème !

++
Lio

Totem
complétement accro
complétement accro

Messages : 4106
Points : 11007
Date d'inscription : 23/12/2011
Age : 21
Localisation : 67 alsace

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  dh42 le Sam 23 Aoû 2014 - 17:31

Salut Lio Wink

Par contre, ce qui est étrange c'est que j'ai déjà exporté plusieurs fois des splines (en volumique, pas en tôlerie) depuis SW vers CamBam, sans avoir besoin de les convertir en polyligne, et je n'ai jamais eu de problème !

Pour ma part, l'exportation des splines n'est pas non plus convertie en polyligne et je n'ai pas de problèmes .. à voir si c'est liée au nouveau mode d'exportation du 2010 ... ça marche peut être avec les mises en plan.

Avec les DXF-> cambam, mon principal problème est avec les polices de caractères ; suivant le format DXF choisis les résultats diffèrent fortement pour les textes.

Suivant le format DXF, il arrive aussi que les arcs soient perdus ... (ça ne m'est jamais arrivé si sauvé depuis AutoCad  scratch )

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12423
Points : 25151
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  Totem le Sam 23 Aoû 2014 - 18:41

Pour ma part, l'exportation des splines n'est pas non plus convertie en polyligne et je n'ai pas de problèmes .. à voir si c'est liée au nouveau mode d'exportation du 2010 ... ça marche peut être avec les mises en plan.

En tout cas, chez moi, ça fonctionne sans problème !

++
Lio

Totem
complétement accro
complétement accro

Messages : 4106
Points : 11007
Date d'inscription : 23/12/2011
Age : 21
Localisation : 67 alsace

Revenir en haut Aller en bas

Re: Encore un mystère...

Message  Contenu sponsorisé Aujourd'hui à 10:44


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum