Première utilisation MACH3

Aller en bas

Première utilisation MACH3 Empty Première utilisation MACH3

Message  MV le Lun 1 Sep 2014 - 12:47

Bonjour à tous!

Après réception de ma cnc (BZT PF 1000P) j'essaie de me lancer dans l'usinage.

J'arrive à dessiner correctement(je pense) mes pièces sous cambam et à générer le g-code (grace aux tutos trouvés par ici, merci à vous) mais les problèmes commencent quand j'ouvre Mach3.

J'arrive à faire bouger la machine en mode manuel mais c'est tout.

Quand je charge le premier projet (surfaçage du plateau martyr) j'ai tout d'abord un problème de placement du dessin:

Première utilisation MACH3 Captur11

Pour mettre la broche au 0,0 du dessin j'ai fait une manip surement pas très orthodoxe (mais c'est la seule que j'ai trouvé): j'ai mis la broche au parking et de là je suis parti manuellement pour la mettre au -660,-800 que sont  les dimensions maxi d'usinage pour cette machine.

Hors, vous voyez sur l'image, le dessin commence un peu plus loin....quel est le problème? que est ce qu'il faudrait faire pour positionner la broche au 0,0 du dessin vraiment?

J'ai également mis le z à 0 à la main avec l'astuce de la feuille du papier comme expliqué par dh42 dans d'autres posts. Je fait ainsi corresponde le z avec la surface de la pièce....mais est ce bien ce qu'il faut faire?

En plus j'ai un capteur d'outil.....l'idéale serait de pouvoir l'utiliser mais je ne vois pas comment.

Bon, ça fait quand même trois jours de lutte avec des mode d'emploi, des tutos, des recherches....et pour l'instant rien...donc si vous avez des astuces à me donner je suis preneur!

Merci d'avance!
MV
MV
très actif
très actif

Messages : 227
Points : 489
Date d'inscription : 24/10/2012
Age : 37

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  dh42 le Lun 1 Sep 2014 - 15:53

Salut,

Dans cambam, le coin inférieur gauche du rectangle qui matérialise le martyre a surfacer doit être à 0,0 c.a.d. sur la croix.

Première utilisation MACH3 Zerocb10

Sur mach3, tu amène le centre de la fraise sur le même coin du martyre, puis tu met tes axes X et Y à zéro en cliquant sur Zéro Z et Zéro Y.

pour le Z avec le palpeur, on verra plus tard,, la je dois partir.

regarde cette vidéo et imagine que la plaque de MDF est ton martyre.

http://www.metabricoleur.com/t5314p15-fabrication-cnc-coffret-electrique-en-mdf#89192

PS: après avoir fait ton 0,0,0 sur Mach3, pense à cliquer sur le bouton "rafraichir" en haut de l'afficheur graphique (regen toolpath sur la VE) pour actualiser la vue des parcours avec le nouveau 0.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17187
Points : 29867
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  MV le Mar 2 Sep 2014 - 11:33

Salut,

J'ai trouvé le problème concernant la position du dessin.

En fait je suis sur la version d'essai limitée à 500lignes, quand je charge les autres 150 lignes je vois le reste du dessin, j'attends de recevoir la licence achetée ce matin pour faire un nouveau essai.

J'ai réussi à faire une bricole pour usiner les 150 lignes après mais j'ai trouvé un message d'erreur (je pense pas que ce message est lié à la bidouille elle même mais à un autre problème): "limites logicielles, depl. ignoré"

Je pense que ça doit être en rapport avec le fichier de configuration de mach3? La machine n'a pas usiné tout le martyr mais du coup elle doit penser qu'elle est aux limites machine? Comment configurer ces limites?

Une autre question que je voudrait résoudre et je pense que c'est lié, c'est la configuration des x++ x-- y++ y-- car quand je fais le référencement des axes j'ai l'impression que cela butte physiquement et non que ça s’arrête avec les détecteurs....que puis-je faire?

Après si vous avez le temps de m'expliquer comment configurer le palpeur d'outils..je suis aussi preneur (ça me parait très bizarre que dans les manuels rien ne soit expliqué à ce sujet, mais je n'ai rien trouvé)
MV
MV
très actif
très actif

Messages : 227
Points : 489
Date d'inscription : 24/10/2012
Age : 37

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  MV le Mar 2 Sep 2014 - 13:49

Et encore une question (pas facile d'être débutant quand même!)

Là j'était en train d'usiner un fichier (poche simple sur du pmma) et au début de la cinquième passe la machine s'arrete net. Ca ne peut pas être du à la version d'essai car j'ai eu la licence ce matin même, en fait le programme s'arrete à la ligne 696.

Première utilisation MACH3 Captur12

Je vous mets ci joint le fichier .cb, voyez vous quelque chose d'étrange?
Fichiers joints
Première utilisation MACH3 Attachment
girafe.zip Vous n'avez pas la permission de télécharger les fichiers joints.(2 Ko) Téléchargé 19 fois
MV
MV
très actif
très actif

Messages : 227
Points : 489
Date d'inscription : 24/10/2012
Age : 37

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  MV le Mar 2 Sep 2014 - 15:11

Bon, j'ai trouvé la solution au problème des limites physiques de ma machine (ça doit vous faire marrer de voir que je réponds tout seul à mes questions drunken )

C'est très bien expliqué par dh42 dans ce tuto sur le paramétrage des home et e-stophttp://www.metabricoleur.com/t1577-mach3-branchement-et-parametrage-contacts-home-et-e-stop#19338

Et donc ma machine elle s'approche tout doucement des capteur et elle s'arrête avant de buter contre le support cheers

Alors il me restent encore deux questions importantes que je n'ai pas réussi à résoudre:

1.-Comment configurer le palpeur d'outil
2.-Pour quoi mach3 s'arrete à la 696ème ligne du fichier d'usinage? je vais lancer d'autres usinages cet après midi et je verrai si cela se reproduit!


Dernière édition par MV le Mar 2 Sep 2014 - 15:24, édité 1 fois
MV
MV
très actif
très actif

Messages : 227
Points : 489
Date d'inscription : 24/10/2012
Age : 37

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  dh42 le Mar 2 Sep 2014 - 15:19

Salut,

Pour la question 2, c'est simple, ta licence n'est pas installé et ton Gcode est toujours tronqué.

je vois ça à 2 choses:

- sur ta capture d'écran, on vois bien que dans la barre de titre c'est toujours marqué 'Mach3 CNC démo' ; logiquement une fois la licence installée il doit y avoir ton nom à la place de Démo

- le Gcode ne se finis pas ; la dernière instruction dans un fichier Gcode, c'est la 'fin de programme' -> code M30 ... alors que sur ton image on fini sur un G1 ..

pour installer correctement ta licence, tu dois décompresser le fichier que tu a reçu (si il est compressé) pour obtenir un fichier 'Mach1Lic.dat' et tu dois mettre ce fichier dans le dossier d'insta de Mach3 (typiquement C:\Mach3\)

je regarde plus tard pour le palpeur, je n'utilise pas la même interface que toi et il faut que je fasse des essais pour voir comment se règle la tienne.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17187
Points : 29867
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  dh42 le Mar 2 Sep 2014 - 15:28

Re

PS, je viens de regarder ton fichier cambam ; une vitesse d'avance en usinage de 5000 mm/min, c'est trop pour cette machine, tu risque des pertes de pas.

en usinage, ne pas dépasser 3500 mm/min, maxi 4000 en gravure (faible efforts de coupe)

ne pas laisser des paramètres sur 'indéfini' dans les op d'usinage (ici: mode de déplacement)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17187
Points : 29867
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  MV le Mar 2 Sep 2014 - 15:46

Ok merci!

Pour la version démo, effectivement, je me suis embrouillé, c'est la licence cambam que j'ai reçu, celle de mach3 devrait arriver prochainement.

Par contre je ne comprends pas quand tu dis
dh42 a écrit:ne pas laisser des paramètres sur 'indéfini' dans les op d'usinage (ici: mode de déplacement)

Je ne vois pas "mode de déplacement" dans CB... scratch
MV
MV
très actif
très actif

Messages : 227
Points : 489
Date d'inscription : 24/10/2012
Age : 37

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  dh42 le Mar 2 Sep 2014 - 15:53

peut être est tu en affichage basique ; clique sur le bouton basique/étendu pour voir tous les paramètres des opérations.

Première utilisation MACH3 Modede10

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17187
Points : 29867
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  MV le Mar 2 Sep 2014 - 16:16

ok, je viens de le voir, merci.

J'imagine donc que le plus adapté serait l'option "trajectoire exacte"? je ne vois pas la différence entre les deux options proposées à vrai dire
MV
MV
très actif
très actif

Messages : 227
Points : 489
Date d'inscription : 24/10/2012
Age : 37

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  dh42 le Mar 2 Sep 2014 - 16:34

Pour le palpeur:

1) vas sur l'écran Diagnostic de Mach3.

2) appui manuellement sur le palpeur pour vérifier qu'il est correctement branché.

lors d'un appui, la LED palpeur doit s'allumer et s'éteindre au relâchement du contact.

Première utilisation MACH3 Mfr_pa10

3) si tout se passe bien, en restat sur cet écran, prends un pied à coulisse et mesure la hauteur du palpeur au moment du déclenchement (quand la LED s'allume).

Première utilisation MACH3 Mfr_pa11

4) Une fois cette valeur connue, vas sur l'écran Palpeur et entre cette valeur dans la case Hauteur du palpeur (30 sur l'image)

5) dans Coordonnée Z de retour, met une valeur un peu supérieure à la hauteur du palpeur, c'est la coordonnée à laquelle la fraise remontera après palpage (ici 35, soit 5mm au dessus du palpeur)

6) entre une vitesse de 250 à 300 dans Vitesse de palpage (vitesse d'avance à laquelle le Z descendra pour palper)

Toutes ces valeurs resteront mémorisées dans Mach3.

Première utilisation MACH3 Mfr_pa12

Pour palper:

si Surface pièce est défini à 0 dans Cambam:

a) pose ton palpeur sur la pièce (donc 'sur' le 0 en Z)

b) descend ta fraise à 1 ou 2cm haut dessus du palpeur.

c) clique sur Palper sur place ; ta fraise va descendre, puis remonter de 5 mm après palpage ; le 0 en Z sera fait automatiquement (tu devrais donc avoir 35 dans l'afficheur Z dans le cas de l'exemple de l'image, à savoir la hauteur ou se trouve la fraise à la fin du palpage)

d) pense à enlever le palpeur de dessous la fraise (ou à déplacer les axes) AVANT de lancer le programme, car la première chose que fait le Gcode, c'est d’amener la fraise au Plan de dégagement défini dans Cambam ... qui a toutes les chances d'être nettement plus bas que la palpeur, donc s'il reste dessous, tu le défonce à coup de fraise !!  What a Face

Si tu veux vérifier que ta fraise aura bien son bout à 0 juste à la surface de ta pièce, tu peux lancer une commande manuellement:

a) vas sur l'écran Manuel

b) tape sur la touche Entrée du clavier ou du pavé numérique, ça affiche une ligne de saisie de Gcode.

c) dans cette ligne de saisie, tape:  G1 F500 Z0  

Ce qui signifie: déplacer l'axe Z jusqu'à la coordonnée 0 (Z0) en V d'usinage et en ligne droite (G1) à la vitesse de 500 mm/min (F500)  .

puis tape Entrée pour valider la commande ; ta fraise devrait descendre au ras de la surface de la pièce et s'arréter.


J'imagine donc que le plus adapté serait l'option "trajectoire exacte"? je ne vois pas la différence entre les deux options proposées à vrai dire

Il vaut mieux utiliser le mode vitesse constante, sauf si tu t’aperçois que tes angles de découpe on tendance à être arrondis (ça le fait surtout aux hautes vitesses) .. dans ce cas tu peux passer l'op à problème en mode trajectoire exacte.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17187
Points : 29867
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  MV le Mer 3 Sep 2014 - 16:42

Bonjour!

J'ai commencé à usiner des vrai pièces pour le boulot....c'est un bonheur de voir la machine travailler toute seule...je pense même à lui donner un prénom tellement je suis ému quand je la vois travailler jesors

Aujourd'hui j'ai trois nouvelles questions:

1.-Pour le palpeur: je prends note, je vais essayer de faire ces opérations dans la semaine, j'ai vérifié et il est bien branché. Je voulais savoir s'il existe une autre méthode pour que la broche vienne toucher le palpeur là où BZT l'installent, c'est à dire sur un côté, je pense que cela serait plus pratique pour pas avoir à prendre à chaque fois le palpeur et le mettre sur la matière, mais je ne sais pas si mach3 peut mémoriser une position de palpeur?

2.-Pour l'emplacement du dessin: pour l'instant je fais comme dit par dh42, c'est à dire que je fais mon dessin cambam en partant du 0,0 qui est positionné en bas à gauche de mon dessin, après je fais le 0,0 sous mach3 au même endroit, en bas à gauche. Le problème est que mon pc est situé juste à côté du parking de la machine, c'est à dire, que pour faire les 0,0,0 tout d'abord je me tords le cou et après je fais plusieurs allers/retours pour ajuster, si je pouvais faire le 0,0,0 dans la zone près du parking cela serait bien plus pratique pour moi. J'ai donc pensé qu'il faudrait faire le dessin sous cambam en ayant l’extrémité au dessus à droite du carré sur l'origine des coordonnées, c'est bien cela? Et après donc faire le 0,0,0 sur la pièce au niveau de l’extrémité "en haut à droite"

3.-Fin de course axe Z : pour finir, je pense que j'ai mal paramétré le fin de course de mon axe z car après usinage quand je fais monter la fraise pour nettoyer, si je reste appuyé trop longtemps le z touche le détecteur de fin de course et tout bloque, je suis obligé d'aller sur les paramètres et en signaux d'entrée décocher les fin de courses des trois axes pour bouger la machine et reactiver les fin de courses. Par contre sur les axes x et y, la machine s'arrete juste avant de toucher les détecteurs, ce qui me semble normale. Que dois-je faire pour bien régler l'axe z?

Merci d'avance!
MV
MV
très actif
très actif

Messages : 227
Points : 489
Date d'inscription : 24/10/2012
Age : 37

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  dh42 le Mer 3 Sep 2014 - 19:25

Salut,

Pour gérer un palpeur fixe, c'est plus compliqué, car tu dois connaitre son décalage entre la surface de ta pièce et le palpeur .... il faut donc 2 palpeur, un mobile qui te permet de mesurer l'écart entre la pièce et le palpeur fixe, et l'autre pour la mise à 0 des outils. Çà n'a d’intérêt que si tu a un changeur d'outil automatique.

Pour l'emplacement du 0,0 sur le dessin, oui, c'est bien ça tu peux parfaitement le faire ailleurs du moment que ça correspond dans Cambam.

Pour le FC du Z, c'est bizarre, car il ne devrait pas être géré en fin de course mais en contact Home, c.a.d que ça ralentis à l'approche et que ça ne dépasse pas. Le référencement du Z fonctionne ? ; vérifie dans les entrées (menu config/port & pin ->onglet input signals) qu'il n'y a bien que X Home, Y Home et Z Home d'activés pour les contacts (coche verte dans la première colonne) et pas les Z++ ou Z--

Pour que les limites logiciel fonctionnent il faut:

- que la course des axes soit correctement renseignées dans le paramétrage.

- que les axes aient été référencés au démarrage de la machine.

- que les limites logiciel soient activées.(sur l'écran Automatique, la led doit être allumée au dessus du bouton activer limites)

++
David


_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17187
Points : 29867
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  MV le Sam 13 Sep 2014 - 10:37

Salut!

Merci pour toutes ces informations bien utiles!!

En ce moment je fais pas mal d'essais et je trouve moins le temps de passer par ici.

J'ai même commencé des usinages en 2D+3D grâce à tes tutos bien didactiques merci Usinage 2D+3D

alors, concernant les questions précédentes:

1.-Pour le palpeur: je me disais; si je change la procédure d'usinage en mettant le 0 en z à la surface du martyr et que à chaque fois je rentre dans cambam l'épaisseur de la matière à usiner (en lieu de faire le 0 en surface de la matière et usiner à -8 etc) je pourrait mettre la distance de décalage entre mon martyr et le moment où le palpeur s'active (en descendant "pas à pas" avec la broche)....je n'ai pas encore trouvé le temps de faire le test mais que est ce que tu en penses? Cela semble une manip correcte, non? Ma seule crainte c'est qu'il faut donner des dimensions d'usinage plus larges que la surface usinable normale pour permettre à la broche de venir toucher le palpeur qui est sur le coté, il faudrait pas qu'un jour j'usine la structure de la machine!!

2.-Pour les axes, j'avait en effet activé les z++ et z-- (ainsi que les x++ x-- y++ y--)....mais à quoi servent-ils?

3.-J'ai eu d'autres problèmes de fois par exemple mon axe x qui buttait contre le corps de la machine même après avoir touché le contact home, tous ces problèmes ont été résolus un fois le référencement des axes fait (je ne le faisais pas au début de chaque séance par oubli): est ce que cela vous arrive à vous aussi? c'est normale ce type de soucis quand on ne fait pas le référencement?
MV
MV
très actif
très actif

Messages : 227
Points : 489
Date d'inscription : 24/10/2012
Age : 37

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  dh42 le Sam 13 Sep 2014 - 17:04

Salut,

Pour le point 1, oui, tu peux tout à fait travailler avec le 0 pièce à la surface du martyre ; c'est même une bonne méthode si tu fais de la découpe, de cette manière, si tu met "profondeur finale" à -0.1 par exemple, tu est sur que tu découpera toujours ta pièce complètement, même si elle n'a pas exactement la bonne épaisseur (découpe de CP qui n'a jamais exactement la même épaisseur d'un lot à l'autre ...) ou que la pièce finale aura bien la bonne épaisseur en faisant un surfaçage à la cote, sans même devoir mesurer ton épaisseur.

Ou ça se complique, c'est si tu a des montages d'usinage (ou bêtement un étau) ; dans ce cas le 0 en Z ne sera plus au même endroit, mais il est toujours possible de mesurer le décalage table/fond d'étau et de mettre la correction dans le champ approprié de mach3.

2 - les Z++, Z-- etc sont les fins de course physiques (des contacts) ; en général sur nos machines il n'y en a pas ; il n'y a que les 3 contact de référencement, une fois que Mach3 connais le point 0,0,0 (grâce au référencement) et la course des axes (réglages dans les limites de mach3) alors il "sait" quand il doit arrêter le déplacement ; ce sont donc des fin de course logiciel .. qui ne fonctionne que si la machine à été référencée et quand les limites logiciels sont activées (bouton sur l'écran principal de Mach3)

3 oui, c'est probablement le cas ; au démarrage tu dois référencer. Tu dois aussi le faire si la machine à perdu des pas (si elle a tapé en butée par exemple), sinon tout sera décalé (Mach3 continu à "compter" la distance même si l'axe est bloqué)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17187
Points : 29867
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  MV le Jeu 30 Oct 2014 - 16:59

Bonjour


Je reprends ce post car je suis en train d'essayer de paramétrer le capteur d'outil.

Mon idée est toujours de faire le 0 avec le martyr et laisser le capteur fixe sur le châssis de la machine.

Pour cela, j'ai fait un référencement des axes et je voulais indiquer la position du capteur sauf que, comme j'ai des valeurs négatifs en x et y il m'est impossible de mettre ces valeurs sur les "position x" et "position y" de la fenetre palpeur....comment cela se fait?
MV
MV
très actif
très actif

Messages : 227
Points : 489
Date d'inscription : 24/10/2012
Age : 37

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  dh42 le Jeu 30 Oct 2014 - 20:35

Salut,

Je n'ai pas trouvé non plus, et comme je n'utilise pas du tout l'interface de Mach3FR, je ne comprends rien à sa manière de gérer ça scratch (même sans valeur négatives, déjà ça semble faire des trucs bizarres.)

Il y a une possibilité de mettre des valeurs négative pour la pos de changement d'outil, sur l'écran Réglages, mais ça n'a aucun effet.

Pour ma part, je me suis fait une bouton sur la page principale (avec MachScreen) qui me permet d'aller à ma pos de changement d'outil ; la position est directement codée dans le code du bouton en VbScript.

Première utilisation MACH3 Pos_ch10

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17187
Points : 29867
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Première utilisation MACH3 Empty Re: Première utilisation MACH3

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum