Premiers Pas avec SolidWorks.

Page 4 sur 5 Précédent  1, 2, 3, 4, 5  Suivant

Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  dh42 le Lun 22 Avr 2019 - 20:08

Salut,

Si la pièce est finie, alors tu la sauve d'abord au format Solidworks histoire de ne pas perdre l'arbre de création (format .sldprt), mais je suppose que c'est déjà fait  Very Happy  puis tu la sauve soit en STL soit en STEP si tu utilise CB V1.0 et que tu a besoins de contours 2D de qualité en plus de la forme 3D.

dans SW il n'y a pas de fonction exporter, tu fait "enregistrer sous", tu choisis le format STL et tu règle la résolution suivant besoin. (bouton options)

Ton objet est déjà une entité à part entière, rien de plus à faire.

Je te met une vidéo dans un moment Wink

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  dh42 le Lun 22 Avr 2019 - 20:45

Re

Sur cette vidéo, je montre 2 formats d'exportation possibles pour communiquer avec CamBam.

STL > pour CB 0.98 uniquement

STL ou STEP > pour CB 1.0

en STL l'objet est un bloc ; en STEP, CB crée une surface par face de l'objet et fournis en plus les contours de l'objet SANS facettisation.

toutes les surfaces obtenues avec le STEP peuvent être jointes pour obtenir un objet unique, comme si importé en STL.











Unable to display content. Adobe Flash is required.


++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Lun 22 Avr 2019 - 21:58

Merci David

C'est en gros ce que j'ai fait.

Voici le dessin dans sa version finale!
Premiers Pas avec SolidWorks. - Page 4 ZoDCS24

En version STEP AP203 sous CB, par contre j'ai du maillage...ou facettes...normal?
Mauvaise manip de ma part scratch
Premiers Pas avec SolidWorks. - Page 4 E23fHCR
@+
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  dh42 le Lun 22 Avr 2019 - 22:56

Pour l'instant le pb de l'importation STEP avec CB V1.0, c'est qu'il convertis le STEP en maillage(*) mais pour l'instant dans CB il n'y a pas de réglage de la résolution comme avec l'exportation STL, c'est un réglage fixe et il n'est pas forcément bien adapté (option à venir)

Si tu a besoin à la fois des lignes et arcs + d'un maillage propre sans trop de boulot, sauve au 2 formats, ouvre le STEP et ne garde que les lignes, puis importe le STL qui aura été sauvé avec une résolution fine.

Une autre option pour avoir des contours propres, c'est de faire une mise en plan en DXF depuis SW et de superposer le DXF et le STL

et enfin dernière méthode, ouvre uniquement le STL et fait une détection des contours, les arcs et les cercles seront facettisés par contre, et il faudra utiliser un "insérer des arcs" pour avoir un meilleur résultat.

je montre ces 2 dernières possibilités ici
http://www.metabricoleur.com/t13089-cambam-usinage-mixte-2d-3d

(*) en réalité, même si ça ne se voit pas forcément, tous les logiciels utilisent du maillage pour la représentation écran, y compris SW. Pour que la carte VGA puisse produire une surface 3D à l'écran, il lui faut des surfaces les plus simples possible, et la plus simple des surfaces est définie par 3 points, donc un triangle "plein"

Ce qui est surprenant c'est que ça t'affiche le maillage ; en principe, suivant le mode d'affichage choisis tu a soit une surface pleine, soit du fil de fer ... j'ai déjà vu cette bizarrerie sur mon autre PC, et ça semble dût à la carte VGA qui n'est probablement pas compatible DirectX10 vu son age ... sur le PC "neuf" ça ne le fait pas. (et ça ne le fait pas non plus sur la version 0.98 de CB, mais il utilise un DirectX et un .net framework plus vieux)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Mar 23 Avr 2019 - 12:35

Je trouve aussi cela étrange le fait de ne pas avoir une surface parfaitement "lisse", autant plus que mon PC est très récent
avec une grosse carte graphique...GTX1080 Pro Gaming 8Go sous W10 Pro 64 donc en principe auncu problème de ce côté là!
@+
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  dh42 le Mar 23 Avr 2019 - 21:37

Salut,

Tu a essayé le divers modes graphiques de CB pour voir si tu a le même résultat ? (tu peux zapper le mode GDI)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Mer 24 Avr 2019 - 20:01

dh42 a écrit:Salut,
Tu a essayé le divers modes graphiques de CB pour voir si tu a le même résultat ? (tu peux zapper le mode GDI)
++
David
Salut

Là en mode "GDI"... il existe un moyen de faire ressortir les arrêtes dans CB?
Premiers Pas avec SolidWorks. - Page 4 Jx3r2UZ
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  dh42 le Mer 24 Avr 2019 - 23:15

Salut,

Non, en mode GDI tu a des 3D toutes plates et l'affichage des arrête (CB V1.0) ne fonctionne pas avec ce mode.

Il te faut choisir entre OpenGL et OpenGL_legacy pour le mode. Si ça fonctionne avec Open_GL, alors tu a aussi 2 options de shading (ombrage)  GLSL_110 ou GLSL_330.

Pour ma part, je suis en OpenGL et GLSL_330 sur une carte Radeon RX 470.

Le mode GDI désactive complètement la gestion de l'OpenGL de la carte, et c'est le CPU du PC qui fait les calculs. C'est un mode à utiliser sur les vieux portables ou les PC de bureau à carte VGA intégrée.

PS, il faut redémarrer CB après un changement de mode graphique/shader

Les drivers de ta carte VGA sont bien installés ?  si tu tourne avec les drivers générique de Windows ça pourrait expliquer la chose.

mon PC est très récent avec une grosse carte graphique...GTX1080 Pro Gaming 8Go

faudrait le changer tous les 6 mois ! ça se périme plus vite que du lait ! What a Face

https://www.ldlc.com/fiche/PB00209764.html

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Ven 26 Avr 2019 - 21:30

Salut

Oui les cartes graphique périment a la vitesse de la lumière... Very Happy
Les drivers sont ceux de chez Nvidia, MSI propose les mêmes et ils sont a jour.

Voici le résultat sous CB V0.98, celle installée sur le PC de la CN, étrangement c'est beaucoup mieux...pourtant c'est un vieux
PC Dell de bureau qui a déjà quelque années...!
Premiers Pas avec SolidWorks. - Page 4 5Dlpqlj

L'essentiel c'est que ca fonctionne!
@+
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  dh42 le Ven 26 Avr 2019 - 22:07

Salut,

Oui, j'avais exactement les mêmes résultats sur mon ancien PC, l'affichage était normal sur la 0.98 et j'avais le maillage en superposition sur la 1.0 (ATI radeon 3870) ; je n'ai pas trouvé de solution et avec Andy on s'y est pris la tête dessus pendant 1 mois .... sans résultat ; en plus de ça il n'a jamais pu reproduire le pb sur ses PC ! donc ça complique la recherche de bug. On a finis par en déduire que c'était à cause de ma carte datant de 2008 ... mais apparemment ce n'est pas une question d'age ... Sur mon PC actuel en Win7 l'affichage est identique sur la 0.98 et la 1.0

note que sur le même PC (l'ancien) je n'avais ce défaut que sur la V1.0 et que sur Win7 ; sur Win XP l'affichage était normal.

Ça le fait dans les 2 modes OpenGL et OpenGL_legacy ?

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Dim 12 Mai 2019 - 18:36

Salut

Je suis en train de commencer un nouveau dessin et question Very Happy
Est'il possible de déplacer sur l'axe "Z" l'esquisse en cours (tracé bleu), pour faire simple, j'aimerais quelle soit sur l'autre face de la pièce!
Premiers Pas avec SolidWorks. - Page 4 HnZZDbM
Merci
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  silky le Dim 12 Mai 2019 - 21:12

bonsoir
à mon avis ce n'est pas déplacer l'axe Z mais déplacer "le plan" sur lequel l'esquisse est dessinée!
oui dans ce cas c'est possible
- tu sélectionnes ton esquisse dans l'arbre de création avec le bouton gauche, des icônes vont s'ouvrir
- tu sélectionnes "éditer le plan d'esquisse"
- une fenêtre va apparaître avec ton plan d'esquisse afficher
- tu le supprimes et tu sélectionnes la face qui te convient
- et tu valides
cela devrait fonctionner
sinon tu vas dans ton dossier de formation, dossier 3 "modéliser des pièces: les esquisses", vidéo 14 "éditer le plan d'une esquisse"

bon dessin

silky


silky
silky
très actif
très actif

Messages : 340
Points : 454
Date d'inscription : 08/10/2013
Age : 64

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  diomedea le Lun 13 Mai 2019 - 7:01

Bonjour,
En image:
Premiers Pas avec SolidWorks. - Page 4 Sans_244

++
JPaul
diomedea
diomedea
complétement accro
complétement accro

Messages : 10998
Points : 21659
Date d'inscription : 14/01/2009
Age : 59
Localisation : Bretagne (29)

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Lun 13 Mai 2019 - 22:24

Salut
Merci pour le coup de main Very Happy
C'est bon, j'ai réussi... cheers  Mais j'avoue que la manip n'est pas très simple a comprendre au début!
@+
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Mar 14 Mai 2019 - 20:19

Salut

Bon...visiblement je n'ai pas encore tout compris...je bute sur cette manip "Editer le plan d'esquisse"
J'ai beau lire et relire, visionner des vidéos...
J'ai pourtant réussi hier soir a continuer ma pièce...
Premiers Pas avec SolidWorks. - Page 4 Wppz1Jm

Maintenant j'aimerais faire une esquisse (je ne sais pas si le terme est le bon) sur les 3 cercles en bleu!
Premiers Pas avec SolidWorks. - Page 4 KsJE7lF

Je clic sur "Esquisse4" puis "Editer le plan d'esquisse" et voici ce que j’obtiens...je pense qu'un truc n'est pas normal non scratch
Est-ce que cela vient du fait que ce sont des "Bossages / Extrusions"?
Premiers Pas avec SolidWorks. - Page 4 QI2VXWH

Ensuite je valide...je ne suis toujours pas sur la partie souhaité...
Premiers Pas avec SolidWorks. - Page 4 Hxy2ida
Merci
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  dh42 le Mer 15 Mai 2019 - 1:52

Salut

Premiers Pas avec SolidWorks. - Page 4 KsJE7lF

Si tes 3 cercles en bleu sont tous à la même hauteur, il ne faut en sélectionner qu'un seul, et il faut cliquer sur la face elle même pour la sélectionner, pas dans l'arbre de création, puis dans la barre d'outil qui s'ouvre, tu choisis "esquisse" ; ça te créera une nouvelle esquisse sur un plan coplanaire avec ta face. A partir de la tu peux esquisser ce que tu veux extruder ou enlever sur chacune des 3 parties circulaires. Si elles ne sont pas à la même hauteur, alors il faudra faire une esquisse pour chaque hauteur différente.



++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Mer 15 Mai 2019 - 20:13

Salut
Merci David...en fait c'est tout simple...je me demande pourquoi je me complique si souvent la vie Very Happy
J'ai donc pu aller au bout de mon dessin, c'est un pare choc pour auto RC 1/8e!

Premiers Pas avec SolidWorks. - Page 4 Ttwtkgw

Premiers Pas avec SolidWorks. - Page 4 RrH3GF5
@


Dernière édition par juleo68 le Mer 15 Mai 2019 - 20:43, édité 2 fois
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  diomedea le Mer 15 Mai 2019 - 20:28

Salut,
Et voila, y'a plus qu'à CNCiser, ou à imprimer! Very Happy
diomedea
diomedea
complétement accro
complétement accro

Messages : 10998
Points : 21659
Date d'inscription : 14/01/2009
Age : 59
Localisation : Bretagne (29)

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Jeu 16 Mai 2019 - 21:10

diomedea a écrit:Salut,
Et voila, y'a plus qu'à CNCiser, ou à imprimer! Very Happy
Oui, ce sera fait entièrement a la CN!
@+
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Lun 12 Aoû 2019 - 18:42

Salut a tous!

Je suis en train de commencer un nouveau dessin 3D sous SW!
Dans ce dessin, j'aimerais créer plusieurs pièces qui formeront un ensemble, j'ai donc commencé par créer une esquisse qui me donne ma première pièce.

Maintenant, je n'arrive pas a comprendre comment je dois faire pour créer une seconde pièce (différente de la première). dois-je créer une seconde esquisse?
Si oui, comment scratch là je sèche!
Merci.
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  dh42 le Lun 12 Aoû 2019 - 19:08

Salut,

Tu dois créer chaque pièce séparément (un fichier .sldprt par pièce) ; ensuite tu crée un assemblage dans lequel tu importe tes pièces et tu met des contraintes d'assemblage.

Un exemple d'assemblage ici



++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17186
Points : 29866
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Lun 12 Aoû 2019 - 21:51

Merci David!

Je testerais l'assemblage Very Happy
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Mar 13 Aoû 2019 - 13:27

Salut

Nouveau problème...j'ai beau regardé différent tutos, je ne trouve rien a ce sujet, ou alors je
n’utilise pas les bon termes!

J'ai créer une pièces dont l'origine est a l'envers, en fait la pièce par rapport au trièdre SW est a l'envers sur l'axe "Z", j'aimerais donc tourner la pièce sur elle même!
Je ne sais pas si je suis clair?
Merci.

juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  silky le Mar 13 Aoû 2019 - 14:31

bonjour
et qu'est-ce qui gêne que l'origine ne soit pas comme tu le désires?

silky
silky
silky
très actif
très actif

Messages : 340
Points : 454
Date d'inscription : 08/10/2013
Age : 64

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  juleo68 le Mar 13 Aoû 2019 - 14:49

silky a écrit:bonjour
et qu'est-ce qui gêne que l'origine ne soit pas comme tu le désires?
silky

Salut
Ben ca n'est pas comme cela devrait être Very Happy
Et je cherche a comprendre...donc a savoir faire, merci.
juleo68
juleo68
complétement accro
complétement accro

Messages : 798
Points : 1447
Date d'inscription : 13/07/2013
Age : 48
Localisation : 68

Revenir en haut Aller en bas

Premiers Pas avec SolidWorks. - Page 4 Empty Re: Premiers Pas avec SolidWorks.

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 4 sur 5 Précédent  1, 2, 3, 4, 5  Suivant

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum