Fichier gcode

Aller en bas

Fichier gcode

Message  Thierry67 le Mer 3 Jan 2018 - 18:13

Bonjour et bonne année.
Depuis peu quand je crée le fichier gcode j'ai ces messages en dessous de la fenêtre du plan de cambam (voir photo)



Et quand j'importe le fichier dans Camotics comme nouveau projet j'ai ça qui s'affiche (voir photo)



Si vous avez des explications, merci d'avance.
avatar
Thierry67
petit nouveau
petit nouveau

Messages : 44
Points : 62
Date d'inscription : 19/12/2016
Age : 57
Localisation : Bas Rhin

Revenir en haut Aller en bas

Re: Fichier gcode

Message  dh42 le Mer 3 Jan 2018 - 23:56

Salut,

Ça veux dire que tu a des caractères/textes erronés dans ton Gcode.

Tu a certainement mis du texte à un endroit ou il ne faut pas, soit directement dans ton fichier cambam (propriétés en tête ou fin d'opération/fichier personnalisé dans une opération d'usinage ou dans les paramètres du dossier Usinage) , soit dans le post processeur que tu utilise ou dans une biblio d'outil.

essai de générer ton Gcode avec un autre post processeur que celui que tu utilise habituellement, si ça marche c'est que le problème est dans le post pro ; si c'est pas mieux, c'est que le pb est dans une opération d'usinage de ton fichier ou dans une définition d'outil de la bibliothèque.

Si tu a le problème sur tous les fichiers, alors il y a de fortes chances que ça vienne soit du post pro soit d'une définition d'outil erronée.

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 15363
Points : 28029
Date d'inscription : 21/06/2009
Age : 54
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Fichier gcode

Message  Thierry67 le Sam 6 Jan 2018 - 11:21

Bonjour et merci pour la réponse DH42. Excuse du retard mais j'étais en déplacement.
Ayant acheté la licence, j'ai effectivement commencé à compléter la bibliothèque d'outils. Je viens de faire des tests et l'erreur venait du post processeur emc2-speed que j'ai installé en suivant le tuto.
J'ai pourtant suivi les instructions et fait un copié coller de la ligne a modifié. scratch

Pour info voici le code du post processeur emc2-speed
Code:
<?xml version="1.0" encoding="utf-8"?>
<PostProcessor xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <PostFile>{$comment} Made using CamBam - http://www.cambam.co.uk {$endcomment}
{$header}
{$mops}
{$footer}
</PostFile>
  <Header>{$comment} {$cbfile.name} {$date} {$endcomment}
{$tooltable}
{$cbfile.header}
{$units} {$distancemode} {$velocitymode} P0.05 {$cuttercomp(off)}\\
{$toolchange(first)}
{$clearance}</Header>
  <Footer>{$clearance}
{$spindle(off)}
{$endrewind}
{$cbfile.footer}
</Footer>
  <ToolTableItem>{$comment} T{$tool.index} : {$tool.diameter} {$endcomment}</ToolTableItem>
  <ToolChange>{$clearance}
{$comment} T{$tool.index} : {$tool.diameter} {$endcomment}
T{$tool.index} M6</ToolChange>
  <MOP>{$comment} {$mop.name} {$endcomment}
{$toolchange}
{$velocitymode} {$workplane}
{$mop.header}
{$spindle} {$s}
{$blocks}
{$mop.footer}
</MOP>
  <G0>G0</G0>
  <G1>G1</G1>
  <G2>G2</G2>
  <G3>G3</G3>
  <G81>G81</G81>
  <G82>G82</G82>
  <G83>G83</G83>
  <Rapid>{$g0} {$_f} {$_x} {$_y} {$_z} {$_a} {$_b} {$_c}</Rapid>
  <FeedMove>{$g1} {$_f} {$_x} {$_y} {$_z} {$_a} {$_b} {$_c}</FeedMove>
  <ArcCW>{$g2} {$_f} {$_x} {$_y} {$_z} {$i} {$j} {$k}</ArcCW>
  <ArcCCW>{$g3} {$_f} {$_x} {$_y} {$_z} {$i} {$j} {$k}</ArcCCW>
  <Drill>{$g81} {$_x} {$_y} {$_z} {$r} {$_f}</Drill>
  <DrillDwell>{$g82} {$_x} {$_y} {$_z} {$p} {$r} {$_f}</DrillDwell>
  <DrillPeck>{$g83} {$_x} {$_y} {$_z} {$q} {$r} {$_f}</DrillPeck>
  <Comment>(</Comment>
  <EndComment>)</EndComment>
  <NumberFormat>0.0####</NumberFormat>
  <UpperCase>false</UpperCase>
  <MinimumArcLength>1e-4</MinimumArcLength>
 <MaximumArcRadius>1e5</MaximumArcRadius>
</PostProcessor>


Dernière édition par Thierry67 le Sam 6 Jan 2018 - 11:53, édité 2 fois
avatar
Thierry67
petit nouveau
petit nouveau

Messages : 44
Points : 62
Date d'inscription : 19/12/2016
Age : 57
Localisation : Bas Rhin

Revenir en haut Aller en bas

Re: Fichier gcode

Message  Thierry67 le Sam 6 Jan 2018 - 11:51

Je me réponds à moi même.
En copiant collant la ligne du tuto dans le code, j'ai inclus les 2 slachs inversés qui sont en fin de linge. Je les ai supprimés et le post pro emc2-speed ne génère plus d'erreur.
Yep, vais enfin pouvoir tester les plugins. Very Happy Very Happy Very Happy
avatar
Thierry67
petit nouveau
petit nouveau

Messages : 44
Points : 62
Date d'inscription : 19/12/2016
Age : 57
Localisation : Bas Rhin

Revenir en haut Aller en bas

Re: Fichier gcode

Message  dh42 le Ven 12 Jan 2018 - 1:51

Salut,

Yep, vais enfin pouvoir tester les plugins.

Je vois que tu est sous Linux ; attention, pour certain plugins (les miens entre autre), il faut ajouter une biblio de plus à linux qui n'est pas listée dans l'insta standard avec:

sudo apt-get install libmono-microsoft-visualbasic10.0-ci

Note que les post pro sont éditables directement depuis CamBam, sous l'onglet système, inutile d'utiliser un éditeur de texte, tu peux changer les valeurs et éditer les macros directement dans la grille de propriétés une fois un PP sélectionné dans la liste.

http://www.atelier-des-fougeres.fr/Cambam/Aide_V1/cam/PostProcessor.htm

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 15363
Points : 28029
Date d'inscription : 21/06/2009
Age : 54
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum