Je roule en NVEM !

Aller en bas

Je roule en NVEM ! Empty Je roule en NVEM !

Message  gipet le Jeu 4 Juil 2019 - 17:12

Bonjour,
Voila, c'est fait, je roule en NVEM. En disant cela, j'ai l'impression de savourer l'achat de ma Ferrari après 18 ans d'économie !
Bref, j'explique:
Je m'étais fait une machine à faire les coques de macarons en CN (si, si ...). La première version était réalisée en récupérant les composants d'une machine à découper que j'avais construite sans jamais savoir la faire marcher (j'étais encore en activité).
Une fois en retraite, je l'ai adapté pour les macarons. La carte CN était une Xories avec connexion LPT 20 broches.
Cette à donné satisfaction pendant 7 ans sans broncher.
Mais comme cette machine était un peu archaïque (surtout du coté des normes alimentaires...) j'ai voulu la refaire complètement et utiliser une carte moderne.
J'ai donc refait toutes les pièces mécaniques, en impression 3D, s'il vous plait ! et acheté une carte CN avec liaison USB.
J'avais prévu une semaine complète de démontage, remontage et config de la nouvelle carte.
Du coté mécanique, pas de problème, la classe !
Mais du coté carte CNC, la galère a commencé. Autour dire de suite que la carte USB est partie à la poubelle au bout de trois jours d'essais. Des bugs, des bugs et des bugs.
Je me décidé à tester la NVEM en Ethernet. Bien sûr, trois semaines d'attente pour la livraison. Je ne comprend pas que cette entreprise n'ait pas de revendeur en France comme l'avait Xories.
Bref, re-démontage, re-cablage (bien sûr, les fils sont devenus trop courts et câblés autrement), et essais. Tout c'est presque bien passé jusqu'au branchement ultime du moteur (broche). Impossible de le faire tourner. Les sorties OUT (collecteur ouvert qui disent...) ne donnent rien, jamais rien ! J'ai tout essayé: un relais 24 V, un relais 12 V, des pull-up, des pull-down, aucun signal au métrix. Finalement, après avoir épuisé mon stock de jurons, j'ai bien consulté un site web (le concurrent...) et un utilisateur conseillait d'utiliser une carte de relais style Arduino. 10 euros d'investissement et une semaine d'attente, mais une satisfaction: ça marche !
Finalement la conclusion après deux mois de galère: Bien la carte NVEM, toujours aussi fastidieux de programmer Mach3, pas trop mal expliqué dans la notice (en anglais), dommage qu'ils ne proposent pas une carte supplémentaire pour les relais.
Moi, maintenant, je suis définitivement faché avec les transistors à "collecteur ouvert"...
Une petite démo: https://youtu.be/LBMFJICgWJw
gipet
gipet
petit nouveau
petit nouveau

Messages : 9
Points : 13
Date d'inscription : 19/05/2014
Age : 72

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  nagut le Jeu 4 Juil 2019 - 18:22

Bonjour

je viens de regarder ta vidéo, et y a pas a dire : c'est original drunken

la seule limite de ce genre de machine est bien .....l'imagination Very Happy

Bravo
nagut
nagut
complétement accro
complétement accro

Messages : 1490
Points : 1714
Date d'inscription : 17/08/2010
Age : 68
Localisation : Haut Jura

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  momoclic le Jeu 4 Juil 2019 - 19:13

Wouarf !
Bravo magnifique réalisation, félicitations Very Happy
momoclic
momoclic
acharné du forum
acharné du forum

Messages : 544
Points : 552
Date d'inscription : 12/10/2016
Age : 71
Localisation : Nantes

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  dh42 le Jeu 4 Juil 2019 - 19:21

Salut,

Excellent ! ; une imprimante à gâteaux cheers ... je veux la même qui marche avec du chocolat jesors

Je me décidé à tester la NVEM en Ethernet. Bien sûr, trois semaines d'attente pour la livraison. Je ne comprend pas que cette entreprise n'ait pas de revendeur en France comme l'avait Xories.
Bref, re-démontage, re-cablage (bien sûr, les fils sont devenus trop courts et câblés autrement), et essais. Tout c'est presque bien passé jusqu'au branchement ultime du moteur (broche). Impossible de le faire tourner. Les sorties OUT (collecteur ouvert qui disent...) ne donnent rien, jamais rien ! J'ai tout essayé: un relais 24 V, un relais 12 V, des pull-up, des pull-down, aucun signal au métrix. Finalement, après avoir épuisé mon stock de jurons, j'ai bien consulté un site web (le concurrent...) et un utilisateur conseillait d'utiliser une carte de relais style Arduino. 10 euros d'investissement et une semaine d'attente, mais une satisfaction: ça marche !
Finalement la conclusion après deux mois de galère: Bien la carte NVEM, toujours aussi fastidieux de programmer Mach3, pas trop mal expliqué dans la notice (en anglais), dommage qu'ils ne proposent pas une carte supplémentaire pour les relais.
Moi, maintenant, je suis définitivement faché avec les transistors à "collecteur ouvert"...

Oui, ces cartes ne sont pas chères, mais ça n'a pas l'air d'être un cadeau (pas une Ferrari en tout cas !) ... mais bon, au 1/3 du prix d'une carte d'interpolation "de marque" et qui intègre la BoB, on ne peux pas demander la Lune. C'est une vraie NVEM ou un de ses clones ?

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17575
Points : 30261
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  speedjf37 le Ven 5 Juil 2019 - 6:26

Bonjour,

Belle réalisation avec le mix méca et imp3D !

Hormis le plaisir de la réalisation de la machine , quels sont les avantages attendus (régularité formes diverses) ?

Quelle matière utilisée pour l'alimentaire ?

Vu les impression 3D réalisées , créer un "poussoir" pour vider les passages (pour faciliter le nettoyage) ne devrait pas être difficile.
Je suggère des écrous papillon pour le carter en imp3D.


JF
speedjf37
speedjf37
petit nouveau
petit nouveau

Messages : 43
Points : 43
Date d'inscription : 03/03/2015
Age : 62
Localisation : TOURS

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  tonyproof le Ven 5 Juil 2019 - 6:59

excellent comme machine
tonyproof
tonyproof
complétement accro
complétement accro

Messages : 1485
Points : 2197
Date d'inscription : 18/10/2012
Age : 46
Localisation : loiret montargis

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  bricolo36 le Ven 5 Juil 2019 - 7:02

Magnifique travail, combien de temps pour régler le débit de pâte afin qu'elle ne bave pas scratch cheers
bricolo36
bricolo36
très actif
très actif

Messages : 234
Points : 246
Date d'inscription : 24/10/2018
Age : 74
Localisation : 36150

Revenir en haut Aller en bas

Je roule en NVEM ! Empty NVEM

Message  gipet le Ven 5 Juil 2019 - 13:39

- Avec du chocolat ?
Pas de problème ! Faut juste une buse chauffante.
- Pour la matière de qualité alimentaire seul le PETG fonctionne. Mais ce n'est pas "officiel", ou cela ne l'est plus...
En fait, les pièces réalisées en impression 3D ne sont pas étanches et laissent passer un peu liquide. Ce qui en alimentaire pose un problème de moisissure interne.
J'ai trouvé une parade en trempant les pièces dans de l'alginate (plâtre spécial pour contact alimentaire) pendant quelques heures pour qu'elles s'imbibent. Puis je les sèchent. L'idéal serait même de le faire sous vide. Ce serait une solution "homologable".
- Vu le prix des cartes NVEM, je trouve stupide d'acheter une copie !
- Le temps mis à galérer pour une mise en service vient plutôt d'une incompétence en électronique (je l'avoue) et de la complexité de Mach3 qui sait faire tellement de choses qu'on ne sait plus par quoi commencer.
- A noter que j'ai ajouté une résistance de "pull-down" sur l'entrée des Z (2.5 m de longueur de câble). J'avais de temps en temps une détection aléatoire du fin de course.
gipet
gipet
petit nouveau
petit nouveau

Messages : 9
Points : 13
Date d'inscription : 19/05/2014
Age : 72

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  FMJ le Ven 5 Juil 2019 - 14:45

Marrant !!!! cheers

Par contre est-ce un plastique de "classe" alimentaire ?
FMJ
FMJ
complétement accro
complétement accro

Messages : 1934
Points : 2625
Date d'inscription : 27/05/2013
Age : 102
Localisation : Sud sud sud Ouest

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  dh42 le Dim 7 Juil 2019 - 23:31

Salut,

- Vu le prix des cartes NVEM, je trouve stupide d'acheter une copie !

Je ne sais pas si c'est tj le cas, mais même les vraies NVEM il y en avait à des prix vraiment très différents, de 60€ pour la moins chère à plus de 100€ ... difficile de s'y retrouver et de savoir pourquoi de telles différences.

exemple ici à 136€ la carte (+35€ de port  scratch )
https://www.ebay.fr/itm/MACH3-Motion-Control-Card-NVEM-CNC-Controller-6-Axis-MACH3-Ethernet-Interface-Mo/123620031217?hash=item1cc853faf1:g:9UAAAOSw5i5cUUUs

et la une autre V2 6 axes à 70€ port gratuit
https://www.ebay.fr/itm/6-Axis-NVEM-CNC-Controller-200KHz-Ethernet-Mach3-Motion-Control-Card-I6M2/223556903035?hash=item340d07a07b:g:NlwAAOSwpoxdCaVR

Une sérigraphie différente sur les 2 cartes ....  scratch originale ou copie ? ... difficile à dire.

Apparemment les Chinois ne se gênent pas pour copier même les logos et les références produit ...

exemple avec les drivers LeadShine.
https://www.usinages.com/threads/hbs86h-leadshine-aide-et-infos.112503/#post-1325718

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17575
Points : 30261
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Je roule en NVEM !

Message  gipet le Lun 8 Juil 2019 - 10:02

Personnellement, j'ai payé une NVEM à 3 axes environ 65 €. Les prix officiels du revendeur Lollette vont de 60 (3 axes) à 130 (6 axes).
Mais, c'est vrai, pas moyen de savoir si c'est une copie une fois le produit en main !
J'en profite pour poser une question sur MACHSCREEN.
Pour l'instant, je travaille avec l'écran Mach3 standard que j'ai modifié.
J'essaie de faire un écran spécifique pour mon application en le composant avec Machscreen, en vue de l'utiliser avec une tablette tactile.
J'ai réussi (en recopiant l'écran standard....) à presque tout faire. Mais je n'arrive pas à ajouter les fenêtres ou s'affiche le fichier en cours d'utilisation et la fenêtre de messages d'erreurs.
Quelqu'un a une idée ?
gipet
gipet
petit nouveau
petit nouveau

Messages : 9
Points : 13
Date d'inscription : 19/05/2014
Age : 72

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  dh42 le Lun 8 Juil 2019 - 16:18

Salut,

Pour ajouter une fenêtre de GCode

choisis Gcode dans la liste, clique sur le bouton Ajouter puis dans la fenêtre à l'endroit ou tu veux mettre la fenêtre Gcode.

Je roule en NVEM ! Fenetr10

Pour l'affichage du nom de fichier, erreur et nom du profile ; c'est un objet Label (tj dans la même liste) ; même principe pour le créer.

Ensuite suivant le type d'info qu'il devra retourner, tu devra éditer la propriété Label de l'objet et remplacer Text par File, Error ou Profile suivant ce que tu veux afficher.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17575
Points : 30261
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Je roule en NVEM !

Message  gipet le Mar 9 Juil 2019 - 9:55

Bonjour,
Jusque là, je sais faire. C'est après que je sèche. Comment faire pour que le label communique avec l'info (nom du fichier en cours, message d'erreur...).
Lorsqu'on charge l'écran type de Mach3 et qu'on l'analyse, il est impossible d'avoir accès au codage.
gipet
gipet
petit nouveau
petit nouveau

Messages : 9
Points : 13
Date d'inscription : 19/05/2014
Age : 72

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  dh42 le Mar 9 Juil 2019 - 22:51

Salut

C'est le fait de mettre File ou Error dans la propriété Label qui dit à Mach3 que ce label devra recevoir le nom du fichier en cours ; apparemment il n'y a rien de plus à faire.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17575
Points : 30261
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  BSMbrahim le Mer 10 Juil 2019 - 9:55

Bonjour
belle réalisation bravo pour l'originalité bonne continuation
BSMbrahim
BSMbrahim
je prends du galon
je prends du galon

Messages : 51
Points : 59
Date d'inscription : 06/07/2018
Age : 37
Localisation : Algérie

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Je roule en NVEM !

Message  gipet le Mer 10 Juil 2019 - 16:17

C'est vrai David !
C'est mieux d'écrire en anglais dans les labels !
Avec le mot "file", le fichier s'inscrit automatiquement à la place.
J'ai presque fini l'interface !
Merci pour ton aide

Gipet
gipet
gipet
petit nouveau
petit nouveau

Messages : 9
Points : 13
Date d'inscription : 19/05/2014
Age : 72

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Je roule en NVEM !

Message  gipet le Ven 9 Aoû 2019 - 15:21

Bonjour,
Ma carte NVEM fonctionne bien.
J'ai quand même un problème curieux.
Mach3 active deux actions en même temps, sur les commandes broche.
Par exemple:
N10 G91 G0 .....
N15 M3
N20 G91 G2 ....
....
N60 G91 G2 ....
N65 M5
N70 G91 G0 ...
Dans ce cas, Mach3 fait en même temps la ligne N10 et N15
De même, il fait en même temps la ligne N65 et la ligne N70.
J'ai solutionné le pb en mettant des tempos entre N10 et N15 (1 seconde) et entre les lignes N65 et N70.
J'ai aussi mis à 0.1 les tempos dans la config.
Le problème est que je ne sais pas si cela vient de Mach3 ou de la carte NVEM.
Quelqu'un a une idée ?
gipet
gipet
petit nouveau
petit nouveau

Messages : 9
Points : 13
Date d'inscription : 19/05/2014
Age : 72

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  dh42 le Ven 9 Aoû 2019 - 19:30

Salut,

Le problème est que je ne sais pas si cela vient de Mach3 ou de la carte NVEM.

Non, Mach3 effectue bien les commandes séquentiellement, il ne passe pas à la suivante tant que la précédente n'est pas finie.

Par contre, avec une carte externe, Mach3 envoie toute une série de ligne de Gcode à la carte, qui sont stockées dans une mémoire (sur la carte), donc suivant le nb de lignes qui ont été stockée dans la mémoire de la carte, si tu fais une pause, par exemple, ça ne s’arrêtera que lorsque la mémoire sera vide.

Un exemple de ce qui se passe avec un code similaire au tiens, en simu.

https://www.screencast.com/t/rrWDNknl1IW

Ça te fais des bizarreries en usinage ?

C'est bizarre ce codage tout en relatif (G91) ... et cette répétition du G91 à chaque ligne .... tu fait ton GCode avec quel soft ?

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17575
Points : 30261
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Je roule en NVEM !

Message  gipet le Mar 13 Aoû 2019 - 13:39

bonjour,
merci pour les infos.
Si j'ai bien compris, ce problème ne peut venir que de la carte NVEM. Moi, cela ne me dérange pas trop, mais pour faire de l'usinage le problème peut être grave.
Je pose la question aux autres éventuels utilisateur de NVEM: avez-vous eu un problème de ce genre ?
Pour ce qui est du codage en G91, cela vient du fait que je procède avec une suite de sous-programmes (voir la vidéo).

Jean-Pierre
gipet
gipet
petit nouveau
petit nouveau

Messages : 9
Points : 13
Date d'inscription : 19/05/2014
Age : 72

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  dh42 le Mar 13 Aoû 2019 - 20:31

Salut,

Il y a certes quelques bugs sur la NVEM, mais je n'ai jamais entendu parler de celui-la, et ce serait le cas si ça rendait l'usinage impossible.

Il faudrait voir s'il n'y a pas un réglage quelconque directement dans le plugin de la NVEM.

Quand tu dis que ça active 2 fonctions en même temps, ça le fait effectivement sur la machine, ou c'est juste que ça exécute 2 lignes sur l'affichage ? si c'est juste à l'affichage, c'est peut être simplement que Mach3 indiques quelles lignes ont été envoyées à la carte et stockées dans sa mémoire ?

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17575
Points : 30261
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Je roule en NVEM !

Message  gipet le Jeu 15 Aoû 2019 - 17:29

Bonjour,
C'est bien sur la machine que le problème se produit.
Maintenant, j'ai plus grave: il semble de temps en temps que certaines lignes ne soient pas lues et pas interprétées par la carte.
Sur la doc NVEM, pas d'indications sur d'éventuels réglages. Existe-t-il une possibilité de réglage sur Mach3 ?
En lisant les posts, tout le monde semble pourtant satisfait de cette carte.
Amitiés

Jean-Pierre
gipet
gipet
petit nouveau
petit nouveau

Messages : 9
Points : 13
Date d'inscription : 19/05/2014
Age : 72

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  dh42 le Jeu 15 Aoû 2019 - 20:43

Salut,

Ah ! et bien je ne sais pas d’où peut venir ce problème.

Le seul truc que je connais sur Mach3 qui pourrait avoir un rapport, c'est le "look ahead", qui détermine combien de lignes sont lues à la suite. Par contre je ne suis pas sûr que ça ai un rapport avec la carte ; de ce que j'ai compris du fonctionnement, ça sert pour le dispositif de vitesse constante en définissant combien de lignes sont prises en compte pour faire la planification de trajectoire. Sur l'ESS, ce qui détermine combien de lignes seront misent en mémoire sur la carte, c'est la fréquence utilisée ; plus la fréquence est élevée, moins il y a de lignes stockées en mémoire sur la carte.

Tu a essayé une autre version du plugin pour la carte ? (attention, ce n'est pas le même plugin pour la NVEM et la NVEM V2)
https://www.nvcnc.net/nvem.html

++
David


_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 17575
Points : 30261
Date d'inscription : 21/06/2009
Age : 55
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Je roule en NVEM ! Empty Re: Je roule en NVEM !

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum