Problème avec carte ESS

4 participants

Page 1 sur 2 1, 2  Suivant

Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Mer 24 Nov 2021 - 15:41

Bonjour à tous,
Ce matin je m’apprêtais à utiliser ma CNC, la machine était ON et Mach3 en fonctionnement, pas d'usinage en cour, j'utilise un PC portable sous W7. Une coupure secteur à eut lieu qui a durée environs 20 s, quand la tension secteur est revenu Mach3 à refuser de s'ouvrir, après analyse, il s’avère que c'est la carte ESS qui a un problème, les échanges de pings ce font correctement entre le PC et la carte mais pas de fonctionnement, j'ai isolé la carte de la machine en débranchant le câble plat le problème est toujours présent. Je suis surpris car à priori la carte est équipé d'optocoupleur, le PC est resté en marche durant la coupure mais rien d'anormal, il m'arrivait souvent d'avoir le PC en marche avec la machine à l'arrêt et connectée, jamais de problèmes.  scratch  Quelqu'un a t'il déjà eut ce problème et si oui comment l'a t'il réglé, si non quoi faire ?
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  dh42 Mer 24 Nov 2021 - 19:00

Salut

Tu a essayé de rèinstaller le plugin de l'ESS ? le plantage à peut être endommagé le fichier.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 21997
Points : 34700
Date d'inscription : 21/06/2009
Age : 58
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Mer 24 Nov 2021 - 19:57

Bonsoir David,

J'y ai pensé mais je ne l'ai pas fait Very Happy Je teste demain matin et je te dirai.
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Jeu 25 Nov 2021 - 10:07

Bonjour David,

Après réinstallation du pluging, le problème est 'presque' le même, j'ai un message d'erreur "The ESS has an invalid bootloader signature" hier je l'avais eut une fois cette fois si pratiquement à chaque démarrage ce message monte, si je presse sur OK Mach3 s'ouvre une fois sur deux mais il ne prend pas les commandes. Il est possible que le soft qui est dans l'ESS soit corrompu ? scratch  je suppose qu'il me faut utiliser "Configurator" ou "SCU Installer" ou les deux ! pour recharger le soft dans l'ESS. Si tu peux me confirmer et me donner la procédure ou au moins me dire ou la trouver, mon anglais n'est pas très au point ! j'ai du mal avec le site de Warp9. Very Happy

A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  dh42 Jeu 25 Nov 2021 - 21:59

Salut,

Voila le FAQ sur ce problème

What do I do after a "Invalid Bootloader Signature" Message?

This message means that Mach3 was unable to talk with your ESS when you launched it.  Typically this is caused by Mach not shutting down and releasing the ESS correctly on the previous run.

To fix this:

   Close Mach
   Power off your SmoothStepper, and wait 5 seconds
   Power the SmoothStepper
   Start Mach again

Mach3 should then be able to successfully connect to, and then work with the ESS.

Ce message signifie que Mach3 n'a pas pu communiquer avec votre ESS lorsque vous l'avez lancé. Cela est généralement dû au fait que Mach n'a pas arrêté correctement l'ESS lors de l'exécution précédente.

Pour résoudre ce problème :

    Fermer Mach
    Éteignez votre SmoothStepper et attendez 5 secondes
    Alimentez le SmoothStepper
    Redémarrer Mach

Si ça ne marche pas, je crains que tu ne soit obligé de refaire ton insta de Mach3 ; tu dois avoir un fichier qui a été corrompu lors du plantage. Tente de le réinstaller par dessus (n'oublie pas de sauver ton fichier de config machine si tu ne veux pas être obligé de refaire tout le paramétrage)

Il est possible que le soft qui est dans l'ESS soit corrompu ?

Non, c'est peu probable.

je suppose qu'il me faut utiliser "Configurator" ou "SCU Installer" ou les deux ! pour recharger le soft dans l'ESS.

Non, le SCU ne sert pas à recharger le firmware de l'ESS mais juste à régler les adresses IP pour le réseau, et il n'y a pas de raison qu'elles aient changées (de toute façon si un ping fonctionne, c'est que l'IP est OK) .. une fois Mach3 réinstallé, il n'y a que le plugin à remettre en place (et si tu installe Mach3 par dessus l'ancien, le plugin devrait toujours être la)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 21997
Points : 34700
Date d'inscription : 21/06/2009
Age : 58
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Ven 26 Nov 2021 - 10:23

Bonjour David,

Si ça ne marche pas, je crains que tu ne soit obligé de refaire ton insta de Mach3 ; tu dois avoir un fichier qui a été corrompu lors du plantage. Tente de le réinstaller par dessus (n'oublie pas de sauver ton fichier de config machine si tu ne veux pas être obligé de refaire tout le paramétrage)

J'ai refait l'installation de Mach3 sans supprimer la précédente, j'ai pris la précaution avant, de sauvegarder tous les fichiers de Mach3 ailleurs. Après réinstallation, j'ai remplacé les fichiers .xml et .set par mes anciens fichiers j'espère que je n'ai pas fait une bêtise, voici les fichiers remplacés :
1024.lset                      
en écrivant je me rends compte que ce fichier n'est pas un .set mais un .iset drunken
1024.set
Alu_Line_0605.xml        
C'est ma config
Engscreenset_V2.set
mach3fr-fraisage_fullscreen.set
Mach3Mill.xml
Screen4.xml

Je ne pense pas en avoir oublié !
J'ai relancé la machine et Mach3, le problème est toujours présent comme hier.  scratch
J'ai retesté la communication avec la carte ESS, les pings passe bien il n'y a pas de perte.
Ce que je peux dire en plus de ce que je t'ai déjà dis, j'ai l'impression que la communication de l'ESS vers Mach3 se fait mais pas dans l'autre sens, ce qui me fait dire ça, lorsque Mach3 est ouvert si je presse sur la touche arrêt d'urgence et que l'arrêt d'urgence n'est pas actif, la touche arrête de clignoter et passe au vert. De plus l'affichage des valeurs des axes est correct.
Si j'avais le schéma détaillé de la carte ESS ainsi que l'implantation des composants, je pourrai regarder si je trouve un composant HS. Si problème il y a pour moi il ce situe après l'interface Ethernet, c'est tous ce que je peux dire pour le moment. scratch

A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  CNCServ Ven 26 Nov 2021 - 11:26

Si c'est un des fichiers que tu as remplacé qui est corrompu, c'est normal que tu retrouve le même problème.
CNCServ
CNCServ
posteur Régulier
posteur Régulier

Messages : 155
Points : 161
Date d'inscription : 24/04/2021
Age : 63
Localisation : Royan

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  Jean47 Ven 26 Nov 2021 - 12:15

Si c'est un des fichiers que tu as remplacé qui est corrompu, c'est normal que tu retrouve le même problème.
Pour lever le doute, j'ai rechargé Mach3 sans modifier aucun fichier, le problème est toujours présent, je vais attendre la réponse de David. La solution est peut être de désinstaller Mach3 avant de refaire l'installation. Que ce passe t'il avec la licence dans ce cas ? scratch
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  Hervé-34 Ven 26 Nov 2021 - 13:15

Bonjour !

Jean47 a écrit: Que ce passe t'il avec la licence dans ce cas ? scratch
A+
Jean47

Déjà tu devrais  avoir un dossier avec toutes tes licences !
tu gardes, dans Mach3 le fichier --mach!lic.dat--

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3374
Points : 4471
Date d'inscription : 07/07/2014
Age : 70
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  Jean47 Ven 26 Nov 2021 - 14:19

Bonjour Hervé,
Déjà tu devrais  avoir un dossier avec toutes tes licences !
tu gardes, dans Mach3 le fichier --mach!lic.dat--
OK s'il faut juste intégrer le fichier clé c'est parfait, j'avais peur que le fichier clé ne puisse servir qu'un seule fois.  tongue Le fichier est sauvegardé dans un autre PC avec la clé de Cambam.
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  Hervé-34 Ven 26 Nov 2021 - 14:33

Salut Jean !

Non, c'est comme avec Cambam, tu peux
mettre ta clé sur 15 pc si tu veux ! ça c'est bien !

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3374
Points : 4471
Date d'inscription : 07/07/2014
Age : 70
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Ven 26 Nov 2021 - 14:56

Non, c'est comme avec Cambam, tu peux
mettre ta clé sur 15 pc si tu veux ! ça c'est bien !
Ça c'est très bien, je peux utiliser des vieux PC pour tester si besoin. merci
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  dh42 Ven 26 Nov 2021 - 15:23

Salut,

Oui, fait une insta complète sur un autre PC pour voir, comme dis CNCSERV, si ça se trouve c'est ton fichier de config qui est endommagé (un des .xml) ... et dans ce cas la le pb se reproduit même sur une insta neuve.

C'est une version boite ou une carte ? ... sur le mien (version boite), il arrive que le jack d'alim pour le 5V de l'ESS fasse mauvais contact et ça le coupe en cours de route .. à vérifier si tu à la même version.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 21997
Points : 34700
Date d'inscription : 21/06/2009
Age : 58
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Ven 26 Nov 2021 - 17:38

Oui, fait une insta complète sur un autre PC pour voir, comme dis CNCSERV, si ça se trouve c'est ton fichier de config qui est endommagé (un des .xml) ... et dans ce cas la le pb se reproduit même sur une insta neuve.
Bonsoir David,
Je viens de faire le test sur un PC sous Windows XP pro. J'ai installé Mach3 (en reprenant le fichier d'installation du PC sous W7), le driver de l'ESS (en reprenant le fichier d'installation du PC sous W7) et j'ai changé l'adresse IP du PC, le problème est toujours le même !
Demain je ferai les essais avec ce PC en utilisant le port // sans utiliser la carte ESS pour vérifier que la machine fonctionne. Je n'ai jamais testé en me raccordant sur le port //, il y a des précautions particulières à prendre ?
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  Hervé-34 Ven 26 Nov 2021 - 20:21

Bonsoir !

Jean a écrit: Je n'ai jamais testé en me raccordant sur le port //, il y a des précautions particulières à prendre ?
A+
Jean47

Non, je ne crois pas, quand j'ouvre Mach3 et que je n'ai pas
mon USB100 de branché, il m’avertis 2ou 3 fois et après je pense
que Mach3 revient "par défaut" comme sur ma capture de Mach3

Hervé

Problème avec carte ESS Captur48
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3374
Points : 4471
Date d'inscription : 07/07/2014
Age : 70
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Sam 27 Nov 2021 - 10:40

Bonjour à tous,
Non, je ne crois pas, quand j'ouvre Mach3 et que je n'ai pas
mon USB100 de branché, il m’avertis 2ou 3 fois et après je pense
que Mach3 revient "par défaut" comme sur ma capture de Mach3

Je vais essayer d'être le plus clair possible !
Test avec le PC sous XP, Hervé, chez moi Mach3 n'a pas basculé sur le port // j'ai redémarré sur Mach3Mill pour voir, la connexion c’est faite mais surprise je ne suis pas sur l'écran en français mais sur un écran en anglais très sombre, pas d'onglets pour d'autres écran apparent scratch j'ai rechargé Mach3 comme déjà dis, ajouté les fichiers .xml et .set comme précédemment. Je relance Mach3 je retrouve le même écran. Sur une intuition, je débranche le port //, je rebranche l'ESS je lance Mach3 avec mon setup, je suis toujours sur l'écran anglais mais au miracle la carte ESS fonctionne correctement les leds vertes s'allument les leds des axes moteurs sont correctes.
Je refais les mêmes opérations sur le PC sous W7 le problème est toujours présent. Vous savez tous, je fais quoi maintenant ?
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Sam 27 Nov 2021 - 11:11

Complément d'information, bien entendu j'ai fais les choses vite et pour l'installation en français sous XP j'ai juste oublié de mettre le dossier Mach3fr (et tout son contenu) dans le dossier C:\Mach3\Bitmaps\, pancoops  je précise que j'ai récupéré ce fichier dans Mach3 du PC sous W7. Quand je lance Mach3 j'ai l'écran en français et tout fonctionne correctement, sous XP !  jesors
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  Hervé-34 Sam 27 Nov 2021 - 13:15

Bonjour !

Quand je lance Mach3 j'ai l'écran en français et tout fonctionne correctement, sous XP ! jesors
A+
Jean47

Donc pour l'instant sous XP tout va bien ?

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3374
Points : 4471
Date d'inscription : 07/07/2014
Age : 70
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Sam 27 Nov 2021 - 13:54

Donc pour l'instant sous XP tout va bien ?

Hervé

Oui, depuis mon dernier message, j'ai finalisé l'installation avec l'ajout de la manivelle hard et tous fonctionne parfaitement. Ce qui est quand même bizarre, j'ai systématiquement copié les fichiers du PC sous W7 pour installer le soft sur le PC XP. Le problème de soft ne vient donc pas à priori de tous ces fichiers copiés ! pourtant il y a bien un problème de soft...
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  Hervé-34 Sam 27 Nov 2021 - 14:11

Tu sais moi sur ma machine j'ai comme toi
un PC en XP, je n'ai pas d'ESS mais la même chose
un USB100 et bien parfois, impossible de connecter l'USB  !
Et bien il me faut changer de place le connecteur USB
sur un autre emplacement et là ça fonctionne !
ça m'arrive souvent !
Alors je me dit que peut-être ça vient du vieux PC mais ??
pas sur ??
Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3374
Points : 4471
Date d'inscription : 07/07/2014
Age : 70
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Sam 27 Nov 2021 - 14:25

Alors je me dit que peut-être ça vient du vieux PC mais ??

Non le problème est sur le PC W7 qui est relativement récent de plus le connecteur RJ45 est beaucoup moins fragile qu'un connecteur USB. Le problème est soft.
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  Hervé-34 Sam 27 Nov 2021 - 14:37

Ah je ne me souvenais pas que l'ESS était en rj45 !!
Mais alors ça viendrai d'où ? si sur le XP ça fonctionne ?

Hervé
Hervé-34
Hervé-34
complétement accro
complétement accro

Messages : 3374
Points : 4471
Date d'inscription : 07/07/2014
Age : 70
Localisation : 34390 Tarassac

Revenir en haut Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Sam 27 Nov 2021 - 14:56

J'attends les commentaires de David notre spécialiste de Mach3 pour en savoir plus et régler le problème sur W7. Le PC est un portable donc sauvegardé, j'ai un onduleur que je vais placer devant la partie électronique de la machine, ce qui permettra d'éliminer les micros coupures que j'ai ici, la partie puissance de la broche en cas de coupure déclenchera l'arrêt d'urgence.
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Problème avec carte ESS Empty Re: Problème avec carte ESS

Message  dh42 Sam 27 Nov 2021 - 16:28

Salut,

Bon et bien déjà l'ESS n'est pas grillé c'est déjà ça.

Si la config Mach3 et l'ESS fonctionne sur un PC et pas l'autre, il est possible alors que le plantage ai bien endommagé des fichiers, mais pas ceux de Mach3, c'est peut être Windows qui déconne ... ou la carte réseau ..

Après le plantage de ton W7, as tu fait une vérif des erreurs disque ? (bt de droite sur le disque C: > propriété > onglet Outils > verif des erreurs) ..

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 21997
Points : 34700
Date d'inscription : 21/06/2009
Age : 58
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Problème avec carte ESS Empty Problème avec carte ESS

Message  Jean47 Sam 27 Nov 2021 - 17:09

Bonjour David,
Bon et bien déjà l'ESS n'est pas grillé c'est déjà ça.
Oui ! c'est une très bonne nouvelle.  Very Happy
Après le plantage de ton W7, as tu fait une vérif des erreurs disque ?
Mon PC n'a jamais planté, comme déjà dis c'est un portable, pendant la coupure il est resté en fonctionnement, c'est juste Mach3 qui a planté car il n'avait plus la liaison avec l'ESS.
Je viens de faire un contrôle du disque, il n'a pas trouvé d'erreurs.
Windows qui déconne ... ou la carte réseau ..

j'ai aussi testé la connexion en me raccordant sur le réseau interne en changeant l'adresse IP tous fonctionne correctement. scratch
A+
Jean47
Jean47
Jean47
je prends du galon
je prends du galon

Messages : 64
Points : 74
Date d'inscription : 16/05/2021
Age : 69
Localisation : Houeillès 47

Revenir en haut Aller en bas

Page 1 sur 2 1, 2  Suivant

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum