Cambam ne veut pas joindre mes polylines

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  F1LQN le Lun 17 Oct 2016 - 20:44

Bonsoir David ,

Merci de votre message , qui m' a permis d'avancer.
J'ai été un peu long à répondre , je voulais faire tourner CAMBAM , pour d'éventuelles autres questions .
Pour le moment , je ne dessine pas avec CAMBAM , je l'utilise que pour la création du gcode , j'ai fait
plusieurs exemples que ce soit en contour, poche ou perçage , je m'en sors bien , c'est vrai qu'en plus des
différents tutos ou vidéos , c'est très bien expliqué , bravo pour ce que vous faites , merci.
Une question malgré tout , sur le plan de dégagement , qui n'empèche pas l'usinage , j'ai fait différentes
simulation sur MACH3 , c'est ok , alors j'y viens , dans générer le parcours de l'outil , je me suis aperçu que
quand j'ai un usinage avec contour et poche , je n'avais pas le dégagement qui s'affichait , par contre sur le
même usinage si je rajoute du perçage , le dégagement apparait ???? j'ai tourné ça dans tous les sens , je
n'ai rien trouver pour palier ce manque , les paramètres sont ok , je suis retourné sur une de vos vidéos
pour comparer , je n'ai rien trouvé d'anormal , ce n'est pas très important , car ça n'empêche pas de marcher
il y a t'il une explication .....
Ma machine n'est pas tout à fait terminée , des photos suivront .
Merci , cdlt
Alain dépt 44 .
Club aérien AIRBUS St Nazaire . Débutant dans le vol avions ultra léger et drone , y a pas d'age pour s'amuser lol....
avatar
F1LQN
petit nouveau
petit nouveau

Messages : 19
Points : 21
Date d'inscription : 15/02/2016
Age : 69
Localisation : 44560 Corsept

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  eric44 le Lun 17 Oct 2016 - 22:07

Vous remarquerez le nombre de pilotes présent sur ce forum
vive le faux rhum
@+
Eric
avatar
eric44
complétement accro
complétement accro

Messages : 800
Points : 1218
Date d'inscription : 04/08/2014
Age : 56
Localisation : Près de Nantes (44)

http://www.lamoricais.fr

Revenir en haut Aller en bas

Affichage des mouvements en rapide dans CamBam

Message  dh42 le Lun 17 Oct 2016 - 23:00

Salut,

Je pense que tu veux parler des parcours affichés en pointillés rouges qui matérialisent les mouvements en rapides ?



Il n'apparaissent que lors des déplacement en rapide à l'intérieur d'une même opération d'usinage, mais pas entre 2 opérations différentes.

ici par exemple, le cercle et l'éllipse sont dans la même op (Poche1) et on vois le déplacement entre les 2, même chose pour les 2 perçages, les 2 points sont dans l'op de perçage (en fait la liste de points est dans l'op, et il y a 2 pt dans la liste), mais on ne vois pas le déplacement entre le rectangle (contour1) et la première poche usinée (l'ellipse), ni entre la dernière (le cercle) et les perçages.

c'est simplement du au fait que les déplacements en rapide entre les op d'usinage ne sont pas calculés lors de la création des parcours d'outil, mais ils sont créés par le post-processeur au moment de la création du Gcode.

Si une fois le Gcode fait, on l'ouvre dans Cambam comme un fichier, ou via l’icône importer Gcode, on vois les rapides entre les op, on vois aussi les plongées en Z ; par exemple ici on vois bien que l'on descend en rapide dans un premier temps, puis en lent, ma hauteur de plongée en rapide étant réglée à 3mm.

on vois aussi les trajectoires latérales en vitesse d'usinage dans les poches, parfois utile quand on fait de la gravure pour s'assurer qu'il n'y a pas de "ponts" indésirables entre 2 opérations. (il y a par contre un petit bug d'affichage sur les rapides du perçage)

ici le fichier nc ouvert seul (comme un fichier .cb ordinaire) ; c'est juste un visualisateur.



++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13882
Points : 26616
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  F1LQN le Mer 19 Oct 2016 - 9:54

Hello David ,

Oui effectivement , il s'agit bien du parcours affiché en pointillé , merci pour ton explication , c'est clair .
J'ai testé également "répétitions d'usinages" excellent comme procédé , quand on a une série de pièces
identiques , Cambam est vraiment formidable , même pour le débutant que je suis , les débuts un peu
galère , mais on s'y fait très vite , je l'utilise que pour la création de gcode , le dessin sans doute plus
compliqué .
Ah une autre question , peut t'on changer d'outil lors d'un même usinage , c'est à dire en arrêtant la cnc
et reprendre avec par exemple une fraise différente , question peut être tordue , ma machine n'étant pas
une professionnelle .

Merci pour tout .

Bonne journée . Alain dépt 44.


avatar
F1LQN
petit nouveau
petit nouveau

Messages : 19
Points : 21
Date d'inscription : 15/02/2016
Age : 69
Localisation : 44560 Corsept

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  dh42 le Mer 19 Oct 2016 - 15:26

Salut,

Ah une autre question , peut t'on changer d'outil lors d'un même usinage , c'est à dire en arrêtant la cnc
et reprendre avec par exemple une fraise différente , question peut être tordue , ma machine n'étant pas
une professionnelle .

Si tu utilise Mach3, oui ; il suffit que le n° d'outil change entre 2 op d'usinage et CB sortira une instruction de changement d'outil.

http://www.metabricoleur.com/t7300p30-mes-usinages-problemes-rencontres#131714

++
David


_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13882
Points : 26616
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  F1LQN le Jeu 20 Oct 2016 - 8:40

Salut ,

Merci pour ta réponse , après avoir parcouru le lien pour le changement d'outils , j'ai mis tout ça en application
effectivement si on attribue bien les différents numéros d'outils , CAMBAM donne bien les instructions à MACH3
d'arrêter la CNC pour le changement ( témoin qui clignote ) mais une question en attire une autre , alors je me
pose cette question , si changement , il faut impérativement que ce nouvel outil soit réglé dans la broche à
l'identique pour la profondeur d'usinage , question con , existe t'il des outils avec des butées dans la broche afin
de respecter les paramètres d'usinage ? ou alors régler ces paramètres en fonction de ce nouvel outil AVANT de
créer le GCODE , sur CAMBAM depuis à peine un mois , ca trotte ici dans ma tête , pour toi évident lol....dans cet
excellent forum , je peux que constater que tu connais bien ton affaire , aucune question ne reste sans réponse
bravo David , cela doit faire des heureux comme moi , pour les débuts de CAMBAM .
Tes explications sont claires , mais costaudes malgré tout , faut suivre , ça va très vite , alors pour ne pas perdre
le fil , ici 2 PC , tes vidéos sur un , et j'applique sur l'autre , avec des arrêts sur image et des retours en arrière
pour bien saisir .

@+ , merci .

Alain dépt 44.
avatar
F1LQN
petit nouveau
petit nouveau

Messages : 19
Points : 21
Date d'inscription : 15/02/2016
Age : 69
Localisation : 44560 Corsept

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  manolo66 le Jeu 20 Oct 2016 - 18:00

Salut,
tu peux soit:
- utiliser des bagues http://www.ironwood-distribution.com/outils_fraisage/bagues_de_reperage-c-20_280.html à fixer sur tes fraises pour qu'elles soient toutes réglées à la même longueur
- ou créer plusieurs gcodes correspondant à chacun de tes outils, que tu règles avant de lancer le gcode.

A+
avatar
manolo66
posteur Régulier
posteur Régulier

Messages : 189
Points : 354
Date d'inscription : 09/02/2015
Age : 47
Localisation : Perpignan (66)

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  dh42 le Jeu 20 Oct 2016 - 18:47

Salut,

si changement , il faut impérativement que ce nouvel outil soit réglé dans la broche à l'identique pour la profondeur d'usinage

Oui bien sur, mais l'avantage de Mach3 par rapport à LinuxCNC, c'est qu'il n'est pas nécessaire de monter les outils tous à la même longueur, ni d'utiliser une table de longueur d'outil car il permet de déplacer les axes lors d'un changement d'outil, et surtout de refaire le 0 en Z avec le nouvel outil ; il suffit de refaire le 0 en Z après avoir changé l'outil, comme tu a fait pour le premier, et c'est tout Wink

http://www.metabricoleur.com/t401-cn-du-dessin-a-la-piece-debutants

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13882
Points : 26616
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  Uriel le Ven 24 Mar 2017 - 15:27

Bonjour à tous,

J'ai suivi vos conseils, et j'ai suivit d'autre conseils d'autres forums mais je suis navré, j'ai toujours le même problèmes, depuis des années en faits (du coup j'essayais autrement !).
Je travaille presque exclusivement avec Blender pour la modélisation 2D ou 3D.
Quelques fois, je fais des cercles, des courbes ou autres que j'exporte en DXF, pas de problèmes. Je les ouvre avec CAMBAM, je les transforme en polyline et les "Joins" pour former des lignes fermées.
Mais d'autres fois, ça ne marche pas, et j'ai beau les nettoyer (elles sont toujours bonne), supprimer les recouvrements (là ça me fait n'importe quoi) et "tout essayer" mais je n'arrive jamais à les joindre.
J'imagine qu'il y a un problème au niveau du recouvrement, mais je n'arrive pas à le traiter !
Voici mon dernier sujet.
(la "jointure" marche cependant avec la première version de CamBam 0.8 de 2007, mais bon, je ne peux pas faire ce que je veux comme avec ma 0.9 de 2015).
Voilà, merci beaucoup !!!
Uriel
Fichiers joints
Cercles.zip Vous n'avez pas la permission de télécharger les fichiers joints.(30 Ko) Téléchargé 4 fois


Dernière édition par Uriel le Ven 24 Mar 2017 - 15:30, édité 1 fois (Raison : oubli du fichier !!)
avatar
Uriel
petit nouveau
petit nouveau

Messages : 4
Points : 4
Date d'inscription : 24/03/2017
Age : 29
Localisation : Rhone-Alpes

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  dh42 le Ven 24 Mar 2017 - 18:15

Salut,

Je viens d'essayer, j'y suis plus ou moins arrivé, mais c'est vraiment acrobatique ; il y a une multitude de lignes qui se superposent (4 niveaux) sur les cercles externes, qui sont 'repliées' sur elles-mêmes et qui souvent sont 'fermées' ce qui empêche toute jointure.

- tout sélectionner - ctrl A
- convertir en polyligne - ctrl p
- créer nouveau calque
- tout sélectionner > polyligne/supp. recouvrement 0.05
- on supprime le calque source et on ne garde que le dernier ou on atterries les nouvelles polylignes.

apparemment seul le cercle du centre est OK, on le passe sur un autre calque et on masque le calque.

- ensuite sélection des polylignes qui restent ; on vois qu'elles on toutes le status fermée = vrai ; il faut le passer sur faux.

ensuite même principe:
- nouveau calque
- tout sélectionner > polyligne/supp. recouvrement 0.05
- on peut supprimer le calque source
- on sélectionne les nouvelles polyligne, on verifie qu'elle ne soit pas 'fermée' (c'est le cas sur cet essais), puis joindre.

la c'est mieux, je n'ai plus que 5 polylignes pour 2 cercles, et certaines sont fermées, et d'autres on des 'retour' à corriger manuellement.

A mon avis, il faut que tu te penche sur le pb coté Blender, car avec un DXF aussi "pourri" tu vas passer des heures à nettoyer tes dessins, et ce n'est pas vraiment fun, le résultat est pire que l'extraction de contour depuis un STL sur ce dessin en particulier.

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13882
Points : 26616
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  Uriel le Ven 24 Mar 2017 - 20:24

Merci beaucoup David,

C'est très aimable de t'être penché sur mon problème !!
Alors, j'ai suivi rigoureusement la procédure, mais je me demande si je n'ai pas zappé quelque chose puis que trouve un peu n'importe quoi dès la première suppression de recouvrements :
En images :

Ensuite, je supprime le calque de base et je passe la cercle en bas sur un autre calque. (Couper/Coller).
Je passe toutes les polylignes sur "Fermée : Faux".
Je recommence à supprimer les recouvrements, je supprime l'ancien calque, et voilà le nouveau :

Ensuite, les joindre les laisse dans l'état de l'image, ce qui est absolument inutilisable pour moi tongue

Je ne comprends pas pourquoi, les erreurs qui sont les mêmes, n'ont aucune incidence sur la version gratuite de 2007 !!

Mais oui, effectivement, si je pouvais créer un fichier "parfait" sous Blender, je préférerais en effet ! Et je ne me l'explique pas puisque deux cercles créés... Ha oui, tiens, ces cercles sont crée par l'outil "spin" qui est une révolution de vertices (donc les 5 points de base). Mais je les ai pourtant bien "mergés"... Mais oui tiens, je vais essayer de placer 5 cercles "classique" à ces places respectives. (Edit-> non, des cercles classiques ne rendent pas mieux... Je soupçonne le module d'exportation DXF...)

En tout cas merci, même si j'avoue que cette solution ne semble pas marcher, ou du moins pas de façon "automatique".

(Et je ne sais pas si c'est vous qui avez traduit CamBam en Français mais félicitation si c'est le cas, le menuisier de mon village à qui j'ai fabriqué une fraiseuse CNC sera ravi d'apprendre qu'il utilise la version française traduite par un gars qui habite à 80Km (et nettement moins à Vol d'oiseau !!)  Very Happy )
avatar
Uriel
petit nouveau
petit nouveau

Messages : 4
Points : 4
Date d'inscription : 24/03/2017
Age : 29
Localisation : Rhone-Alpes

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  Uriel le Ven 24 Mar 2017 - 20:46

Parade : en me mettant en vue XZ je tire des rectangle de sélection par niveau, par étage quoi, et le "joins" les polylignes -> aucuns problèmes !
ça ne résous pas le problème de fond mais sur cette forme ça marche puisque ce sont les niveaux qui posent problème à cette version logiciel.
avatar
Uriel
petit nouveau
petit nouveau

Messages : 4
Points : 4
Date d'inscription : 24/03/2017
Age : 29
Localisation : Rhone-Alpes

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  dh42 le Ven 24 Mar 2017 - 20:56

Re

Pour les lignes en zigzag sur Z, oui, j'ai vu après et j'ai oublié d'en parler ; tu peux utiliser ce plugin pour aplatir les polylignes et autres objets de dessin.

http://www.atelier-des-fougeres.fr/Cambam/Aide/Plugins/flattenFR.html

Je ne comprends pas pourquoi, les erreurs qui sont les mêmes, n'ont aucune incidence sur la version gratuite de 2007 !!

Probablement parce que le code à fortement évolué depuis 2007 .. et malheureusement, en programmation certaines améliorations sur un point provoquent d'autres problèmes sur un autre.

ceci-dit, ton DXF est vraiment problématique du fait de la spécificité du pb rencontré ; à savoir que les lignes existe en 4 exemplaires, mais qui se superposent exactement ; des essais que j'ai fait sur ton dessin, il semble que 'supprimer les recouvrements' marche sur 2 niveaux de lignes, il faut donc l'appliquer 2x pour arriver à réduire à un seul trait, par contre il y a des polylignes qui sont impossible à traiter quel que soit l'outil, même en manuel ; c'est un peu comme si la maillage de l'objet 3D avait été compressé en Z, ce qui donne des lignes repliées en accordéon.

En règle général, les soft qui travaillent en maillage ne donnent pas de bon résultats en exportation DXF, mais celui-la, il est costaud ! ; je ne connais pas Blender (enfin si, ... la version Amiga qui date de 1990 Very Happy ) et le seul soft travaillant en maillage que j'utilise, c'est 3DSmax, et il n'y a pas d'option permettant de faire une mise en plan exportable en DXF ; c'est carrément l'objet 3D qui est exporté en DXF et c'est la cata.

A tu essayé de sauver ta 3D en STL, d’ouvrir le STL sous CB et d'utiliser éditer/surfaces/détection des arrêtes pour en tirer tes contours 2D ?

Et je ne sais pas si c'est vous qui avez traduit CamBam en Français

Oui, c'est moi.

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13882
Points : 26616
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  dh42 le Ven 24 Mar 2017 - 21:08

Uriel a écrit:Parade : en me mettant en vue XZ je tire des rectangle de sélection par niveau, par étage quoi, et le "joins" les polylignes -> aucuns problèmes !
ça ne résous pas le problème de fond mais sur cette forme ça marche puisque ce sont les niveaux qui posent problème à cette version logiciel.

Ah oui, en fait ton DXF est en 3D, je n'avais pas vu, c'est ça le pb ; il faut sauver en DXF 2D si c'est possible dans Blender.

mais effectivement, en sélectionnant un seul niveau à la fois, et en joignant + insérer des arcs, ça va tout seul. (en fait tu peux supprimer 3 des 4 niveaux qui ne servent à rien)

note que certaines fonctions de CB aplatissent automatiquement les polylignes (insérer des arcs, par exemple)

++
David

_________________

Traduction Française de CamBam et de sa documentation.
avatar
dh42
Admin
Admin

Messages : 13882
Points : 26616
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: Cambam ne veut pas joindre mes polylines

Message  Uriel le Sam 25 Mar 2017 - 21:22

Merci David pour ces réponses.
Alors, merci pour le plugin, j'ai installé ça, heu, il faudra que je me fasse la main, merci ! Dans mon cas c'est finalement toujours plus compliqué que de me mettre en vue de face et sélectionner les 4 niveaux les uns après les autre pour les joindre.

D'ailleurs, j'ai réfléchis et le problème c'est que le soft ne fait pas ce qu'on lui demande, c'est tout. Si on lui met de joindre les points à moins de 0.01mm il n'a qu'à le faire en X/Y et Z, s'il va les joindre à 1mm (en Z ou autre), c'est que le code est à revoir. Même si mon maillage n'est pas "top" (pourtant il l'est avant sa conversion en DXF), c'est le soft qui semble bugger. Il écrase en Z, ce qui explique les accordéons, enfin si j'ai bien compris !
Je ne peux pas comparer Blender à d'autres soft, mais comme il est gratuit et super puissant, que je peux écrire des scripts en Python il est très recommandable. Je ne pourrais plus travailler sous Solidworks comme à l'école, parce que je "ne sais pas ce que je fais" alors que là, on a vraiment le contrôle de tout (mais c'est clairement plus long à apprendre ! Mais tellement plus de possibilités au final).
(EDIT : certes, Solidwoks est paramétrique en fait, ce n'est pas comparable, c'est vrai !)


Oui, j'ai essayé de sauver les lignes en STL : le fichier semble vide : 84 octets et rien quand on l'ouvre sous sous CamBam. On dirait que seule les "formes" acceptent d'être exportées en STL, avec des faces, parce que dès que je remplit un des cercle avec une face, alors celui-là uniquement apparait (et pas les autres cercles).

Un grand bravo pour la traduction !!
Uriel
avatar
Uriel
petit nouveau
petit nouveau

Messages : 4
Points : 4
Date d'inscription : 24/03/2017
Age : 29
Localisation : Rhone-Alpes

Revenir en haut Aller en bas

Page 2 sur 2 Précédent  1, 2

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum