problème de référencement des axes X et Y

Aller en bas

problème de référencement des axes X et Y Empty problème de référencement des axes X et Y

Message  silky le Jeu 7 Avr 2016 - 18:54

bonsoir
je constate un problème de référencement sous mach3
lorsque je lance le cycle de référencement, en manuel, l'axe Y démarre en premier et fait son cycle normalement, puis les axes X et Y démarrent en même temps et si je suis plus près du capteur de référencement du X les 2 chariots X et Y font leur cycle de référencement puis s'arrêtent en même temps, et si inversement je suis plus proche du Y les 2 axes font leur cycle de référencement et s'arrêtent aussi en même temps
le cycle se termine ainsi
il y a donc un axe qui ne fait pas son référencement correctement! (soit le X ou le Y en fonction de la configuration)
merci de votre aide
silky
silky
très actif
très actif

Messages : 375
Points : 489
Date d'inscription : 08/10/2013
Age : 64

Revenir en haut Aller en bas

problème de référencement des axes X et Y Empty Re: problème de référencement des axes X et Y

Message  Zarkann le Ven 8 Avr 2016 - 0:18

Bonsoir

Oui c'est étrange
Il faut peut être ajouter une fonction d'attente dans la routine genre:

Code:
While IsMoving()

@++ Eric

_________________
Cordialement         .::Zarkann::.  .::Administrateur et Fondateur MB::.


problème de référencement des axes X et Y Miniba10
Zarkann
Zarkann
Admin
Admin

Messages : 2034
Points : 3609
Date d'inscription : 06/12/2008
Age : 51
Localisation : St Sylvestre (87)

http://if-design.e-monsite.com/

Revenir en haut Aller en bas

problème de référencement des axes X et Y Empty Re: problème de référencement des axes X et Y

Message  silky le Ven 8 Avr 2016 - 12:25

bonjour
je ne comprends pas car cela fonctionnait auparavant!
par contre je ne me souviens plus si lors des référencements précédents les axes bougeaient simultanément ou indépendamment les uns des autres?
richard
silky
silky
très actif
très actif

Messages : 375
Points : 489
Date d'inscription : 08/10/2013
Age : 64

Revenir en haut Aller en bas

problème de référencement des axes X et Y Empty Re: problème de référencement des axes X et Y

Message  toutikini le Ven 8 Avr 2016 - 13:09

Bonjour,

ce que j'ai pu voir sur les prémisses de la mienne,
il semblerait que Z monte seul et ensuite X et Y en simultané .... et quand l'un des 2 est à zéro, le suivant poursuit ...

mais ça demande à être vérifié, car je ne l'ai constaté que sur l’écran ..

A+
toutikini
toutikini
complétement accro
complétement accro

Messages : 859
Points : 1652
Date d'inscription : 04/07/2011
Age : 49
Localisation : Poitiers (86)

Revenir en haut Aller en bas

problème de référencement des axes X et Y Empty Re: problème de référencement des axes X et Y

Message  silky le Ven 8 Avr 2016 - 16:07

j'ai refaits des essais, toujours pareil!
par contre j'ai voulu faire des déplacements en manuel en tapant G41 x100 par exemple, la machine ne se déplace pas de la valeur, ni pas toujours de la même valeur pourtant quand je me déplace en restant appuyé sur le bouton concerné et que je contrôle le déplacement d'après l'afficheur et en mesurant j'obtiens bien la bonne valeur!
et ce sur les 3 axes
bizarre!
richard
silky
silky
très actif
très actif

Messages : 375
Points : 489
Date d'inscription : 08/10/2013
Age : 64

Revenir en haut Aller en bas

problème de référencement des axes X et Y Empty Re: problème de référencement des axes X et Y

Message  Zarkann le Ven 8 Avr 2016 - 17:35

Bonjour

Tu n'entend pas de perte de pas ?

@++ Eric

_________________
Cordialement         .::Zarkann::.  .::Administrateur et Fondateur MB::.


problème de référencement des axes X et Y Miniba10
Zarkann
Zarkann
Admin
Admin

Messages : 2034
Points : 3609
Date d'inscription : 06/12/2008
Age : 51
Localisation : St Sylvestre (87)

http://if-design.e-monsite.com/

Revenir en haut Aller en bas

problème de référencement des axes X et Y Empty Re: problème de référencement des axes X et Y

Message  silky le Ven 8 Avr 2016 - 18:20

après avoir consulté différentes discussions sur le forum, je m'y suis remis et je me suis rendu compte que je faisais les référencements en mode manuel, je suis passé sur l'onglet automatique et cela fonctionne les 3 référencements se font correctement
pour les décalages je pense que j'ai trouvé après mes consultations sur le forum, je pensais que je me déplaçais de la valeur affichée par rapport à l'ancienne position mais en fait non, la valeur que l'on affiche est la valeur par rapport au "0" machine!
donc je pense que c'est bon!
désolé pour le dérangement et merci quand même,
il faut dire que je débute en programmation
je vais pouvoir passer à la suite
merci
richard
silky
silky
très actif
très actif

Messages : 375
Points : 489
Date d'inscription : 08/10/2013
Age : 64

Revenir en haut Aller en bas

problème de référencement des axes X et Y Empty Re: problème de référencement des axes X et Y

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum