LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  Alexis81 le Mar 3 Mar 2020 - 9:47

Bonjour,

Je vous explique mon problème, depuis quelques jours ma Cnc en cours d'usinage, me fait un décalage sur l'axe Y. Donc je me suis dis je dois avoir du jeu quelque part !!!

J'ai démonté la vis 1605, j'ai changé les roulements des extrémités de la vis, j'ai démonter la vis à bille, pour le nettoyer complètement, puis j'ai tout remonté. Après avoir mis le comparateur sur l'axe Y, si je fais ce bout de Code 50 fois :

G0 y5
G0 y0

Mon comparateur m'indique un décalage de -0,04. Si je relance le même bout de Code 50 fois de plus sans remettre le comparateur à 0, j'obtiens un décalage de -0,08, etc...

Avez-vous une idée pour régler ce problème ??? Cela une semaine que je suis dessus, j'ai beau modifier les vitesses de l'axe sur Linuxcnc, j'ai toujours le même problème.

Merci d'avance.

Alexis
Alexis81
Alexis81
posteur Régulier
posteur Régulier

Messages : 172
Points : 412
Date d'inscription : 01/08/2010
Age : 53
Localisation : LAVAUR

Revenir en haut Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty Re: LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  dh42 le Mar 3 Mar 2020 - 14:37

Salut,

J'ai modifié ton titre pour le rendre plus explicite Wink

A tu tenté de réduire l'accélération ?

Tu a pensé au serrage des coupleurs ? (glissement lors de la rotation)

si je ne me trompe pas, tu a pourtant des moteurs avec encodeurs et donc les pertes de pas devraient se rattraper automatiquement non ?  scratch

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19426
Points : 32127
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty Re: LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  Dagda le Mar 3 Mar 2020 - 15:21

DIY la machine ou indus?
Un truc a changé dans l'environnement de la machine dernièrement ?
Dagda
Dagda
acharné du forum
acharné du forum

Messages : 549
Points : 578
Date d'inscription : 18/02/2016
Age : 38
Localisation : Fontenay sous Bois

Revenir en haut Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty Re: LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  dh42 le Mar 3 Mar 2020 - 15:28

salut

C'est une 6040, mais j'ignore quel modèle.

http://www.metabricoleur.com/t18490-moteur-pap

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19426
Points : 32127
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty Re: LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  Dagda le Mar 3 Mar 2020 - 15:41

Tu n'as pas un faux contact quelque part ?
Regarde si des borniers ne se sont pas un peu dévissés ...
Mais si le problème est régulier, c'est pas forcément ça.

D.
Dagda
Dagda
acharné du forum
acharné du forum

Messages : 549
Points : 578
Date d'inscription : 18/02/2016
Age : 38
Localisation : Fontenay sous Bois

Revenir en haut Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty Re: LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  franck67530 le Mar 3 Mar 2020 - 16:03

et as tu essayer avec une vitesse differente que le G0 ?
franck67530
franck67530
acharné du forum
acharné du forum

Messages : 443
Points : 495
Date d'inscription : 21/09/2017
Age : 55
Localisation : alsace

Revenir en haut Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty Re: LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  Alexis81 le Mar 3 Mar 2020 - 21:04

Bon, ce soir j'ai resserré la liaison entre le moteur PAP et la vis sans fin, puis j'ai bougé sur un switch sur le moteur PAP Active Edge Setting, en fait lui dire si les commandes pour les pas arrivent sur un front haut ou bas..

J'ai un léger jeux quand je bouge la vis à la main... Faut-il que je change la vis ????

Je viens de faire des tests vite fait, cela semble aller mieux... Demain je ferais des tests plus poussés...

Voici une photo de la bête :

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Img_0810

Oui j'ai des moteurs PAP IHSS57 avec des encodeurs...

Voici la documentation des moteurs : https://webseite.sorotec.de/download/Technische-Daten/schrittmotor_datenblaetter/jmc_closed_loop/DS_iHSSXXen_181030Soro.pdf

Vous pouvez les trouver sur les sites chinois...
Alexis81
Alexis81
posteur Régulier
posteur Régulier

Messages : 172
Points : 412
Date d'inscription : 01/08/2010
Age : 53
Localisation : LAVAUR

Revenir en haut Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty Re: LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  nagut le Mar 3 Mar 2020 - 21:33

Si pilotée avec Mach3, il y a la fonction "Backlash" qui est très efficace
nagut
nagut
complétement accro
complétement accro

Messages : 1903
Points : 2145
Date d'inscription : 17/08/2010
Age : 69
Localisation : Haut Jura

Revenir en haut Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty Re: LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  Alexis81 le Mar 3 Mar 2020 - 21:35

Il y a la même chose sur Linuxcnc, mais vous faites comment pour le mesurer ?
Alexis81
Alexis81
posteur Régulier
posteur Régulier

Messages : 172
Points : 412
Date d'inscription : 01/08/2010
Age : 53
Localisation : LAVAUR

Revenir en haut Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty Re: LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  dh42 le Mar 3 Mar 2020 - 22:07

Salut,

J'ai un léger jeux quand je bouge la vis à la main... Faut-il que je change la vis ????

Le jeu, entre la vis et l'écrou à billes ou entre la vis et le montant du portique ? si entre la vis et le montant, c'est un problème de butée à billes en bout de vis (mal réglée)

Si c'est entre la vis et l'écrou, je ne sais pas trop, sur certains écrous le jeu peut se régler et si les billes sont usées on peut les remplacer par des billes un poil plus grosses, mais sur une VàB chinoise (si c'est toujours celle d'origine), à mon avis il vaut mieux changer

Il y a la même chose sur Linuxcnc, mais vous faites comment pour le mesurer ?

Avec un comparateur ; Assure toi que la vis est parfaitement fixe au niveau de sa butée, par exemple en la contraignant manuellement dans un sens (par exemple en la "tirant" vers la jambe du portique) ; met la touche du comparateur sur ton chariot X et fait un mouvement de vas et viens du chariot à la main ; si tu a un jeu dans l'écrou/vis, tu lira directement sa valeur sur le comparateur.

un exemple ici pour contrôler le jeu de la buté, et un peu plus loin celui de l'écrou (dans le bloc alu, mais c'est le même principe pour contrôler le jeu vis/écrou)
http://www.metabricoleur.com/t9776-entretien-cnc-bzt-pf750p#188392

ce qui me semble bizarre, c'est qu'un jeu, ça n'augmente pas avec le nombre d'aller/retour que tu fais faire à ton axe ; si tu à 0.02mm de jeu dans l'écrou/vis ou dans la vis/buté, tu devrais trouver 0.02 à chaque fois, que tu fasse un seul aller/retour ou 50 ; ce ne devrait pas être cumulatif .. un glissement du coupleur sur l'axe, par contre pourrait l'être (et bien sûr, des pertes de pas aussi)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19426
Points : 32127
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty Re: LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  F6FCO le Sam 21 Mar 2020 - 18:23

David à raison, moi je penserai plutôt à un mauvais paramétrage, un chiffre mal tapé après la virgule ou quelque chose de ce genre. Avec Stepconf tu devrais aller vérifier tes valeurs sur l'axe en question.
Après les vis à billes qui prennent du jeu çà arrive, je suis en train de donner. Je croyais avoir des vibrations à cause du moteur de broche et en fait c'est la noix X qui a pris du jeu (ou l'usure de la vis, difficile à savoir).
F6FCO
F6FCO
complétement accro
complétement accro

Messages : 3443
Points : 5675
Date d'inscription : 13/05/2011
Age : 66
Localisation : Aveyron de l'Ouest, Hi Haaaa !

http://f6fco.pagesperso-orange.fr/index.htm

Revenir en haut Aller en bas

LinuxCNc - Besoin de vos lumières (pertes de pas ?) Empty Re: LinuxCNc - Besoin de vos lumières (pertes de pas ?)

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum