Le Deal du moment : -28%
110€ de remise sur le Dyson Pure Hot+Cool ...
Voir le deal
289 €

[Résolu] CNC Makko : Mach3 commande à nouveau la broche

Page 1 sur 3 1, 2, 3  Suivant

Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 11:28

Bonjour
Plus moyen de faire démarrer la broche avec Mach3, manuellement (bouton marche/arrêt Mach3) ou avec un programme en gcode)
Ce n'est pas un problème de la CNC ou du contrôleur, en remettant la pulsebox Galaad, ça fonctionne.

Ca vient sans doute d'une erreur de paramétrage. Le W10 du PC d'usinage s'étant mis à faire des siennes (fenêtre peristante de demande d'ajouter un compte courrier, alors que le PC n'était pas relié au réseau), puis affichage de fenêtres de navigateur en cascade...), j'ai pris la voie radicale : réinstallation W10 (32bits)

Pour l'installation et le paramétrage de Mach3, je me suis appuyé sur des photos d'écran et surtout le fil de la mise en service de la Makko
http://www.metabricoleur.com/t18711p50-presentation-cnc-makko-m1070-su

Pour info, voici les paramètres auxquels j'ai touché :
Paramètre généraux
[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota17

Limites
[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota14

Ports Pins

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota13

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota10

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota11

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota12


Moteurs
[Résolu] CNC Makko : Mach3 commande à nouveau la broche Captur26
[Résolu] CNC Makko : Mach3 commande à nouveau la broche Captur27


Broche
[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota15

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota16


Les axes fonctionnent correctement, le référencement aussi, soft limits ok (après quelques tâtonnements, je n'avais pas sauvegardé le fichier Mach3.xml final ni les bonnes captures d'écran...)
Pour la broche, j'ai loupé un truc, c'est sûr...

Edit. Dans Port Pins, Motors output, j'ai bien coché Spindle enabled, contrairement à la photo...

Je viens aussi de tester un câble neuf : pas moieux


Dernière édition par Jivé le Sam 14 Nov 2020 - 16:39, édité 1 fois
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 15:16

Salut,

Il n'y a rien qui me saute aux yeux, la config me semble correcte scratch

Juste un truc sur la 1ière image, en haut à gauche, "ignore tool change" est coché, il faudrait cocher "Stop spindle ..." si tu veux que ça s'arrête sur une instruction de changement d'outil. (mais ça n'a rien à voir avec ton pb de broche)

tu n'entends pas le relais claquer sur la carte quand tu met la broche en marche ?

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 15:21

dh42 a écrit:
tu n'entends pas le relais claquer sur la carte quand tu met la broche en marche ?


Salut David

Comme quand on lance un programme et qu'on a oublié le variateur ? Lol
Plus sérieusement, ça ne fait pas ce petit claquement habituel quand je fais m/a sans le variateur allumé.
La "diode" rectangle de Mach3 se met en rouge.

Je viens d'essayer une calibration de broche : rien
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 16:04

La "diode" rectangle de Mach3 se met en rouge.

je ne vois pas de quelle diode tu parle.

Je viens d'essayer une calibration de broche : rien

Ah, ça y fallait pas, sans codeur sur la broche ça fout la m*** dans les vitesses.

Ferme Mach3, puis dans le dossier des macros, sous dossier avec le même nom que ta config, supprime "linearity.dat" et relance Mach3 pour réinitialiser le calibrage.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 16:11

Plus sérieusement, ça ne fait pas ce petit claquement habituel quand je fais m/a sans le variateur allumé.

Bizarre, pourtant tout semble OK pour le démarrage, Output#1 est sur pin 1 port 1 > OK et M3/M4 sont bien assignés à output#1 et le relais est actif ... (3ieme et avant dernière image)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 17:28

lineary.dat supprimé.

La "led", c'est celle de la broche dans l'écran Mach3 qui passe en rouge quand je clique sur le bouton Broche
[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota10

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota11


Pourrait-on tenter un truc pour éliminer les "gestes fous" ? Partir d'une installation nouvelle, sur un autre PC (portable, qui a déjà fonctionné avec la Makko) vierge de toute intervention et ne cocher que les paramètres utiles au démarrage de la broche ? Si ça marchait, je n'aurais plus qu'à rajouter les bons paramètres restants

Edit. Voilà, j'ai désinstallé Mach3, supprimé le dossier C:/Mach3 et installé la Mach3Version3.043_2018 de ce site
https://warp9td.com/index.php/sw/software-mach

Puis je suis allé sur le site CNCDrive télécharger l'exécutable d'installation de l'UC100.  UCx00setup.exe et réinstallé l'UNCC 100.
J'en suis là.
Je lance Mach3 et le "Reqset" reste cligotant, logique.
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 19:40

Re

Si le reset reste clignotant, c'est que le E-Stop n'est pas configuré.

faudrait voir aussi si tu a des réglages dans le plugin de l'UC100 ; je ne me souviens plus du tout s'il y en a.

La "led", c'est celle de la broche dans l'écran Mach3 qui passe en rouge quand je clique sur le bouton Broche

Ok, donc pour Mach3 ça veux dire que le M3 à bien été pris en compte (pas d'erreur de script)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 20:07

E-stop donc : enable, port 1, pin 11

Pour l'UC100, je suis allé sur le site
https://www.cncdrive.com/UC100.html

et j'ai téléchargé et lancé UCx00 automatic installer application for Mach3 and Mach4 qui installe le driver USB et le plugin adapté à l'UC100.
J'avoue que je n'ai pas lu le manuel  :-(

Edit. Avec le E-stop configuré, le Reset arrête de clignoter.
J'ai mis Spindle 17,0,1,1.
Quand je clique sur Spindle CWF5, le cartouche est entouré de jaune clignotant


Dernière édition par Jivé le Ven 13 Nov 2020 - 20:22, édité 1 fois
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 20:21

Il ne semble pas y avoir de réglage particulier sur le plugin de l'UC100, juste un moniteur permettant de voir quelles sont les pin activées.

pour les réglages du M/A broche, il n'y a pas grand chose ; le M3 sur Output#1 (en haut à gauche) et "disble spindle relay" décoché.

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota15

Output#1 activé et sur port 1 pin 1

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Annota13

en principe quand tu met la broche en marche, sur l'écran diagnostique output#1 doit clignoter. Sur le plugin de l'UC100 "1 out" devrait être allumé quand la broche est en marche. (image page 4 de la doc de l'UC100)

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 21:06

Paramétrage output1 fait

Quand je clique sur Spindle CWF5 :
- le cartouche est entouré de jaune clignotant
- dans diagnostics, output 1 clignote en rouge orangé
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 21:09

donc jusque la tout est normal ; vérifie si la led s'allume aussi dans le plugin de l'UC100 ; c'est peut être lui qui a un problème.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 21:17

Heu... comment on accède au plugin ?
J'ai parcouru le manuel, la diode verte est allumée en continu, signe de fonctionnement correct et la bleue aussi
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 21:19

menu plugin control

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 21:23

Voilà ce que ça donne
[Résolu] CNC Makko : Mach3 commande à nouveau la broche Captur14
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 21:26

si ça s’allume dans le plugin, reste à tester si l'UC100 commute bien la sortie 1

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Db25

avec un multimètre, calibre Volt Continu, pour mesurer du 5V ; met la touche noire sur une des pin de masse (GND) soit n'importe quelle pin entre 18 et 25 (ou la partie métallique de la prise) et la pin 1 de l'UC100 ; tu devrais trouver 5V broche en marche et 0V broche arrêtée.

(brochage page 7 de la doc de l'UC100)

++
David


Dernière édition par dh42 le Ven 13 Nov 2020 - 21:30, édité 1 fois

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 21:28

J'en ai profité aujourd'hui pour entr'ouvrir le contrôleur et mettre un coup de soufflette.
C'est pour ça que je me suis dépêché de tester avec Galaad et la Pulsebox quand j'ai découvert que la broche ne démarrait pas avec Mach3.
Si ça déclenche avec, ça doit le faire aussi avec l''UC100, non ?
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 21:31

Je débranche donc l'UC100 de la prise //
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 21:32

Si ça déclenche avec, ça doit le faire aussi avec l''UC100, non ?

Si ça marche avec Galaad, c'est que ta BoB et ton câble // sont OK.

Vu que les réglages sont OK sur Mach3, je ne vois plus qu'un problème au niveau de l'UC100 lui-même ..

Je débranche donc l'UC100 de la prise //

Oui

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 21:34

Le truc, c'est que Reset reste clignotant quand je débranche l'UC100 de la prise //.
Edit J'ai essayé aussi sur le PC fixe et c'est pareil
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 21:40

essai d'inverser le "Active low" dans la ligne E-Stop pour lui faire croire que l'AU est enlevé

ensuite on pourra aussi tenter d'utiliser le 2iem relais pour le M/A broche pour voir si il claque ou non.

++
David

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 21:42

Tenter de l'ouvrir ?
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 21:45

Non, vaut mieux pas, surtout s'il est tj sous garantie.

En regardant tes captures de l'écran principal, je vois que la vitesse de broche est à 0 (spindle speed) ; met 12000 et valide par entrée ; c'est peut être ça qui empêche la broche de démarrer ....

++
David


Dernière édition par dh42 le Ven 13 Nov 2020 - 21:57, édité 1 fois

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 21:48

bien vu, je teste
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Jivé le Ven 13 Nov 2020 - 22:03

Alors, j'ai 4.59 V en permanence, même quand e clique sur reset (AU clignotant))
Jivé
Jivé
complétement accro
complétement accro

Messages : 934
Points : 1864
Date d'inscription : 05/05/2010
Localisation : Languedoc Roussillon

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  dh42 le Ven 13 Nov 2020 - 22:07

Jivé a écrit:Alors, j'ai 4.59 V en permanence, même quand e clique sur reset (AU clignotant))

suis pas un expert en électronique ; tu est sûr que tu est bien entre 1 et 25 et pas entre 13 et 14 ?  (je ne me souviens jamais si on doit regarder la prise coté pin ou coté soudure pour les n° de broche)

mettre une V de rotation n'a rien changé ?

++
David


Dernière édition par dh42 le Ven 13 Nov 2020 - 22:21, édité 1 fois

_________________
Traduction Française de CamBam et de sa documentation.
dh42
dh42
Admin
Admin

Messages : 19738
Points : 32441
Date d'inscription : 21/06/2009
Age : 56
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

[Résolu] CNC Makko : Mach3 commande à nouveau la broche Empty Re: [Résolu] CNC Makko : Mach3 commande à nouveau la broche

Message  Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 3 1, 2, 3  Suivant

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum