MechMate Angevine

Page 1 sur 5 1, 2, 3, 4, 5  Suivant

Voir le sujet précédent Voir le sujet suivant Aller en bas

MechMate Angevine

Message  joscad49 le Sam 18 Avr 2015 - 8:20

athanase a écrit:C'est bon tout fonctionne maintenant !

Year ! cheers

J'ai recâblé le moteur X.

Avant:



J'ai déposer le câble pour lui trouver un autre passage, puis après j'ai soigné le montage en reconstituant la tresse de masse, un peu de gaine thermo.



Essais avec un panneau de mousse: carrés de 500X500, 400X400, 300X300, puis mes autres carrés des tests précédents.

Avec mon ancienne config pour le X ( carrés du bas) puis nouveau essai avec cette fois les mêmes valeurs pour tous les axes soit 127.xxxxx  (carrés du haut)


Résultat  nickel  Very Happy

Je vais pouvoir passer à mes premiers "vrai" usinages.
J'ai aussi bien avancé dans mon rail pour manipuler seul des panneaux, en plus c'est que de la récup !

A+ pour la suite

Bonjour a tous
Je suis nouveau sur ce forum et tres heureux de lire du français! Comme beaucoup j'ai pas mal galèré avec les forums en anglais...
Bravo pour toutes ces informations Athanase et quel courage de se rendre à l'atelier quand il fait bien froid.
J'ai réalisé une configuration similaire l'été dernier, tout d'abord tres heureux de réaliser diverses babioles, je me suis rendu compte que pour faire une pièce avec des côtes précises, ça le faisait pas
j'ai une erreur de 1,4mm en x pour une pièce de 290mm et 0,5 à 1mm sur Y pour 229mm pour exemple
mes moteurs sont reglés à 127,3562114

j'imagine à quel point le moral est remonté pour toi Athanase car on se demande bien à quoi va servir cette machine qui a représenté tant d'heures de travail si elle est fausse!

Est ce que ta solution a été uniquement le problème de blindage du câble ou as tu trouvé finalement autre chose?

Voici une photo de la bête


A bientôt et merci pour votre aide....j'ai besoin de retrouver le moral!

Joscad

joscad49
je prends du galon
je prends du galon

Messages : 53
Points : 157
Date d'inscription : 18/04/2015
Age : 58
Localisation : Angers

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  bob47 le Sam 18 Avr 2015 - 10:58

Bonjour

Pour joscad49

J’espère que tu t'est tromper dans les unités .  What a Face  What a Face  

Sa me parait énorme comme défaut.  guitou

BOB47

bob47
complétement accro
complétement accro

Messages : 1061
Points : 1735
Date d'inscription : 28/10/2011
Age : 59
Localisation : THONON

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  meles le Sam 18 Avr 2015 - 11:00

@joscad49


Merci de ne pas utiliser la fonction "JOINDRE UN FICHIER " pour poster une image.
Cette fonction stocke les images sur le forum qui à un espace de stockage limité, contrairement à SERVIMG.
Merci de lire ce TUTO qui explique comment poster une image et d'éditer le message incriminé pour corriger le problème, sans quoi nous devrons supprimer ces photos en pièces joints.

Merci de ta compréhension.

meles
Admin
Admin

Messages : 7185
Points : 13962
Date d'inscription : 13/05/2011
Age : 45
Localisation : Marseille

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  joscad49 le Sam 18 Avr 2015 - 12:34

Oui je trouve cela énorme et c'est ce qui m'inquiète

Cdt

Joscad

Ps/ a l'administrateur effectivement je comprends le problème de place, mais il serait bon de retirer la fonction joindre un fichier de fait si pas utilisable.

joscad49
je prends du galon
je prends du galon

Messages : 53
Points : 157
Date d'inscription : 18/04/2015
Age : 58
Localisation : Angers

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  meles le Sam 18 Avr 2015 - 14:38

joscad49 a écrit:Ps/ a l'administrateur effectivement je comprends le problème de place, mais il serait bon de retirer la fonction joindre un fichier de fait si pas utilisable.

Ça permet quand même de joindre de petits fichiers autres que des images (des plans sketchup ou  des pdf par exemple). c'est donc utilisable, mais pas pour des images !

@+

meles
Admin
Admin

Messages : 7185
Points : 13962
Date d'inscription : 13/05/2011
Age : 45
Localisation : Marseille

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  joscad49 le Sam 18 Avr 2015 - 14:58

ok parfait dès que je suis a la maison j'essaie de comprendre la procédure et change ma photo
Cdt
Joscad

joscad49
je prends du galon
je prends du galon

Messages : 53
Points : 157
Date d'inscription : 18/04/2015
Age : 58
Localisation : Angers

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  meles le Sam 18 Avr 2015 - 15:16

joscad49 a écrit:ok parfait dès que je suis a la maison j'essaie de comprendre la procédure et change ma photo
Cdt
Joscad

Pour celle ci, c'est fait ! Je te laisses potasser pour les suivantes Very Happy

@+

meles
Admin
Admin

Messages : 7185
Points : 13962
Date d'inscription : 13/05/2011
Age : 45
Localisation : Marseille

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  athanase le Sam 18 Avr 2015 - 20:42

Hello,

C'est clair l'erreur est assez importante...

As-tu vu si c'était proportionnelle aux déplacements ou assez aléatoire ?
As tu fait un réglage automatique des axes ?
As-tu les mêmes moteurs, pignons, réductions, crémaillère pour tous les axes ?

J'arrête mes questions et donne nous quelques infos, c'est quand même pas normal d'avoir des écarts pareils.

Après ça fait plaisir de voir des constructeurs Français de Mechmate qui osent communiquer Very Happy

A+
Denis


athanase
acharné du forum
acharné du forum

Messages : 508
Points : 1018
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  joscad49 le Lun 20 Avr 2015 - 16:05

athanase a écrit:Hello,

C'est clair l'erreur est assez importante...

As-tu vu si c'était proportionnelle aux déplacements ou assez aléatoire ?
As tu fait un réglage automatique des axes ?
As-tu les mêmes moteurs, pignons, réductions, crémaillère  pour tous les axes ?

J'arrête mes questions et donne nous quelques infos, c'est quand même pas normal d'avoir des écarts pareils.

Après ça fait plaisir de voir des constructeurs Français de Mechmate qui osent communiquer  Very Happy

A+
Denis


Bonjour

voila ce que je peux dire:

lorsque je verifie l'avance sous mach3, le déplacement est ok dans tous les sens les côtes sont bonnes avec l'assistant réglage auto des axes.

j'ai la même configuration pour tous les moteurs, idem la tienne denis
j'utilise un fichier provenance Vétric:
l'erreur est énorme donc si je lui donne une découpe avec des angles la forme est fausse ( erreur de 1,4mm sous X sur 300mm)
elle se répète en déplacement le zéro de démarrage comme si le fichier était mal interprêté et donc les côtes fausses sont reproduites à l'identique

lorsque j'utilise un assistant mach3 par exemple je demande une poche rectangulaire de 1000/50 la machine m'exécute de manière reproductible 1006/40, la l'erreur est encore bien pire sous Y

Je m'arrache les cheveux, je n'y comprends rien!

Merci de votre aide

José








joscad49
je prends du galon
je prends du galon

Messages : 53
Points : 157
Date d'inscription : 18/04/2015
Age : 58
Localisation : Angers

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  dh42 le Lun 20 Avr 2015 - 17:59

Salut,

Pour t'affranchir des erreurs pouvant être due à des pertes de pas, monte un stylo à la place de ta broche et essais le Gcode en pièce jointe.(pas d'effort de coupe, et V de déplacement faible -> 1000mm/min)

Il fait un simple carré de 500x500 mm (sans décalage outil). Mesure les dimensions du carré une fois tracé ; si c'est pas bon, c'est que tu a surement un problème de calibrage, si c'est bon, c'est que tu dois avoir des pertes de pas quand ça force .... ou que le ficher Gcode que tu utilise est faux.

PS, sur le Gcode, 0,0 dans l'angle inférieur gauche, 0 de la pointe du stylo à la surface de la feuille.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12402
Points : 25130
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  joscad49 le Lun 20 Avr 2015 - 18:39

Bonsoir Denis

cela me donne un carré d'équerre de dimension 505 axe crayon

peut etre pourrais tu m'envoyer une copie d'ecran de tes paramètres, peut être quelque chose me sautera aux yeux...

Je vais en plus verifer mes pignons mais j'y crois guère, ils viennent de tri distribution

Merci de ton aide spontanée

José

joscad49
je prends du galon
je prends du galon

Messages : 53
Points : 157
Date d'inscription : 18/04/2015
Age : 58
Localisation : Angers

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  dh42 le Lun 20 Avr 2015 - 18:54

Re

Il semble donc que tu ai un pb de calibrage sur tes axes.

Tu à 505 en X et en Y ?

peux tu me donner la valeur de step per (pas/mm) que tu a pour X et pour Y, je te calculerais de nouvelles valeurs.

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12402
Points : 25130
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  athanase le Lun 20 Avr 2015 - 18:57

Hello,

Bon c'est forcément un problème de paramétrage.

Pour vérifier tu peux aussi la faire se déplacer avec l'écran manuel en tapant directement un truc du genre G0 X100 mais le fichier que tu as de David fonctionne aussi très bien.

Je te scanne une copie de mes réglages moteur pour un Axe ce soir.


athanase
acharné du forum
acharné du forum

Messages : 508
Points : 1018
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  athanase le Lun 20 Avr 2015 - 19:10

J'ai trouvé le réglage pour le X en Pdf .
C'est la même chose pour les autres axes (sauf la vitesse/acc pour le Z)
Fichiers joints
MoteurX.pdf Vous n'avez pas la permission de télécharger les fichiers joints.(195 Ko) Téléchargé 5 fois

athanase
acharné du forum
acharné du forum

Messages : 508
Points : 1018
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  joscad49 le Lun 20 Avr 2015 - 20:30

dh42 a écrit:Re

Il semble donc que tu ai un pb de calibrage sur tes axes.

Tu à 505 en X et en Y ?

peux tu me donner la valeur de step per (pas/mm) que tu a pour X et pour Y, je te calculerais de nouvelles valeurs.

++
David

Bonsoir David

mes paramètres sur config moteurs oriental 296 version europe  X 4 pignons 36 dents et crémaillère modul 1

AXE x: pas par mm:127,3562114
vitesse 15540
Accélération 429,305
Y idem
Z plus lent


l'axe A est asservi sur X curieusement l'accélération n'est pas règlée idem( 250), cela me parait pas normal car dans ce cas la machine ne doit pas être réglée en équerrage lors du référencement.
Autant je suis à l'aise avec un poste de soudure ou un bout de bois, autant tout cela est compliqué pour moi et tellement impalpable
je vois que les réglage de Denis sont différents en vitesse
Ha oui ce qui m'interpelle aussi c'est pourquoi les réglages semblent bons lorsque je vérifie le déplacement à l'aide de l'assistant automatique...

A+

José

joscad49
je prends du galon
je prends du galon

Messages : 53
Points : 157
Date d'inscription : 18/04/2015
Age : 58
Localisation : Angers

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  dh42 le Lun 20 Avr 2015 - 20:38

j'ai besoin de savoir si tu avait 505 sur les 2 axes ou si la cote était différente.

pour tester la machine, une vitesse plus basse serait préférable, ça évite le risque de perte de pas.

met à 8000 au lieu de 15540 pour les tests (et n'oublie pas de sauver pour chaque axe) ; met les accélérations à 400 pour l'instant.

quand tu aura répondu à la première question, je pourrais te donner les correctif pour le pas/mm du X et du Y

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12402
Points : 25130
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  joscad49 le Lun 20 Avr 2015 - 20:57

David

Oui effectivement la côte obtenue est la même sur X et Y soit 505 mm

Mais sur d'autres fichiers essayés, j'avais plus d'erreur sur X que Y, ce qui me fait à priori écarter d'éventuels parasites c'est que si je déplace mon point 0 de travail, l'erreur à partir d'un fichier se reproduit à l'identique... Mes blindages sont normalement corrects

par contre la fréquence de travail est de 45khz

la longueur de cablerie est de 12M

Merci beaucoup de cette aide

José

joscad49
je prends du galon
je prends du galon

Messages : 53
Points : 157
Date d'inscription : 18/04/2015
Age : 58
Localisation : Angers

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  dh42 le Lun 20 Avr 2015 - 21:14

Il est tout à fait possible qu'il y ai 2 problèmes différents, c'est même très probable

- le calibrage ; à mon avis il est faux car le fichier que je t'ai donné ne fait pas de déplacement rapide (risque de perte de pas si trop rapide) et la vitesse d'usinage est suffisamment basse pour ne pas en faire non plus.

- Des pertes de pas, dues soit à une vitesse/accélération trop importante (le moteur décroche par manque de couple), soit à des parasites comme pour Denis. Il y a des chances qu'il y ai aussi ce problème, vu que tu a parfois des cotes loufoques.

essais déjà de régler ton pas/mm à 126.095 sur X et Y, l’accélération à 400mm/s² et la vitesse à 8000mm/min et refait le test du carré de 500

++
David

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12402
Points : 25130
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  athanase le Lun 20 Avr 2015 - 21:30

Ok merci pour les infos David Very Happy je vais modifier tout ça.

Moi je me souviens plus à quelle fréquence il tourne Mach3, je crois que c'est celle de base lors de l'installation. Avec une fréquence différente les paramètres seront différents non ?

David dans ton calcul, tu as tenu compte de la réduction car 126 c'est loin de 127 ? (sûrement, c'est juste pour faire celui qui y connaît Very Happy (En fait pas grand chose ) !! )

athanase
acharné du forum
acharné du forum

Messages : 508
Points : 1018
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  dh42 le Lun 20 Avr 2015 - 22:18

Re

Ok merci pour les infos David je vais modifier tout ça.

NON surtout pas, ces réglages ne sont pas pour toi, mais pour José ; ton pas/mm est juste puisque tu à les bonnes cotes ! ... on ne touche plus à rien quand ça marche nickel !

Moi je me souviens plus à quelle fréquence il tourne Mach3, je crois que c'est celle de base lors de l'installation. Avec une fréquence différente les paramètres seront différents non ?

Le changement de fréquence n'a pas d'autre utilité que de pouvoir sortir plus d’impulsion par seconde, mais en principe, il vaut mieux rester sur 25 Khz pour éviter que le PC ne puisse pas suivre (ce qui risque d'être le cas si c'est un vieux PC genre Athlon ou P4 = pertes de pas) , surtout avec des PàP, le nb d'impulsion/mm est faible par rapport à des servo ; avec 126 impulsions par/mm, même à 25Khz ça passe tranquille.

David dans ton calcul, tu as tenu compte de la réduction car 126 c'est loin de 127 ? (sûrement, c'est juste pour faire celui qui y connaît Very Happy (En fait pas grand chose ) !! )

Je n'ai pas du tout besoin de connaitre la réduction du moment que je connais la cote demandée, la cote atteinte et le pas/mm existant ; ce n'est qu'une règle de 3

Il est tout à fait possible qu'il y ai des disparités de pas entre tes crémaillères et celle de josé, donc normal que vous n'ayez pas exactement les mêmes valeur (ça ne fait jamais que 1% d'écart)

++
David
Fichiers joints
calculateur (afinage) steps_per.zip Vous n'avez pas la permission de télécharger les fichiers joints.(3 Ko) Téléchargé 5 fois

_________________

Traduction Française de CamBam et de sa documentation.

dh42
Admin
Admin

Messages : 12402
Points : 25130
Date d'inscription : 21/06/2009
Age : 53
Localisation : Près de St Etienne (42)

http://dh42.free.fr/

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  athanase le Mar 21 Avr 2015 - 7:52

Hello,

Ok merci pour les infos David Very Happy je vais modifier tout ça.

T'inquiète pas, je parlais des attaches pour mon poteau Very Happy

ce n'est qu'une règle de 3
Ah ben moi qui m'attendait à un calcul hyper scientifique...je suis déçu... Very Happy

Je ne vais surtout rien changé à mes réglages, Quand tout sera au top, faut que je pense à les sauvegarder.

Hâte de savoir si ces changements vont lui régler son problème, il a quand même une belle machine. (Pour la mienne il ne faut pas trop regarder les soudures....)

A+
Denis

athanase
acharné du forum
acharné du forum

Messages : 508
Points : 1018
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  joscad49 le Mar 21 Avr 2015 - 7:56

Bonjour David
Merci pour toutes ces infos
Si je réflêchis( avec ma petite tête) à tous ça; vu que j'ai la bonne avance lorsque je vérifie avec l'assistant qui génère un déplacement tres lent et qu'il y a un problème lorsque j'usine une pièce, c'est qu'il y a perte de pas. Sauf erreur donc lorsqu il y a perte de pas la machine surcôte la piece. Elle ne peux sous côter, est ce bien cela?

je vais vérifier cela en appliquant les modifs dans l'après midi.

j'ai remarqué que par rapport à Denis mon délai de direction est différent( 1) et impulsion pas (7)...

A bientôt

José


joscad49
je prends du galon
je prends du galon

Messages : 53
Points : 157
Date d'inscription : 18/04/2015
Age : 58
Localisation : Angers

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  joscad49 le Mar 21 Avr 2015 - 8:14

Salut Denis,
Merci du compliment, cela fait toujour plaisir, comme tu le sais c'est un peu de travail tout ça, mais tu sais elle a des défauts, le plus gros est d'être inutilisable pour l'instant. J'avais pourtant fais déplacer M Dubois( mach3fr) qui est un garçon super sympa et pas avare de son temps. Il avait vérifié pas mal de choses puis nous avions fait des objets style sculpture 3D et nous sommes passés à côté de ces problèmes de côte ( du fait que les côtes étaient bonnes avec l'assistant)

David pourrais tu me répondre sur la configuration de l'axe A( deuxième moteur de X), actuellement il est juste asservi à X donc comment faire pour qu'il puisse avoir son propre référencement? D'après ce que j'ai cru comprendre c'est important pour l'équerrage du fait d'un portique de 2,20m

Comment est configurée ta machine la dessus, Denis, as tu également quatre moteurs?

A++

José

joscad49
je prends du galon
je prends du galon

Messages : 53
Points : 157
Date d'inscription : 18/04/2015
Age : 58
Localisation : Angers

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  athanase le Mar 21 Avr 2015 - 8:26

Hello José,

J'ai bien 4 moteurs et un seul capteur inductif pour le référencement du portique (Y).
Il faut relire mon post, car j'avais eu des problèmes pour mon référencement et de mémoire je fais référencer qu'un seul coté (moteur) et je ne crois pas avoir eu des problèmes d'équerrages trop important ceci étant pour de la menuiserie. David m'avait bricolé un truc, en fait modifié la macro associé au bouton sur l'écran Mach3. Je m'en souviens plus trop...ça doit être vers le début. Si tu ne trouves pas je rechercherais à midi.



athanase
acharné du forum
acharné du forum

Messages : 508
Points : 1018
Date d'inscription : 10/01/2014
Age : 46

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  joscad49 le Mar 21 Avr 2015 - 8:41

Denis

Dans mon cas j'ai deux capteurs inductifs sur X et compte tenu de la largeur, on note bien une tendance à un léger faux equerrage lors du référencement sur 3 capteurs uniquement. car il suffit qu'il y est eu un problème avant qui du coup n'est pas rectifié dans ce cas lors du référencement.

Je regarderai plus en détail tes nombreux messages en fin d'apm

Bonne journée
José

joscad49
je prends du galon
je prends du galon

Messages : 53
Points : 157
Date d'inscription : 18/04/2015
Age : 58
Localisation : Angers

Revenir en haut Aller en bas

Re: MechMate Angevine

Message  Contenu sponsorisé Aujourd'hui à 16:42


Contenu sponsorisé


Revenir en haut Aller en bas

Page 1 sur 5 1, 2, 3, 4, 5  Suivant

Voir le sujet précédent Voir le sujet suivant Revenir en haut

- Sujets similaires

 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum